Bug 575292 - Crash on NULL TYPE_FIELD_TYPE
Summary: Crash on NULL TYPE_FIELD_TYPE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f833c7548c5da5e598283cbcbce...
: 580809 580817 583970 584732 (view as bug list)
Depends On: 585445
Blocks: 592016
TreeView+ depends on / blocked
 
Reported: 2010-03-19 22:07 UTC by Gabriel PREDA
Modified: 2010-06-30 15:09 UTC (History)
10 users (show)

Fixed In Version: gdb-7.1-27.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 592016 (view as bug list)
Environment:
Last Closed: 2010-04-28 01:12:59 UTC


Attachments (Terms of Use)
File: backtrace (12.28 KB, text/plain)
2010-03-19 22:07 UTC, Gabriel PREDA
no flags Details


Links
System ID Priority Status Summary Last Updated
Sourceware 11465 None None None Never

Description Gabriel PREDA 2010-03-19 22:07:51 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gdb -batch -ex 'set debug-file-directory /usr/lib/debug:/var/cache/abrt-di/usr/lib/debug' -ex 'file /usr/bin/rhythmbox' -ex 'core-file /var/cache/abrt/ccpp-1269035382-2229/coredump' -ex 'thread apply all backtrace 2048 full' -ex 'info sharedlib' -ex 'print (char*)__abort_msg' -ex 'print (char*)__glib_assert_msg'
component: gdb
executable: /usr/bin/gdb
kernel: 2.6.33-1.fc13.x86_64
package: gdb-7.0.50.20100203-15.fc13
rating: 4
reason: Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Rawhide)

Comment 1 Gabriel PREDA 2010-03-19 22:07:54 UTC
Created attachment 401357 [details]
File: backtrace

Comment 2 Benjamin Otte 2010-04-01 13:54:39 UTC

How to reproduce
-----
1. Run an epiphany with custom-compiled libraries
2. Wait until it crashes
3. Start abrt
4. Click on "report"
5. Wait a bit
6. *boom*

Comment 3 Jan Kratochvil 2010-04-01 14:09:36 UTC
or:
webkitgtk-debuginfo-1.1.22-1.fc13.x86_64
gdb -nx -readnow /usr/lib/debug/usr/lib64/libwebkit-1.0.so.2.16.0.debug
or:
cat <<HERE | g++ -c -o x.o -g -x c++ -; gdb -nx -readnow ./x.o
namespace N {
  class C {
  public:
    typedef void (*t) (C);
    void m (t);
  };
  typedef C::t u;
};
N::u f;
HERE

On FSF GDB HEAD the problem gets masked (producing invalid results but not crashing) and to get a crash one has to revert:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/dwarf2read.c.diff?cvsroot=src&r1=1.376&r2=1.377

It is due to dwarf2_physname() accessing unfinished types being read-in, dwarf2_physname() is by Keith Seitz, it is not in FSF gdb-7.1 but it is in HEAD.

Comment 4 Jan Kratochvil 2010-04-11 21:44:42 UTC
*** Bug 580817 has been marked as a duplicate of this bug. ***

Comment 5 Jan Kratochvil 2010-04-11 21:45:32 UTC
*** Bug 580809 has been marked as a duplicate of this bug. ***

Comment 6 Jan Kratochvil 2010-04-21 09:50:02 UTC
*** Bug 583970 has been marked as a duplicate of this bug. ***

Comment 7 Jan Kratochvil 2010-04-22 10:12:53 UTC
*** Bug 584732 has been marked as a duplicate of this bug. ***

Comment 8 Jan Kratochvil 2010-04-22 16:49:18 UTC
Post upstream by Keith Seitz:
[RFA] Delayed physname computation
http://sourceware.org/ml/gdb-patches/2010-04/msg00641.html

Comment 9 Fedora Update System 2010-04-22 17:42:38 UTC
gdb-7.1-14.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdb-7.1-14.fc13

Comment 10 Fedora Update System 2010-04-23 06:03:01 UTC
gdb-7.1-14.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gdb-7.1-14.fc13

Comment 11 Fabien Archambault 2010-04-26 12:30:29 UTC
Hello,

I do not know exactly if this problem is fixed. I explain:
When this bug was present I got this bug : https://bugzilla.redhat.com/show_bug.cgi?id=584733
The abrt tool was shown everytime the crash appeared.

With the installation of the new gdb I was able to send a report (a few minutes ago) with the download of the needed debuginfo. But now I reproduce the bug (#584733) and no abrt is shown.

If needed I can open another report but it seems to be related.

Comment 12 Jan Kratochvil 2010-04-26 12:39:04 UTC
Hi Fabien Archambault,
thanks for the notice - this bug is now back ASSIGNED.
Fix of this crash Bug 575292 has caused crash Bug 585445.
Reverted now the fix causing crash Bug 585445 but thus the crash Bug 575292 is back.
It may be best to temporarily import
http://sourceware.org/ml/gdb-patches/2010-03/msg01039.html
which produces wrong result in some rare cases but it does not crash.
Going to ask today Keith Seitz if a fix for both this Bug 575292 and the related Bug 585445 is available and otherwise going to provide the workaround in the meantime.
Thanks.

Comment 13 Jan Kratochvil 2010-04-27 11:44:04 UTC
Put there now the workaround to no longer crash.

Comment 14 Fedora Update System 2010-04-27 11:51:06 UTC
gdb-7.1-16.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdb-7.1-16.fc13

Comment 15 Fedora Update System 2010-04-28 01:12:54 UTC
gdb-7.1-16.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-05-13 17:37:39 UTC
gdb-7.1-20.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdb-7.1-20.fc13

Comment 17 Fedora Update System 2010-05-15 20:16:26 UTC
gdb-7.1-20.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-06-29 23:53:04 UTC
gdb-7.1-27.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdb-7.1-27.fc13

Comment 19 Fedora Update System 2010-06-30 15:09:17 UTC
gdb-7.1-27.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.