Bug 575533 - supertux-0.3.3 is available
supertux-0.3.3 is available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: supertux (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-21 07:17 EDT by Upstream Release Monitoring
Modified: 2010-12-08 06:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-08 06:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed spec file for 0.3.3. (5.30 KB, text/plain)
2010-04-02 09:59 EDT, Nils Philippsen
no flags Details
patch to use system squirrel libs, not own copy (3.56 KB, patch)
2010-04-02 10:02 EDT, Nils Philippsen
no flags Details | Diff
Patch to use standard directories (881 bytes, patch)
2010-04-02 10:04 EDT, Nils Philippsen
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2010-03-21 07:17:08 EDT
Latest upstream release: 0.3.3
Current version in Fedora Rawhide: 0.3.1
URL: http://supertux.lethargik.org/download.html

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 Nils Philippsen 2010-04-02 09:59:07 EDT
Created attachment 404185 [details]
Proposed spec file for 0.3.3.

I've built 0.3.3 with this spec file. I removed all the old, seemingly obsolete patches for it and added two new ones which I'll attach here as well. I made a scratch build here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2091119

So far it works well here.
Comment 2 Nils Philippsen 2010-04-02 10:02:24 EDT
Created attachment 404186 [details]
patch to use system squirrel libs, not own copy

This patch makes SuperTux use the packaged squirrel libraries, instead of its own copy. SuperTux 0.3.3 contains some other external libraries and links these statically, but these aren't packaged for Fedora (I'm not sure if they're intended to be packages as separate dynamic libraries anyway).
Comment 3 Nils Philippsen 2010-04-02 10:04:39 EDT
Created attachment 404187 [details]
Patch to use standard directories

This patch places the supertux binary in /usr/bin (not/usr/games) and its data files in /usr/share/supertux (not /usr/share/games/supertux).
Comment 4 Matt McCutchen 2010-04-14 03:26:05 EDT
I notice that SuperTux 0.3.3 was built for rawhide with changes based on those in comments 1-3:

https://koji.fedoraproject.org/koji/buildinfo?buildID=165815

I entered bug 579639 to specifically track the unbundling of Squirrel.  All of the currently outstanding abrt bugs (bug 581156, bug 574243, bug 544296, bug 572089) are fixed in 0.3.3.
Comment 5 Hans de Goede 2010-12-08 06:07:35 EST
(In reply to comment #4)
> I notice that SuperTux 0.3.3 was built for rawhide with changes based on those
> in comments 1-3:
> 
> https://koji.fedoraproject.org/koji/buildinfo?buildID=165815
> 
> I entered bug 579639 to specifically track the unbundling of Squirrel.  All of
> the currently outstanding abrt bugs (bug 581156, bug 574243, bug 544296, bug
> 572089) are fixed in 0.3.3.

Right, I somehow mist this bug when rebasing supertux, sorry about that.
0.3.3 is in Fedora 14 and later, closing.

Note You need to log in before you can comment on or make changes to this bug.