This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 579639 - SuperTux bundles Squirrel
SuperTux bundles Squirrel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: supertux (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2010-04-06 01:57 EDT by Matt McCutchen
Modified: 2010-04-15 03:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: supertux-0.3.3-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-15 03:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SuperTux changes to squirrel (3.87 KB, patch)
2010-04-15 02:13 EDT, Matt McCutchen
no flags Details | Diff

  None (edit)
Description Matt McCutchen 2010-04-06 01:57:44 EDT
Description of problem:
SuperTux bundles a Squirrel interpreter.  It shouldn't.

https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries

Version-Release number of selected component (if applicable):
supertux-0.3.1-9.fc12

Steps to Reproduce:
yumdownloader --source supertux
rpmdev-extract supertux-*.src.rpm
tar -tvf supertux-*.src/supertux-*.tar* | grep squirrel/
Comment 1 Matt McCutchen 2010-04-06 01:58:28 EDT
It looks like this may be addressed along with bug 575533.
Comment 2 Dan Horák 2010-04-06 02:34:49 EDT
Please check if this is an unmodified copy of squirrel, people quite often make API incompatible improvements to squirrel.
Comment 3 Matt McCutchen 2010-04-14 03:17:07 EDT
The modifications are unimportant.  It looks like SuperTux was successfully built against the system Squirrel:

https://koji.fedoraproject.org/koji/buildinfo?buildID=165815
Comment 4 Dan Horák 2010-04-14 05:49:12 EDT
(In reply to comment #3)
> The modifications are unimportant.  It looks like SuperTux was successfully
> built against the system Squirrel:

Can you post the diff somewhere?
Comment 5 Matt McCutchen 2010-04-15 02:13:36 EDT
Created attachment 406681 [details]
SuperTux changes to squirrel

Here is the diff.  It consists of two changes.

- Adding a missing const.  Accepted upstream, but there is no publicly viewable repository (ugh):
http://squirrel-lang.org/forums/thread/3632.aspx

- A change to word size determination that was proposed upstream but got no response:
http://squirrel-lang.org/forums/thread/3633.aspx
Comment 6 Dan Horák 2010-04-15 03:31:15 EDT
Thanks, they looks harmless. Closing because the rawhide package already uses system squirrel.

Note You need to log in before you can comment on or make changes to this bug.