Bug 57571 - pygtk threads disabled (gnome-python-1.4.1-3.src.rpm has a bad patch)
Summary: pygtk threads disabled (gnome-python-1.4.1-3.src.rpm has a bad patch)
Status: CLOSED DUPLICATE of bug 43317
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-python   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL: http://www.daa.com.au/pipermail/pygtk...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-16 07:51 UTC by F. Duncan M. Haldane
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 16:59:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description F. Duncan M. Haldane 2001-12-16 07:51:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.16 i686)

Description of problem:
The  patch  gnome-python-1.4.1-disablethreads.patch  is malformed and
completely disables
threads in pygtk (it was only supposed to  disable them if an enviroment
variable is set,  but
is incorrectly written....)  all  pygtk applications that use threads are
completely broken in RH7.2 :(

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run any threads-based gtk application.
2.(see the pygtk mailing list referenced above)
3.
	

Actual Results:  application hangs.

Expected Results:  should not hang.  Worls fine if pygtk is downgraded to
the version
that came with RedHat 7.1, rebuilt on RH 7.2,

Additional info:

Comment 1 Matt Wilson 2002-04-05 16:59:00 UTC
this is fixed in my 1.4.2 (0.6.9) package.

Comment 2 Matt Wilson 2002-04-15 22:24:21 UTC

*** This bug has been marked as a duplicate of 43317 ***


Note You need to log in before you can comment on or make changes to this bug.