This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 576082 - Words did not translate in F13 beta during install
Words did not translate in F13 beta during install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-23 04:09 EDT by Liam Li
Modified: 2014-09-30 19:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.37-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 00:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pic1 (81.63 KB, image/png)
2010-03-23 04:09 EDT, Liam Li
no flags Details
pic2 (74.18 KB, image/png)
2010-03-23 04:10 EDT, Liam Li
no flags Details
pic3 (91.73 KB, image/png)
2010-03-23 04:11 EDT, Liam Li
no flags Details
pic4 (166.14 KB, image/png)
2010-03-23 04:11 EDT, Liam Li
no flags Details
pic5 (68.89 KB, image/png)
2010-03-23 04:12 EDT, Liam Li
no flags Details
zh-en1 (32.74 KB, image/png)
2010-05-13 03:34 EDT, Liam Li
no flags Details
zh-en2 (40.33 KB, image/png)
2010-05-13 03:35 EDT, Liam Li
no flags Details
zh-en3 (18.05 KB, image/png)
2010-05-13 03:36 EDT, Liam Li
no flags Details
zh-cn4 (69.67 KB, image/png)
2010-05-13 03:36 EDT, Liam Li
no flags Details
Zh-Cn6 (20.64 KB, image/png)
2010-05-13 03:37 EDT, Liam Li
no flags Details

  None (edit)
Description Liam Li 2010-03-23 04:09:56 EDT
Created attachment 401955 [details]
pic1

Description of problem:
During install, select Chinese, continue the install, lots of words are English, not Chinese. please see attached pic 

Version-Release number of selected component (if applicable):
anaconda 13.36

How reproducible:

100%
Comment 1 Liam Li 2010-03-23 04:10:45 EDT
Created attachment 401956 [details]
pic2
Comment 2 Liam Li 2010-03-23 04:11:15 EDT
Created attachment 401957 [details]
pic3
Comment 3 Liam Li 2010-03-23 04:11:45 EDT
Created attachment 401958 [details]
pic4
Comment 4 Liam Li 2010-03-23 04:12:12 EDT
Created attachment 401959 [details]
pic5
Comment 5 Ales Kozumplik 2010-03-25 11:04:33 EDT
In anaconda this is fixed by:
db7cafaa3bd099d0af0e6ec4c358614f7d269765
and
1dde2abacfdb00023de8e2a73f8ea758d3a56be4

Note that the former commit merely enables several strings for translation so only English texts will be visible until new translations are available.

Ales
Comment 6 Ales Kozumplik 2010-03-25 11:06:16 EDT
Additionally,

the fix of this bug depends on the bug 571940.

Ales
Comment 7 Fedora Update System 2010-03-26 23:26:19 EDT
anaconda-13.37-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.37-1.fc13
Comment 8 Fedora Update System 2010-03-27 00:53:04 EDT
anaconda-13.37-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Liam Li 2010-05-13 03:31:50 EDT
This issue still did not fix on F13-final-RC3, we can see that the button is Chinese, but the pages conclude some English characters
Comment 10 Liam Li 2010-05-13 03:34:30 EDT
Created attachment 413660 [details]
zh-en1

These are some pages I got during install.
Comment 11 Liam Li 2010-05-13 03:35:01 EDT
Created attachment 413661 [details]
zh-en2

These are some pages I got during install.
Comment 12 Liam Li 2010-05-13 03:36:02 EDT
Created attachment 413662 [details]
zh-en3

These are some pages I got during install.
Comment 13 Liam Li 2010-05-13 03:36:47 EDT
Created attachment 413663 [details]
zh-cn4

These are some pages I got during install.
Comment 14 Liam Li 2010-05-13 03:37:17 EDT
Created attachment 413664 [details]
Zh-Cn6

These are some pages I got during install.
Comment 15 Ales Kozumplik 2010-05-13 05:14:35 EDT
Hi Liam,

some translations are missing because the outdated .po file (the one where translators put translations of the original languages into the target language). The latest version of the Chinese translation is from the March 17 and the Taiwanese one from 23rd September 2009!

The translators simply need to pick up the latest .pot version and translate the missing texts. All of this is handled through Transifex: https://translate.fedoraproject.org/projects/p/anaconda/c/f13-branch/ 

Note that it's too late for the  f13 translations now.

Ales

Note You need to log in before you can comment on or make changes to this bug.