Bug 576110 - Screen button displayed badly in rescue mode
Summary: Screen button displayed badly in rescue mode
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstaidkit
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Sivák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 576107 576108 576109 (view as bug list)
Depends On:
Blocks: F13Target
TreeView+ depends on / blocked
 
Reported: 2010-03-23 09:32 UTC by He Rui
Modified: 2010-03-30 11:08 UTC (History)
6 users (show)

Fixed In Version: firstaidkit-0.2.11.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 11:08:50 UTC
Type: ---


Attachments (Terms of Use)
bad rescue screen (34.19 KB, image/png)
2010-03-23 09:33 UTC, He Rui
no flags Details

Description He Rui 2010-03-23 09:32:48 UTC
Description of problem:

please refer to the attachment. the 'ok' and 'cancel' button are badly displayed in rescue screen.

Version-Release number of selected component (if applicable):
anaconda 13.36
Fedora 13 beta tc1

How reproducible:
100%

Steps to Reproduce:
1. choose resue mode

Comment 1 He Rui 2010-03-23 09:33:29 UTC
Created attachment 401981 [details]
bad rescue screen

Comment 2 Chris Lumens 2010-03-23 14:03:30 UTC
*** Bug 576107 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2010-03-23 14:03:35 UTC
*** Bug 576108 has been marked as a duplicate of this bug. ***

Comment 4 Chris Lumens 2010-03-23 14:03:41 UTC
*** Bug 576109 has been marked as a duplicate of this bug. ***

Comment 5 Martin Sivák 2010-03-23 14:23:04 UTC
This is standard whiptail button, if it should look different (as it is using  the same newt library as anaconda does) it has to be fixed in newt itself.

The dialog was constructed using /usr/bin/firstaidkit-qs script from firstaidkit which calls:

whiptail --menu "First Aid Kit quickstart menu" "18" "45" "10" shell "Start shell" fakd "Run diagnostic" reboot "Reboot"

And I'm reassigning this to newt.

Comment 6 Miroslav Lichvar 2010-03-29 11:06:35 UTC
What exactly is wrong with the buttons? Seem ok to me in the screenshot.

Comment 7 He Rui 2010-03-30 01:15:57 UTC
I was hoping the <Ok> and <Cancel> button could have red background as the other screens do in anaconda. But I'm OK with this current one.

Comment 8 Miroslav Lichvar 2010-03-30 10:48:22 UTC
whiptail has --fb option which can be used to draw full sized buttons. Would it be better?

Comment 9 Martin Sivák 2010-03-30 10:56:28 UTC
Ah I didn't know that, thanks for tip, I will change it in firstaidkit.


Note You need to log in before you can comment on or make changes to this bug.