Bug 576429 - cannot set arhln using arptables mangle options
Summary: cannot set arhln using arptables mangle options
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: arptables_jf
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jiri Skala
QA Contact: Aleš Mareček
URL:
Whiteboard:
Keywords: Patch, Reopened
Depends On:
Blocks: 807315 906355 1030508
TreeView+ depends on / blocked
 
Reported: 2010-03-24 01:29 UTC by Hushan Jia
Modified: 2014-11-09 22:32 UTC (History)
3 users (show)

(edit)
Clone Of:
: 807315 906355 1030508 (view as bug list)
(edit)
Last Closed: 2011-11-28 13:57:49 UTC


Attachments (Terms of Use)
The patch fixes this issue (549 bytes, patch)
2011-08-25 11:51 UTC, Jiri Skala
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1481 normal SHIPPED_LIVE arptables_jf bug fix update 2011-11-28 18:56:51 UTC

Description Hushan Jia 2010-03-24 01:29:08 UTC
Description of problem:

Hardware address length, i.e. --arhln parameter cannot be set. it always get a 
arptables v0.0.8: no hln defined
error message.

Version-Release number of selected component (if applicable):
[root@localhost ~]# arptables -V
arptables v0.0.8


How reproducible:
always

Steps to Reproduce:
[root@localhost ~]# arptables -A OUT --arhln=06 --target-hw EA:5F:72:69:25:94 -j mangle --mangle-hw-s 52:54:00:12:34:57
arptables v0.0.8: no hln defined
Try `arptables -h' or 'arptables --help' for more information.

[root@localhost ~]# arptables -A OUT --arhln=06/FF --target-hw EA:5F:72:69:25:94 -j mangle --mangle-hw-s 52:54:00:12:34:57
arptables v0.0.8: no hln defined
Try `arptables -h' or 'arptables --help' for more information.


Actual results:


Expected results:
arptables command should succeed.

Additional info:

Comment 1 Jiri Skala 2010-03-24 09:27:04 UTC
Do replace --arhln=06 with --arhln 06 and it should work. Please read man page carefully, try more cases.

Comment 2 Hushan Jia 2010-03-24 23:56:46 UTC
Sorry, I tried that, just not mentioned in first comment:


[root@localhost ~]# arptables -A OUT --arhln 06 --target-hw EA:5F:72:69:25:94 -j mangle --mangle-hw-s 52:54:00:12:34:57
arptables v0.0.8: no hln defined
Try `arptables -h' or 'arptables --help' for more information.


it does not work.

Comment 3 Jiri Skala 2010-03-25 10:14:18 UTC
This is an issues using mangle-hw opitns.

Comment 7 Jiri Skala 2011-08-25 11:51:46 UTC
Created attachment 519821 [details]
The patch fixes this issue

Comment 12 errata-xmlrpc 2011-11-28 13:57:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1481.html


Note You need to log in before you can comment on or make changes to this bug.