Bug 576493 - [abrt] crash in transmission-gtk-1.92-1.fc12: Process /usr/bin/transmission was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in transmission-gtk-1.92-1.fc12: Process /usr/bin/transmission w...
Keywords:
Status: CLOSED DUPLICATE of bug 583855
Alias: None
Product: Fedora
Classification: Fedora
Component: transmission
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1938a68b067aa5b62b057f9a197...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-24 09:31 UTC by raflexras
Modified: 2010-04-22 18:02 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-22 18:02:14 UTC


Attachments (Terms of Use)
information from ABRT (backtrace) (14.63 KB, application/octet-stream)
2010-04-22 17:15 UTC, AkhaBorz
no flags Details

Description raflexras 2010-03-24 09:31:26 UTC
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/transmission
component: transmission
executable: /usr/bin/transmission
kernel: 2.6.32.9-70.fc12.i686
package: transmission-gtk-1.92-1.fc12
rating: 4
reason: Process /usr/bin/transmission was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Ankur Sinha (FranciscoD) 2010-03-24 09:49:32 UTC
(In reply to comment #0)
> abrt 1.0.8 detected a crash.
> 
> architecture: i686
> Attached file: backtrace
> cmdline: /usr/bin/transmission
> component: transmission
> executable: /usr/bin/transmission
> kernel: 2.6.32.9-70.fc12.i686
> package: transmission-gtk-1.92-1.fc12
> rating: 4
> reason: Process /usr/bin/transmission was killed by signal 11 (SIGSEGV)
> release: Fedora release 12 (Constantine)    

hi,

Can you please submit a backtrace and steps to reproduce this bug?

regards,
Ankur

Comment 2 Ankur Sinha (FranciscoD) 2010-03-29 13:22:44 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > abrt 1.0.8 detected a crash.
> > 
> > architecture: i686
> > Attached file: backtrace
> > cmdline: /usr/bin/transmission
> > component: transmission
> > executable: /usr/bin/transmission
> > kernel: 2.6.32.9-70.fc12.i686
> > package: transmission-gtk-1.92-1.fc12
> > rating: 4
> > reason: Process /usr/bin/transmission was killed by signal 11 (SIGSEGV)
> > release: Fedora release 12 (Constantine)    
> 
> hi,
> 
> Can you please submit a backtrace and steps to reproduce this bug?
> 
> regards,
> Ankur    

http://fedoraproject.org/wiki/StackTraces

Comment 3 Charles Kerr 2010-04-16 03:47:02 UTC
Thank you for taking the time to report this bug. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Comment 4 Mike Wood 2010-04-19 01:22:17 UTC

How to reproduce
-----
1.Just downloading a torrent...
2.
3.


Comment
-----
Downloading a torrent...

Comment 5 Charles Kerr 2010-04-19 13:28:31 UTC
Hi Mike,

I'm not able to reproduce the bug using the steps that you described.  Can you please submit a backtrace?

http://fedoraproject.org/wiki/StackTraces

Comment 6 AkhaBorz 2010-04-22 16:08:05 UTC

How to reproduce
-----
1. disconnect Wi-Fi lan (Network Manager)
2.
3.

Comment 7 Charles Kerr 2010-04-22 16:36:11 UTC
These one-line comments are helpful for telling me there are at least two people experiencing this problem, but not so much for helping me diagnose the problem.

I'm not able to reproduce this crash either by downloading a torrent or by disconnecting my Wi-Fi lan.  Can either of you please submit a backtrace?

http://fedoraproject.org/wiki/StackTraces

Comment 8 AkhaBorz 2010-04-22 17:13:07 UTC
information from ABRT (backtrace):
- - -

[New Thread 2761]
[New Thread 2759]
warning: .dynamic section for "/lib/libgmodule-2.0.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libpthread.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/librt.so.1" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libgobject-2.0.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libglib-2.0.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libdl.so.2" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libz.so.1" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libm.so.6" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libc.so.6" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/usr/lib/libX11.so.6" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libresolv.so.2" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/lib/libselinux.so.1" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
Core was generated by `transmission'.
Program terminated with signal 11, Segmentation fault.
#0  epoll_add (arg=0xb6900820, ev=0xb1b03af0) at epoll.c:281
281	epoll.c: No such file or directory.
	in epoll.c

Thread 3 (Thread 2759):
#0  0x00529424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x004753b6 in __poll (fds=0x96f87c8, nfds=8, timeout=1927)
    at ../sysdeps/unix/sysv/linux/poll.c:87
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        oldtype = 0
        result = <value optimized out>
#2  0x002d98ac in IA__g_poll (fds=0x96f87c8, nfds=8, timeout=1927)
    at gpoll.c:127
No locals.
#3  0x002cc723 in g_main_context_poll (context=0x1b8eb0, block=1, dispatch=1, 
    self=0x94acc38) at gmain.c:2904
        poll_func = <value optimized out>
#4  g_main_context_iterate (context=0x1b8eb0, block=1, dispatch=1, self=
    0x94acc38) at gmain.c:2586
        max_priority = 2147483647
        timeout = 1927
        some_ready = 8
        nfds = 8
        allocated_nfds = <value optimized out>
        fds = 0x96f87c8
        __PRETTY_FUNCTION__ = "g_main_context_iterate"
#5  0x002ccd5f in IA__g_main_loop_run (loop=0x96f9cf8) at gmain.c:2799
        self = 0x94acc38
        __PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#6  0x008c2c79 in IA__gtk_main () at gtkmain.c:1218
        tmp_list = <value optimized out>
        functions = 0x0
        init = <value optimized out>
        loop = 0x96f9cf8
#7  0x0806e446 in main (argc=1, argv=0xbfaa1864) at main.c:625
        str = <value optimized out>
        myUIManager = <value optimized out>
        win = <value optimized out>
        session = <value optimized out>
        cbdata = 0x951f430
        err = 0x0
        argfiles = <value optimized out>
        gerr = 0x0
        didinit = <value optimized out>
        didlock = <value optimized out>
        showversion = 0
        startpaused = 0
        startminimized = 0
        domain = 0x80dd70c "transmission"
        configDir = 0x94b0600 "/home/username/.config/transmission"
        tr_state = <value optimized out>
        entries = {{long_name = 0x80e1eeb "paused", short_name = 112 'p', 
            flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0xbfaa1790, 
            description = 0x80df01c "Start with all torrents paused", 
            arg_description = 0x0}, {long_name = 0x80e432a "version", 
            short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, 
            arg_data = 0xbfaa1794, description = 
    0x80dec3c "Show version number and exit", arg_description = 0x0}, {
            long_name = 0x80dec59 "minimized", short_name = 109 'm', flags = 
    0, arg = G_OPTION_ARG_NONE, arg_data = 0xbfaa178c, description = 
    0x80df03c "Start minimized in notification area", arg_description = 0x0}, 
    {long_name = 0x80dec63 "config-dir", short_name = 103 'g', flags = 0, 
            arg = G_OPTION_ARG_FILENAME, arg_data = 0xbfaa1788, description = 
    0x80df064 "Where to look for configuration files", arg_description = 
    0x0}, {long_name = 0x0, short_name = 0 '\000', flags = 0, arg = 
    G_OPTION_ARG_NONE, arg_data = 0x0, description = 0x0, arg_description = 
    0x0}}

Thread 2 (Thread 2761):
#0  0x00529424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00478391 in select () at ../sysdeps/unix/syscall-template.S:82
No locals.
#2  0x080a8360 in tr_webThreadFunc (vsession=0x9523880) at web.c:308
        r_fd_set = {__fds_bits = {0 <repeats 32 times>}}
        max_fd = -1
        t = {tv_sec = 0, tv_usec = 525374}
        w_fd_set = {__fds_bits = {0 <repeats 32 times>}}
        c_fd_set = {__fds_bits = {0 <repeats 32 times>}}
        msec = 1000
        msg = <value optimized out>
        mcode = <value optimized out>
        task = 0x0
        unused = 0
        multi = 0xb5d01950
        web = 0xb5d01900
        taskCount = 0
        session = 0x9523880
#3  0x0808fe73 in ThreadFunc (_t=0xb6902248) at platform.c:109
        t = 0xb6902248
#4  0x001b5ab5 in start_thread (arg=0xb68ffb70) at pthread_create.c:297
        __res = <value optimized out>
        __ignore1 = -1232080344
        __ignore2 = -1232080472
        pd = 0xb68ffb70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {1863668, 0, 4001536, 
    -1232079880, 1510623265, 1935237964}, mask_was_saved = 0}}, priv = {pad = 
    {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#5  0x0047fdae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
No locals.

Thread 1 (Thread 2760):
#0  epoll_add (arg=0xb6900820, ev=0xb1b03af0) at epoll.c:281
        epev = {events = 0, data = {ptr = 0x0, fd = 0, u32 = 0, u64 = 0}}
        evep = 0xb6a26ce0
        fd = -101
        op = <value optimized out>
        events = <value optimized out>
#1  0x075b65a2 in event_add (ev=0xb1b03af0, tv=0x0) at event.c:748
        base = 0xb6900468
        evsel = 0x75cb050
        evbase = <value optimized out>
        res = 4120
        __PRETTY_FUNCTION__ = "event_add"
#2  0x080b5077 in event_enable (io=0xb1b03768, event=<value optimized out>)
    at peer-io.c:464
No locals.
#3  0x080b51bd in tr_peerIoReconnect (io=0xb1b03768) at peer-io.c:644
        pendingEvents = 4
        session = 0x9523880
#4  0x080ca009 in gotError (io=0xb1b03768, what=33, vhandshake=0xb69fd418)
    at handshake.c:1156
        handshake = 0xb69fd418
#5  0x075b62c0 in event_process_active (base=0xb6900468, flags=0)
    at event.c:392
        activeq = <value optimized out>
        i = <value optimized out>
        ev = 0xb1b03aa8
        ncalls = 0
#6  event_base_loop (base=0xb6900468, flags=0) at event.c:544
        evsel = 0x75cb050
        evbase = 0xb6900820
        tv = {tv_sec = 0, tv_usec = 499075}
        tv_p = <value optimized out>
        res = <value optimized out>
#7  0x075b642a in event_loop (flags=0) at event.c:468
No locals.
#8  0x075b645f in event_dispatch () at event.c:406
No locals.
#9  0x080a3e1d in libeventThreadFunc (veh=0x9523998) at trevent.c:230
        eh = 0x9523998
#10 0x0808fe73 in ThreadFunc (_t=0x9523a28) at platform.c:109
        t = 0x9523a28
#11 0x001b5ab5 in start_thread (arg=0xb74c4b70) at pthread_create.c:297
        __res = <value optimized out>
        __ignore1 = -1232074720
        __ignore2 = -101
        pd = 0xb74c4b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {1863668, 0, 4001536, 
    -1219738632, -580237278, 1935237964}, mask_was_saved = 0}}, priv = {pad = 
    {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#12 0x0047fdae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
No locals.
From        To          Syms Read   Shared Object Library
0x021e74f0  0x021e89d8  Yes (*)     /usr/lib/libcanberra-gtk.so.0
0x021d63c0  0x021e02f8  Yes (*)     /usr/lib/libcanberra.so.0
0x07787f00  0x077a55c8  Yes (*)     /usr/lib/libgconf-2.so.4
0x00c32f40  0x00c346b8  Yes (*)     /lib/libgthread-2.0.so.0
0x022975f0  0x0229a798  Yes (*)     /usr/lib/libnotify.so.1
0x007c6dd0  0x00a9cab8  Yes (*)     /usr/lib/libgtk-x11-2.0.so.0
0x074eb250  0x07550c78  Yes (*)     /usr/lib/libgdk-x11-2.0.so.0
0x002791b0  0x002862e8  Yes (*)     /usr/lib/libatk-1.0.so.0
0x00c4bad0  0x00cb7088  Yes (*)     /lib/libgio-2.0.so.0
0x0022b420  0x00246088  Yes (*)     /usr/lib/libpangoft2-1.0.so.0
0x001950f0  0x001a7908  Yes (*)     /usr/lib/libgdk_pixbuf-2.0.so.0
0x007273d0  0x0072c4b8  Yes (*)     /usr/lib/libpangocairo-1.0.so.0
0x07457040  0x074b5a28  Yes (*)     /usr/lib/libcairo.so.2
0x0740e0e0  0x07430088  Yes (*)     /usr/lib/libpango-1.0.so.0
0x00cf33c0  0x00d5c7f8  Yes (*)     /usr/lib/libfreetype.so.6
0x00104f70  0x00120cd8  Yes (*)     /usr/lib/libfontconfig.so.1
0x00136c30  0x00137d98  Yes (*)     /lib/libgmodule-2.0.so.0
0x075b4c80  0x075c4748  Yes (*)     /usr/lib/libevent-1.4.so.2
0x07594530  0x075a5af8  Yes (*)     /usr/lib/libdbus-glib-1.so.2
0x0013f230  0x0016b3c8  Yes (*)     /lib/libdbus-1.so.3
0x001b4300  0x001bfc28  Yes (*)     /lib/libpthread.so.0
0x00182880  0x00186688  Yes (*)     /lib/librt.so.1
0x001d0460  0x001fb898  Yes (*)     /lib/libgobject-2.0.so.0
0x002a1a20  0x0031f328  Yes (*)     /lib/libglib-2.0.so.0
0x00542140  0x0057a1c8  Yes (*)     /usr/lib/libcurl.so.4
0x07bb7ce0  0x07bee538  Yes (*)     /usr/lib/libssl.so.10
0x07a26a40  0x07b08848  Yes (*)     /usr/lib/libcrypto.so.10
0x0018aa60  0x0018ba88  Yes (*)     /lib/libdl.so.2
0x0020f620  0x0021a8e8  Yes (*)     /lib/libz.so.1
0x0037e420  0x00398718  Yes (*)     /lib/libm.so.6
0x003bb990  0x004c74c0  Yes (*)     /lib/libc.so.6
0x07d97720  0x07d9c858  Yes (*)     /usr/lib/libvorbisfile.so.3
0x07fa2a10  0x07fb8d48  Yes (*)     /usr/lib/libvorbis.so.0
0x07f99310  0x07f9bb88  Yes (*)     /usr/lib/libogg.so.0
0x07f83610  0x07f8c868  Yes (*)     /usr/lib/libtdb.so.1
0x07f77a30  0x07f7c458  Yes (*)     /usr/lib/libltdl.so.7
0x075e8d90  0x076107b8  Yes (*)     /usr/lib/libORBit-2.so.0
0x0059f370  0x00630798  Yes (*)     /usr/lib/libX11.so.6
0x0026ce70  0x0026f3a8  Yes (*)     /usr/lib/libXfixes.so.3
0x00d88720  0x00d92ff8  Yes (*)     /usr/lib/libXext.so.6
0x00df62c0  0x00dfc178  Yes (*)     /usr/lib/libXrender.so.1
0x00221780  0x00222258  Yes (*)     /usr/lib/libXinerama.so.1
0x00250740  0x0025a4b8  Yes (*)     /usr/lib/libXi.so.6
0x00263150  0x00267c38  Yes (*)     /usr/lib/libXrandr.so.2
0x0051be40  0x00521458  Yes (*)     /usr/lib/libXcursor.so.1
0x0025d890  0x0025e488  Yes (*)     /usr/lib/libXcomposite.so.1
0x005247c0  0x00525248  Yes (*)     /usr/lib/libXdamage.so.1
0x006c5650  0x006d3b48  Yes (*)     /lib/libresolv.so.2
0x006e0190  0x006f13c8  Yes (*)     /lib/libselinux.so.1
0x00dc66f0  0x00de2578  Yes (*)     /usr/lib/libpng12.so.0
0x00e017a0  0x00e53e68  Yes (*)     /usr/lib/libpixman-1.so.0
0x0052afc0  0x0052bfe8  Yes (*)     /usr/lib/libxcb-render-util.so.0
0x00734450  0x007377f8  Yes (*)     /usr/lib/libxcb-render.so.0
0x00c13e80  0x00c22608  Yes (*)     /usr/lib/libxcb.so.1
0x00d9b040  0x00db3f28  Yes (*)     /lib/libexpat.so.1
0x07f5c170  0x07f6a9e8  Yes (*)     /lib/libnsl.so.1
0x00dedda0  0x00def8d8  Yes (*)     /lib/libcap-ng.so.0
0x00759830  0x00770d0f  Yes (*)     /lib/ld-linux.so.2
0x020abd00  0x020b0828  Yes (*)     /lib/libidn.so.11
0x00e69650  0x00e97438  Yes (*)     /usr/lib/libldap-2.4.so.2
0x00f35750  0x00f57478  Yes (*)     /lib/libgssapi_krb5.so.2
0x00f6de50  0x00fd0f88  Yes (*)     /lib/libkrb5.so.3
0x00ea87f0  0x00ec3288  Yes (*)     /lib/libk5crypto.so.3
0x00743d10  0x00744928  Yes (*)     /lib/libcom_err.so.2
0x07da60b0  0x07dcb398  Yes (*)     /usr/lib/libssl3.so
0x07dfabb0  0x07e14468  Yes (*)     /usr/lib/libsmime3.so
0x07e30060  0x07f19998  Yes (*)     /usr/lib/libnss3.so
0x00ed1920  0x00f003c8  Yes (*)     /lib/libfreebl3.so
0x006fc150  0x00719bb8  Yes (*)     /usr/lib/libnssdbm3.so
0x0369ac10  0x036c6918  Yes (*)     /usr/lib/libsoftokn3.so
0x07ddcb90  0x07de89d8  Yes (*)     /usr/lib/libnssutil3.so
0x079c3a90  0x079c4a18  Yes (*)     /lib/libplds4.so
0x07d8fe50  0x07d91808  Yes (*)     /lib/libplc4.so
0x07d58820  0x07d7c488  Yes (*)     /lib/libnspr4.so
0x021023f0  0x0211e5e8  Yes (*)     /usr/lib/libssh2.so.1
0x00c2da00  0x00c2e7f8  Yes (*)     /usr/lib/libXau.so.6
0x0217d5d0  0x02184a58  Yes (*)     /usr/lib/liblber-2.4.so.2
0x01de71b0  0x01df7aa8  Yes (*)     /usr/lib/libsasl2.so.2
0x0052fc60  0x005341f8  Yes (*)     /lib/libkrb5support.so.0
0x00753860  0x00753fc8  Yes (*)     /lib/libkeyutils.so.1
0x07cc2e20  0x07d340a8  Yes (*)     /usr/lib/libsqlite3.so.0
0x040698b0  0x0406ea18  Yes (*)     /lib/libcrypt.so.1
0x00747a00  0x0074f0e8  Yes (*)     /lib/libnss_files.so.2
0x0073b610  0x00740798  Yes (*)     /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so
0x00757070  0x007579d8  Yes (*)     /usr/lib/gtk-2.0/modules/libpk-gtk-module.so
0x00c08680  0x00c0a778  Yes (*)     /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so
0x00f1a810  0x00f1b658  Yes (*)     /lib/libnss_mdns4_minimal.so.2
0x00f1dc00  0x00f21228  Yes (*)     /lib/libnss_dns.so.2
0x079bda20  0x079be2c8  Yes (*)     /lib/libutil.so.1
0x02b3b340  0x02b55f18  Yes (*)     /usr/lib/gio/modules/libgvfsdbus.so
0x089d9920  0x089e4508  Yes (*)     /usr/lib/libgvfscommon.so.0
0x08555f40  0x0855f808  Yes (*)     /lib/libudev.so.0
0x084c9b00  0x084d6208  Yes (*)     /usr/lib/gio/modules/libgioremote-volume-monitor.so
0x00f26010  0x00f29368  Yes (*)     /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so
(*): Shared library is missing debugging information.
$1 = 0x0
No symbol "__glib_assert_msg" in current context.
Debuginfo absent: 4591ebf33868e00425d7cbc47de5b25d7503f611
Debuginfo absent: 8be38d8f4f314234b5d661495040aca825da79bb
Debuginfo absent: ec82a33432ccc8879be7abef70f02fb36d41abc9

Comment 9 AkhaBorz 2010-04-22 17:15:21 UTC
Created attachment 408392 [details]
information from ABRT (backtrace)

Comment 10 Charles Kerr 2010-04-22 18:01:13 UTC
Thanks!

The most important section:

> #1  0x075b65a2 in event_add (ev=0xb1b03af0, tv=0x0) at event.c:748
> #2  0x080b5077 in event_enable (io=0xb1b03768, event=<value optimized out>)
> #3  0x080b51bd in tr_peerIoReconnect (io=0xb1b03768) at peer-io.c:644
> #4  0x080ca009 in gotError (io=0xb1b03768, what=33, vhandshake=0xb69fd418)
> #5  0x075b62c0 in event_process_active (base=0xb6900468, flags=0)

Comment 11 Charles Kerr 2010-04-22 18:02:14 UTC

*** This bug has been marked as a duplicate of bug 583855 ***


Note You need to log in before you can comment on or make changes to this bug.