Bug 576548 - [abrt] crash in kdebase-runtime-4.4.1-1.fc12: Process /usr/bin/nepomukservicestub was killed by signal 11 (SIGSEGV)
[abrt] crash in kdebase-runtime-4.4.1-1.fc12: Process /usr/bin/nepomukservice...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-runtime (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:b87d2423f19c7c8ef914eb9fa95...
:
: 576514 602612 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-24 08:36 EDT by andreas.mack@konsec.com
Modified: 2010-07-16 04:17 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-29 20:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (24.44 KB, text/plain)
2010-03-24 08:36 EDT, andreas.mack@konsec.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 232564 None None None Never

  None (edit)
Description andreas.mack@konsec.com 2010-03-24 08:36:34 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/nepomukservicestub nepomukstorage
comment: nothing special. nepomuk never worked for me though :(
component: kdebase-runtime
executable: /usr/bin/nepomukservicestub
kernel: 2.6.32.9-70.fc12.x86_64
package: kdebase-runtime-4.4.1-1.fc12
rating: 4
reason: Process /usr/bin/nepomukservicestub was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. start kontact
2.
3.
Comment 1 andreas.mack@konsec.com 2010-03-24 08:36:37 EDT
Created attachment 402291 [details]
File: backtrace
Comment 2 Steven M. Parrish 2010-03-28 18:39:12 EDT
Thank you for taking the time to report this issue to us.  This is an issue which is best addressed by the upstream developers.

Please file a report at bugs.kde.org , and when done add the upstream report info to this report.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Christoph Wickert 2010-03-29 05:37:36 EDT

How to reproduce
-----
1. start kontact
2. it crashes (sometimes)
3. try to start it again. kontact is reported to be running and I cannot start it again, so I have to log out.


Comment
-----
I just started Kontact and it crashed
Comment 4 Christoph Wickert 2010-03-29 07:04:44 EDT
(In reply to comment #2)

> Please file a report at bugs.kde.org , and when done add the upstream report
> info to this report.

IMHO this is the job of the KDE maintainers or the KDE bug triagers. They already have a KDE bugzilla account while I doubt all our users have one. The wiki says:

"Deal with reported bugs in a timely manner

    * If there are bugs which you aren't capable of fixing yourself because they deal with intricacies of the source code which you don't fully understand, then you still need to address these bugs. It can be helpful to work with the upstream maintainer of the code, obtain help from more code-oriented people on fedora-devel, or check other distributions for patches. Always be sure to post to the bug report what you have done so that the reporter knows what it happening and what to expect."

Source: https://fedoraproject.org/wiki/Package_maintainer_responsibilities

> We will continue to track the issue in the centralized upstream bug tracker,
> and will review any bug fixes that become available for consideration in future
> updates.

Would you mind showing me bugs where this approach worked out?

You are closing all bugs no matter if they are fixed or not. They are ether closed WONTFIX because the reporter didn't respond or they are closed UPSTREAM as soon as they are forwarded. This means you are not tracking anything, you are just closing everything. You make tracking impossible because nobody is able to search our bugzilla for bugs that actually affect our packages.
Comment 5 andreas.mack@konsec.com 2010-03-29 10:20:59 EDT
Christoph, thanks for handling this.
Comment 6 Christoph Wickert 2010-03-29 17:12:35 EDT
Steven, I think I should turn the tables on you in order to show how counterproductive the KDE SIG's approach is. So let me ask you again: Can you show me bugs where your approach worked out?

And if you don't reply in a timely manner, I will declare you AWOL. JK ;)
Comment 7 Rex Dieter 2010-03-29 18:07:53 EDT
Good: discussing kde bug triage policy onlist (thanks, even though the way it was done here wasn't exactly the most constructive way possible).

Bad: arguing triage policy with triagers in bugzilla

Let's try to stick with the good, ok?  Please allow discussion to continue, and perhaps we can arrive at some sort of constructive improvement to kde bug triage procedure and policy.  I'd invite interested parties to sit in our kde sig meeting tomorrow, where we plan on discussing this.
Comment 8 Kevin Kofler 2010-03-29 20:33:30 EDT
1. The upstream bug will usually have at least one or two of us CCed on it. (Rex and I both try to CC ourselves to those upstreamed reports.)
2. It doesn't make sense to have 2 bugs filed for the same issue. The bug is in the upstream software.
3. Even if we did not track the resolution, we would still automatically pick up the fix as we push bugfix releases, and even feature releases which also fix many bugs, as updates.
4. You wouldn't find anything with a Bugzilla search if we had tons of bugs open. Upstream's Bugzilla instance has more finegrained components, so it's much more effective for handling KDE bugs.
5. If you still don't agree with this bug tracking policy, please bring this up in a meeting or on the kde@lists.fe… ML. This is not the place for such a discussion.
Comment 9 Radek Novacek 2010-07-16 04:03:24 EDT
*** Bug 576514 has been marked as a duplicate of this bug. ***
Comment 10 Radek Novacek 2010-07-16 04:17:11 EDT
*** Bug 602612 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.