Bug 57684 - rpm segfaults, possible damaged package db (maybe kpackage related)
Summary: rpm segfaults, possible damaged package db (maybe kpackage related)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL: http://www.geocities.com/jfxberns
Whiteboard:
Keywords:
: 57719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-18 22:09 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 23:21:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-12-18 22:09:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011013

Description of problem:
I can't do ANYTHING that involved upgrading or installing RPMs.  Not only
will rpm fail on --install (--install --test) --U -qa and --rebuilddb--on
top of that, gnorpm, kpackage, up2date and Ximian RecCarpet all crash as well!

I read over previous issues that are similar on RedHat Bugzilla.  I tried
the db_verify script on the /var/lib/rpm files and it gave me an error that
the Packages db was corrupt.

I tried moving the db to Packages.old and running:

    db_dump Packages.old | db_load Packages

and that seemed to work--at least the db_verify script 'liked' the
database, however, the segfaults still continue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -qa
2.rpm --rebuilddb
3.rpm -U anything.rpm
4.rpm -i anything.rpm
5.gnorpm
6.kpackage
7.redcarpet
8.kpackage
	

Actual Results:  Segmentation fault (core dumped).

Expected Results:  check rpmdb, repair rpmdb, install rpm, upgrade rpm,
etc.; i.e. the program shopu;d perform normally!

Additional info:

I tend to think it is one of the kpackage-related RPM db corruptions
issues.  I tried looking for a solution, but it seems that all the ones
listed on Bugzilla failed to fix the issue.  What's next?

I ran 'rpm --rebuilddb -vv'and saved the output to a file rebuild.txt, I
also have the core file (renamed core.something so I could upload it...)
that was dumped, you can d/l them from:

http://www.geocities.com/jfxberns

The Packages file itself is about 20MB, if you need to peruse that, tell me
the best way to send it to you.

Comment 1 Need Real Name 2001-12-18 23:21:16 UTC
Just a couple more data points:

1)  rpm is version 4.0.2.  
2)  A gzipped version of the Packages database is posted on the above web site
if it is helpful in solving the problem.  It's about 6.5 Mb...

Comment 2 Jeff Johnson 2001-12-19 19:21:46 UTC
Install rpm-4.0.3 packages from ftp.rpm.org/pub/rpm/dist-4.0.x
and do a --rebuilddb. That will eliminate damaged header
instance #1022 from your Packages database.

Comment 3 Need Real Name 2001-12-20 07:39:29 UTC
No can do.

I can't install the new RPM 4.0.3 via RPM, because RPM is broken.

I downloaded rpm-4.0.3.tar.gz and tried to build it, but it doies not seem to
build properly.

If I understand the INSTALL instructions correctly, running ./autogen.sh should
set some env variable then launch configure.  

When I run ./autogen.sh all I get is a USAGE message ( see
http://www.geocities.com/jfxberns/autogen.output.txt ).  

I checked the versions of the required apps and they meet the requirements for
RPM 4.0.3 ( see http://www.geocities.com/jfxberns/versions.txt )

I tried ./configure, but it dies with an error (see
http://www.geocities.com/jfxberns/configure.output.txt ).

OK.  I am back to square one.  No working rpm, no way to run rpm --rebuilddb.

What's next?

Comment 4 Jeff Johnson 2001-12-20 13:45:38 UTC
There's a tarball of binaries at
    ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/rpm-4.0.3.i386.tar.gz

Comment 5 Jeff Johnson 2001-12-20 13:46:58 UTC
*** Bug 57719 has been marked as a duplicate of this bug. ***

Comment 6 Need Real Name 2001-12-20 18:54:53 UTC
I didn't even see the pre-compiled binaries before when I looked there.

tar -xzf'd them and 
everything works beautifully.

You guys are amazing.  Many thanks!


Note You need to log in before you can comment on or make changes to this bug.