Bug 57719 - Can't Fix RPM problem (Bugzilla bug report #57684) by upgrading rpm
Can't Fix RPM problem (Bugzilla bug report #57684) by upgrading rpm
Status: CLOSED DUPLICATE of bug 57684
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
http://www.geocities.com/jfxberns
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 02:56 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-20 02:56:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-20 02:56:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011013

Description of problem:
Your solution to bug report 57684:

>> Install rpm-4.0.3 packages from ftp.rpm.org/pub/rpm/dist-4.0.x
>> and do a --rebuilddb. That will eliminate damaged header
>> instance #1022 from your Packages database.

No can do.

I can't install the new RPM 4.0.3 via RPM, because RPM is broken.

I downloaded rpm-4.0.3.tar.gz and tried to build it, but it does not seem to
build properly.

If I understand the INSTALL instructions correctly, running ./autogen.sh should
set some env variable then launch configure.  

When I run ./autogen.sh all I get is a USAGE message ( see
http://www.geocities.com/jfxberns/autogen.output.txt ).  

I checked the versions of the required apps and they meet the requirements for
RPM 4.0.3 ( see http://www.geocities.com/jfxberns/versions.txt )

I tried ./configure, but it dies with an error (see
http://www.geocities.com/jfxberns/configure.output.txt ).

OK.  I am back to square one.  No working rpm, no way to run rpm --rebuilddb.

What's next?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  d/l rpm-4.0.3.tar.gz
2.  tar -xzf rpm-4.0.3.tar.xzf
3.  cd rpm-4.0.3
4.  ./autogen.sh
5.  ./configure
	

Actual Results:  ./autogen.sh should run configure, but it doesn't

./configure exits with an error

Expected Results:  ./autogen should generate a proper config file...

Additional info:

I re-installed a fresh copy of db-3.1.17 just to make sure that that wasn't
generating a problem.
Comment 1 Jeff Johnson 2001-12-20 08:47:03 EST

*** This bug has been marked as a duplicate of 57684 ***

Note You need to log in before you can comment on or make changes to this bug.