Bug 576845 - 13-Beta.TC1: unicode characters are brighter than normal ones
Summary: 13-Beta.TC1: unicode characters are brighter than normal ones
Keywords:
Status: CLOSED DUPLICATE of bug 578454
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 578454
Blocks: F13Target
TreeView+ depends on / blocked
 
Reported: 2010-03-25 12:45 UTC by Milan Kerslager
Modified: 2014-09-30 23:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 07:31:42 UTC
Type: ---


Attachments (Terms of Use)
National characters has different ink color (window title, button, text inside window) (21.30 KB, image/png)
2010-03-25 12:45 UTC, Milan Kerslager
no flags Details
broken dialog 1 (4.71 KB, image/png)
2010-03-25 14:41 UTC, Kamil Páral
no flags Details
broken dialog 2 (4.09 KB, image/png)
2010-03-25 14:41 UTC, Kamil Páral
no flags Details
too wide dialog (7.26 KB, image/png)
2010-03-25 14:42 UTC, Kamil Páral
no flags Details
shot from installed system (6.11 KB, image/png)
2010-03-25 16:51 UTC, Kamil Páral
no flags Details
boot in cs_CZ locale in KVM (30.93 KB, image/png)
2010-05-14 13:33 UTC, Kamil Páral
no flags Details

Description Milan Kerslager 2010-03-25 12:45:03 UTC
Created attachment 402532 [details]
National characters has different ink color (window title, button, text inside window)

When I choose text install and czech language, the unicode characters are brighter that "normal" ACSII chars (gray instead of black and similar with red). This happened under VirtualBox. I'll try bare metal hardware.

How to reproduce: boot TC1 and add "text lang=cs" as kernel parameter.

Comment 1 Ales Kozumplik 2010-03-25 14:26:59 UTC
Proposing as F13Blocker.

Comment 2 Kamil Páral 2010-03-25 14:41:34 UTC
Created attachment 402570 [details]
broken dialog 1

Confirmed. Not only cs national characters have different color, but some dialogs are clearly broken. See attachments.

PS: Still I don't think it's a blocker.

Comment 3 Kamil Páral 2010-03-25 14:41:52 UTC
Created attachment 402571 [details]
broken dialog 2

Comment 4 Kamil Páral 2010-03-25 14:42:07 UTC
Created attachment 402572 [details]
too wide dialog

Comment 5 Ales Kozumplik 2010-03-25 15:36:27 UTC
The broken dialog is bug 576541, it only happens with lang= set from the kernel command line, I will look into it at some point.

The wide dialog is an unrelated problem.

Let's focus this bug on the weird character colors: Kamil, do you see this in s-c-whatever programs after the installation finishes?

Thanks.

Comment 6 Ales Kozumplik 2010-03-25 15:58:38 UTC
Strangly, I am unable to reproduce the problem in my own Fedora compose from the last night. It can be a font problem or a terminal problem.

Comment 7 Kamil Páral 2010-03-25 16:51:38 UTC
Created attachment 402611 [details]
shot from installed system

I have tried another F13 Beta TC1 virtual machine installed from DVD through common GUI install. Still in the installed system I see some character with different colors (ř and ě, see attachment). It happens only in virtual console (VT2, etc), but not in terminal emulator (gnome-terminal).

Comment 8 Kamil Páral 2010-03-25 16:52:04 UTC
Tomorrow I can try to test it on real hardware.

Comment 9 Kamil Páral 2010-03-26 17:26:36 UTC
This problem does not happen on real hardware for me, just in the virtual machine.

Comment 10 Kamil Páral 2010-03-29 12:16:10 UTC
I have fully updated my F13 in virtual machine (virt-manager, libvirt, KVM) and this problem still persists.

Comment 11 Ales Kozumplik 2010-03-31 11:33:19 UTC
I discussed this with mlichvar and he thinks it's a kernel bug 578454.

Comment 12 Ales Kozumplik 2010-05-14 13:02:38 UTC
The bug hasn't been spotted for a long time now. I assume it went away with a new kernel version.

Comment 13 Kamil Páral 2010-05-14 13:32:32 UTC
(In reply to comment #12)
> The bug hasn't been spotted for a long time now. I assume it went away with a
> new kernel version.    

Which kernel do you have in mind? I have 2.6.33.3-85.fc13.x86_64 installed in KVM and still seeing this issue. See screenshot.

Comment 14 Kamil Páral 2010-05-14 13:33:06 UTC
Created attachment 414048 [details]
boot in cs_CZ locale in KVM

Comment 15 Kamil Páral 2010-05-14 14:05:35 UTC
If this is a kernel bug and not anaconda bug (apparently) I guess this should be closed as duplicate of bug 578454 or wontfix (or something).

Comment 16 Ales Kozumplik 2010-05-17 07:31:42 UTC
Closing this again. Kamil is right this exist, but it's not a bug in anaconda, it's a kernel issue. See bug 576845.

*** This bug has been marked as a duplicate of bug 578454 ***


Note You need to log in before you can comment on or make changes to this bug.