Bug 577095 - Trying to hyphenate verbatim text breaks some PDF builds
Trying to hyphenate verbatim text breaks some PDF builds
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
: 577703 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-26 01:35 EDT by Ruediger Landmann
Modified: 2010-11-23 23:18 EST (History)
5 users (show)

See Also:
Fixed In Version: publican-1.6.2-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-03 00:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2010-03-26 01:35:14 EDT
Description of problem:

PDF builds of books that contain long lines of verbatim content break with messages like:

xsltApplyXSLTTemplate: A potential infinite template recursion was detected.
You can adjust xsltMaxDepth (--maxdepth) in order to raise the maximum number of nested template calls and variables/params (currently set to 250).
Templates:
#0 name hyphenate.verbatim 
#1 name hyphenate.verbatim 
#2 name hyphenate.verbatim 
#3 name hyphenate.verbatim 
#4 name hyphenate.verbatim 
#5 name hyphenate.verbatim 
#6 name hyphenate.verbatim 
#7 name hyphenate.verbatim 
#8 name hyphenate.verbatim 
#9 name hyphenate.verbatim 
#10 name hyphenate.verbatim 
#11 name hyphenate.verbatim 
#12 name hyphenate.verbatim 
#13 name hyphenate.verbatim 
#14 name hyphenate.verbatim 


Version-Release number of selected component (if applicable):
1.6.1

How reproducible:
100%

Steps to Reproduce:
1. Create a book
2. Include the following content somewhere :
<screen>Update-LogicalNetworkToNetworkAdapter -HostObject &amp;lt;CLIHost&amp;gt;  -Network &amp;lt;CLINetwork&amp;gt;  -OldNetworkName &amp;lt;String&amp;gt;  -NetworkAdapterObjects &amp;lt;CLIHostNetworkAdapter[]&amp;gt;  [-Address] &amp;lt;String&amp;gt;  [-Subnet] &amp;lt;String&amp;gt;  [-Gateway] &amp;lt;String&amp;gt;  [-BootProtocol] &amp;lt;String&amp;gt;  [-BondName] &amp;lt;String&amp;gt;  [-BondingOptions] &amp;lt;String&amp;gt;  [-CheckConectivity] &amp;lt;Boolean&amp;gt;  [-Async] [-AsyncTimeOut] &amp;lt;Int32&amp;gt; </screen>
3. Build the PDF 
  
Actual results:
Build fails

Expected results:
Build succeeds

Additional info:

Change 1112 turned on:
<xsl:param name="hyphenate.verbatim" select="1"/> 

Setting this back to 
<xsl:param name="hyphenate.verbatim" select="0"/> 

allows the book to build normally.
Comment 1 Jeff Fearn 2010-03-26 01:40:06 EDT
Setting XML::LibXSLT->max_depth(1000); also fixes this.

I'd rather do this as it allows people to test hyphenation without changing the shipped XSL.
Comment 2 Jeff Fearn 2010-03-28 20:48:04 EDT
*** Bug 577703 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-04-01 01:14:53 EDT
publican-1.6.2-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.6.2-0.fc12
Comment 4 Fedora Update System 2010-04-01 01:15:20 EDT
publican-1.6.2-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.6.2-0.fc11
Comment 5 Fedora Update System 2010-04-01 01:15:46 EDT
publican-1.6.2-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.6.2-0.fc13
Comment 6 Fedora Update System 2010-04-03 00:39:28 EDT
publican-1.6.2-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-04-03 00:50:09 EDT
publican-1.6.2-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-04-09 00:27:34 EDT
publican-1.6.2-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.