Bug 577703 - Publican 1.6.1 XSL regression
Publican 1.6.1 XSL regression
Status: CLOSED DUPLICATE of bug 577095
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity high
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-28 20:46 EDT by David Jorm
Modified: 2014-10-20 20:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-28 20:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jorm 2010-03-28 20:46:04 EDT
Description of problem:
XSL processing of certain books with publican 1.6.1 breaks. These books build under publican 1.6.0 locally, but when pushed to brew running 1.6.1 they fail, with the error:

runtime error: file file:///usr/share/sgml/docbook/xsl-stylesheets-1.75.1/fo/verbatim.xsl line 439 element param
xsltApplyXSLTTemplate: A potential infinite template recursion was detected.
You can adjust xsltMaxDepth (--maxdepth) in order to raise the maximum number of nested template calls and variables/params (currently set to 250).

Discussions with Rudiger revealed the XSL itself to be the cause of the problem. For an example build, see:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2347861

https://brewweb.devel.redhat.com//getfile?taskID=2347862&name=build.log

Version-Release number of selected component (if applicable):
1.6.1 as deployed on brew

How reproducible:
Every time

Steps to Reproduce:
1. Build book locally, succeeds
2. Push to brew, fails
Comment 1 Jeff Fearn 2010-03-28 20:48:04 EDT

*** This bug has been marked as a duplicate of bug 577095 ***

Note You need to log in before you can comment on or make changes to this bug.