Bug 5771 - Redhat 6.1 upgrade wont work (rpm: error during package check) (non-NTFS)
Redhat 6.1 upgrade wont work (rpm: error during package check) (non-NTFS)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 11:21 EDT by Olivier Crête
Modified: 2015-01-07 18:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-21 12:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Crête 1999-10-09 11:21:15 EDT
This looks very very similar to bugs #5705 and #5545

I tried installing it by both HTTP and FTP...I am upgrading
from a Rh 6.0 install which is on hda2 (hda1 is a fat16 with
dos). It is a simple IDE hd, with no raid or anything
special. And when it crashes my linux partition does not
seems to have been mounted.

 While it was in the "Reading packages information" phase I
had the following python error... (which has been copied by
hand from a "screenshot" done with a digital camera)

 Traceback (innermost last):
    File "/usr/bin/anaconda.real" line 225, in ?
	intf.run(todo, test = test)
    File  "/tmp/lib/python1.5/site-package/text.py", line
1000, in run
	rc = apply (step[1](), step[2])
    File "/tmp/lib/python1.5/site-package/text.py", line
251, in __call_
	todo.upgradeFindPackages (root)
    File "/tmp/lib/python1.5/site-package/todo.py", line
1125, in upgradeFindPackages
	packages = rpm.findUpgradeSet (self.hdList.hdlist,
self.instPath)
 rpm.error: error during upgrade check
Comment 1 Olivier Crête 1999-10-11 01:55:59 EDT
I looked at it more closely and I believe that the bug is in the fs
mounting section of the code not finding that the mount has failed (or
simply "forgetting" to mount the partitions). The rpm error messages
seems to be triggered by the impossibility to open the specified rpm
db (since the fs has not been mounted).

Btw, I believe the fs was not mounted because the mount command
returned nothing about my main ext2 (on hda2) (didnt check in
/proc/mount....)

------- Additional Comments From   10/15/99 06:26 -------
Same resaults doing a HD install or upgrade
Comment 2 hchcheng 1999-10-18 20:36:59 EDT
Same thing here installing from CD-ROM (both GUI and text).

My fstab looks like:

/dev/hda3	/	ext2	 exec,dev,suid,rw 1 1
/dev/hdb3	/home	ext2	 exec,dev,suid,rw 1 2
/dev/hda2	/mnt/backup	ext2	defaults	1 2
/dev/hdb2	swap		swap	defaults	0 0
/dev/fd0	/mnt/floppy	ext2	noauto		0 0
/dev/cdrom	/mnt/cdrom	iso9660	noauto,ro,user	0 0
none		/proc		proc	defaults	0 0
none		/dev/pts	devpts	gid=5,mode=620	0 0
/dev/hda1	/win98-1	vfat	exec,dev,suid,rw,conv=auto,umask=0 1 1
/dev/hdb1	/win98-2	vfat	exec,dev,suid,rw,umask=0 1 1
/dev/pda1	/mnt/shark	ext2	noauto		0 0

From the bash shell during the install, I see that /dev/hda2 was
mounted, but /dev/hda3 was not when the installer hangs.
Comment 3 Jay Turner 1999-10-21 12:05:59 EDT
The problem is that the mount code for upgrades is looking for the
mouse options specified in fstab being "defaults" only.  We are in the
process of putting together a fix to this problem and will be posting
that on the errata site as soon as the patch is ready and tested.

*** This bug has been marked as a duplicate of 5768 ***

Note You need to log in before you can comment on or make changes to this bug.