Bug 5768 - Upgrade failes on Thinkpad
Upgrade failes on Thinkpad
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 09:03 EDT by Christoph Rohland
Modified: 2015-01-07 18:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-25 13:43:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Rohland 1999-10-09 09:03:32 EDT
...in todo.py:1155

> packages = rpm.findUpgradeSet (...)

What I think: It did not mount the old partition.
The device file is created under /tmp
but mount does not show the filesystem mounted.
proc is mounted under /mnt/sysimage/proc

If I mount /tmp/hda5 to /mnt/sysimage, rpm.findUpradeSet
works in the debugger.
Comment 1 martin 1999-10-14 12:13:59 EDT
I have had success upgrading from 60 to 61 on an IBM Thinkpad 380 with
3COM Etherlink III NIC/Modem.

Used a CD from an ISO image. Booted from the floopy image. Upgrade
works.

------- Additional Comments From   10/15/99 03:38 -------
I found the bug: in todo.py: def readFstab (self, path): f= open (path, r) lines= f.readlines () f.close fstab= {} for line in lines: fields= string.split (line) # skip comments if fields and fields[0][0]==' #': continue # all valid fstab entries have 6 fields if not len (fields) < 4 and len (fields) <= 6: if fields and (fields[2]== ext2 or fields[2]== swap) \ --> and fields[3]== defaults: format= 0 # XXX always format swap. if fields[2]== swap: format= 1 fstab[fields[1]]= (fields[0][5:], fields[2], format) return fstab It only accepts mounts, which have tghe single option' defaults' which failed, because I enabled the option noatime in /etc/fstab. The only valid check to exclude an entry woul be the presence of option' noauto'. I think this check is really dangerous: If you have options on e.g. /usr it would not be mounted, but upgraded which would lead to a heavily screwed up system.
Comment 2 Jay Turner 1999-10-21 12:05:59 EDT
*** Bug 5771 has been marked as a duplicate of this bug. ***

This looks very very similar to bugs #5705 and #5545

I tried installing it by both HTTP and FTP...I am upgrading
from a Rh 6.0 install which is on hda2 (hda1 is a fat16 with
dos). It is a simple IDE hd, with no raid or anything
special. And when it crashes my linux partition does not
seems to have been mounted.

 While it was in the "Reading packages information" phase I
had the following python error... (which has been copied by
hand from a "screenshot" done with a digital camera)

 Traceback (innermost last):
    File "/usr/bin/anaconda.real" line 225, in ?
	intf.run(todo, test = test)
    File  "/tmp/lib/python1.5/site-package/text.py", line
1000, in run
	rc = apply (step[1](), step[2])
    File "/tmp/lib/python1.5/site-package/text.py", line
251, in __call_
	todo.upgradeFindPackages (root)
    File "/tmp/lib/python1.5/site-package/todo.py", line
1125, in upgradeFindPackages
	packages = rpm.findUpgradeSet (self.hdList.hdlist,
self.instPath)
 rpm.error: error during upgrade check

------- Additional Comments From tester@videotron.ca  10/11/99 01:55 -------
I looked at it more closely and I believe that the bug is in the fs
mounting section of the code not finding that the mount has failed (or
simply "forgetting" to mount the partitions). The rpm error messages
seems to be triggered by the impossibility to open the specified rpm
db (since the fs has not been mounted).

Btw, I believe the fs was not mounted because the mount command
returned nothing about my main ext2 (on hda2) (didnt check in
/proc/mount....)

------- Additional Comments From   10/15/99 06:26 -------
Same resaults doing a HD install or upgrade

------- Additional Comments From hchcheng@scg.math.uwaterloo.ca  10/18/99 20:36 -------
Same thing here installing from CD-ROM (both GUI and text).

My fstab looks like:

/dev/hda3	/	ext2	 exec,dev,suid,rw 1 1
/dev/hdb3	/home	ext2	 exec,dev,suid,rw 1 2
/dev/hda2	/mnt/backup	ext2	defaults	1 2
/dev/hdb2	swap		swap	defaults	0 0
/dev/fd0	/mnt/floppy	ext2	noauto		0 0
/dev/cdrom	/mnt/cdrom	iso9660	noauto,ro,user	0 0
none		/proc		proc	defaults	0 0
none		/dev/pts	devpts	gid=5,mode=620	0 0
/dev/hda1	/win98-1	vfat	exec,dev,suid,rw,conv=auto,umask=0 1 1
/dev/hdb1	/win98-2	vfat	exec,dev,suid,rw,umask=0 1 1
/dev/pda1	/mnt/shark	ext2	noauto		0 0

From the bash shell during the install, I see that /dev/hda2 was
mounted, but /dev/hda3 was not when the installer hangs.
Comment 3 Jay Turner 1999-10-21 12:25:59 EDT
*** Bug 5789 has been marked as a duplicate of this bug. ***

It would be nice to have a Component section directly
related to the boot-install images. I put this in installer
for this reason.

Priority high because if the problem is confirmed it
means that the boot image has a real problem.

My system is RH 6.0, kernel 2.2.10, upgraded from hard drive
from a previous RH 5.2.
This time I wanted to do the same to RH 6.1 but the process
stopped with errors after the second phase of the system
exploration. First it searched for redhat installation,
this went OK, but the next one seemed to work but I got this
(copied by hand):

-------------------
Traceback(innermost last):
 File "/usr/bin/anaconda.real",line 225, in ?
intf.run(todo,test=test)
 File "/tmp/lib/python1.5/site-packages/text.py", line 1000,
in run rc=apply(step[1](),step[2])
 File "/tmp/lib/python1.5/site-packages/text.py", line 251,
in __call__ todo upgradeFindPackages(root)
 File "/tmp/lib/python1.5/site-packages/todo.py", line 1155,
in upgradeFindPackages
packages=rpm.findUpgradeSet(self.hdList.hdlist,self.instPath)
rpm.error: error during upgrade check

[OK] [Debug]
----------------

My rpm version is 3.0.2 and I tried the upgrade after
rpm --rebuildb to be sure that the database was OK, and
it was.

I have copied the RedHat directory on a different partition
than my linux partition as it should be done.

/Alexandre

PS: I could not use bootnet because it simply does NOT work
with my TI1225 pcmcia controller, although it works fine
under my installed Linux
(from /proc/pci:
  Bus  0, device   3, function  0:
    CardBus bridge: Texas Instruments Unknown device (rev
1).
      Vendor id=104c. Device id=ac1c.
      Medium devsel.  Master Capable.  Latency=32.  Min
Gnt=192.Max Lat=7.
)

------- Additional Comments From jturner@redhat.com  10/11/99 08:58 -------
You will want to use the pcmcia.img disk when trying to use a pcmcia
device for installation.  This is why the bootnet.img file did not
work for you . . . the card manager stuff is not on that disk.  As for
the error that you are receiving, do you have any NTFS partitions on
the machine?

------- Additional Comments From   10/11/99 09:48 -------
I have noticed the change in the installation disks, that's better
now, so I tried pcmcia.img, it recognizes my hardware and goes on
but on the "finding padkages to update" message:
* if I check the customize checkbox, the machines stays silent:
  no network activity and no hardrive activity after a short time
  and during 5 minutes or so
* if I do not check the checkbox, the network seems active, but
  nothing happens even after one hour.

This may be due to a network problem, I'll try later on,
but the server responds normally, so it's strange.

My try from the hard-drive failed as well and I gave the description.
What is your diagnostic concerning these tries?


------- Additional Comments From   10/13/99 04:08 -------
I had confirmationon a network problem here,
however the local installation problem from the
hard drive still remains.

My only partitions on my disk are:
hda1: windows 98
hda5: Linux (only one mount for root)
+swap
and I had RH6.1 on hda1 to install it
on hda5.

I tried to install RH6.1 on a RH5.2 system
with this disk configuration (fstab):
/dev/hda2     /       ext2     exec,dev,suid,rw 1 1
/dev/hda1     /dosc   vfat     user,noexec,nodev,nosuid,rw 0 0
/dev/hdb3    /export ext2     exec,dev,nosuid,rw 2 2
/dev/hdb4    /home/butter    ext2     exec,dev,nosuid,rw 2 2
/dev/hda3                 none                      swap   sw
/dev/hda4                 none                      swap   sw
/dev/hdb1                 none                      swap   sw
/dev/hdb2                 none                      swap   sw

and I got the same error for a local installation.

Alexandre
Comment 4 Anonymous 1999-10-21 12:48:59 EDT
Hey guys, this is really easy. If you look at the code the option has
to be 'defaults' and only 'defaults'. Everything else is ignored.

I am really a little bit astonished that this cannot be affirmed by
Redhat and here is so much discussion about it.
Comment 5 Jay Turner 1999-10-25 13:43:59 EDT
This problem is fixed by errata at
http://www.redhat.com/corp/support/errata/RHEA1999045-01.html
Comment 6 zito 1999-11-15 07:36:59 EST
This bug has not been resolved!!!! See bug 6278 harddrive install and about 6
other bugs with this same anoconda python error. This is getting old really
fast. No wonder Win Nt is gaining Market share, when the Redhat linux install
doesn't work. I really have questions in my mind when the product has a bigger
install manual that it's operating manual. What a mess!!!
Comment 7 Philip Hirschhorn 2000-01-24 06:37:59 EST
I was trying to do an upgrade from a hard drive partition, and it kept bailing
out with the python stacktrace listed above.  I finally removed the file
TRANS.TBL from the RedHat/RPMS directory, and that solved the problem.

Note You need to log in before you can comment on or make changes to this bug.