Bug 5773 - kudzu problems
kudzu problems
Status: CLOSED DUPLICATE of bug 5680
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 11:37 EDT by eloranta
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-18 13:42:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eloranta 1999-10-09 11:37:56 EDT
Couple of problematic cases for kudzu:

1) I changed ethernet card from 3c509 to 3c59x.
   In the next boot it found out that the machine
   contained 3c59x. However, it left the old 3c509
   as eth0 and added 3c59x as eth1. It should have
   tested if 3c509 was gone (modprobe?) and removed
   it first then 3c59x would have appeared as eth0.

2) PC style parallel port (parport_pc) is not detected
   at all.
Comment 1 Bill Nottingham 1999-10-11 11:16:59 EDT
1) 3c509 is an ISA card, and kudzu doesn't detect ISA stuff, so
   it doesn't know that it's gone. The current behavior is to
   assume it isn't.  We could try using modprobe as you suggested,
   but that could get ugly, as the behavior of various module probes
   is not consistent (some even load successfully even if there
   isn't a card....)
2) Add
    alias parport_lowlevel parport_pc
   to /etc/conf.modules, or update to the latest modutils
   from Raw Hide.
Comment 2 Bill Nottingham 1999-10-18 13:42:59 EDT
*** This bug has been marked as a duplicate of 5680 ***

Note You need to log in before you can comment on or make changes to this bug.