Bug 5680 - device lp0 problem
device lp0 problem
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dev (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
: 5773 5821 5862 5884 5955 5985 6061 6067 6188 6319 6364 6389 6616 6635 6703 6717 6780 7134 8278 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-07 08:51 EDT by lkrahenbil
Modified: 2008-05-01 11:37 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-07 10:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lkrahenbil 1999-10-07 08:51:14 EDT
When doing a clean install (not update)of RH6.1 over RH6.0,
device lp0 is not recognized.  Example, cannot configure
Printtool to establish a printer.

Printer would work previously under RH6.0.  This identical
situation has occurred a number of times in the last couple
of days and reported in various newsgroups since 6.1's
release.
Comment 1 Bill Nottingham 1999-10-07 10:23:59 EDT
add

alias parport_lowlevel parport_pc

to your /etc/conf.modules. Alternatively, upgrade to the latest
modutils in Raw HIde, which automatically maps the parport_lowlevel
alias.
Comment 2 Bill Nottingham 1999-10-11 10:22:59 EDT
*** Bug 5821 has been marked as a duplicate of this bug. ***

After installing RH6.1 the printer ports are
not detected when running printtool.
The error-message in /var/log/message is
cannot locate module parport_lowlevel
this can be fixed by putting the line
alias parport_lowlevel parport_pc
into
/etc/conf.modules
after this change the printer port is detected!
Comment 3 Bill Nottingham 1999-10-12 11:08:59 EDT
*** Bug 5862 has been marked as a duplicate of this bug. ***

after setting up my parallel printer it didn't work. After
adding the module parport_pc to /etc/conf.modules everything
was fine.
Comment 4 Bill Nottingham 1999-10-14 14:02:59 EDT
*** Bug 5955 has been marked as a duplicate of this bug. ***

After upgrading to RH 6.1, my printer is no longer recognized
(i.e., no devices are found when I start up printtool).  I
have a HP Laserjet 2100 connected through the parallel port.
My linux box is dual boot, and booting under windoze showed
that the printer is connected and functioning correctly.
Comment 5 Bill Nottingham 1999-10-15 11:57:59 EDT
*** Bug 5985 has been marked as a duplicate of this bug. ***

The default kernel shipping with RedHat 6.1 does see the
parallel ports correctly.

Looking at the messages, it says that it can't find
parport_lowlevel ...

This means that my parallel printer could not be detected or
configured!

Recompiling the kernel, by including parallel port support
(as opposed to modular) and IEEE1224 support etc... fixes
it! I also removed everything else I don't need.

Below, I am including my .config file. It works except for a
sysrq error message and an unresolved symbol I did not yet
fix.

You should look at the printer parts!


############################################
#
# Automatically generated make config: don't edit
#

#
# Code maturity level options
#
# CONFIG_EXPERIMENTAL is not set

#
# Processor type and features
#
# CONFIG_M386 is not set
# CONFIG_M486 is not set
# CONFIG_M586 is not set
CONFIG_M586TSC=y
# CONFIG_M686 is not set
CONFIG_X86_WP_WORKS_OK=y
CONFIG_X86_INVLPG=y
CONFIG_X86_BSWAP=y
CONFIG_X86_POPAD_OK=y
CONFIG_X86_TSC=y
CONFIG_1GB=y
# CONFIG_2GB is not set
# CONFIG_MATH_EMULATION is not set
CONFIG_MTRR=y
# CONFIG_SMP is not set

#
# Loadable module support
#
CONFIG_MODULES=y
CONFIG_MODVERSIONS=y
CONFIG_KMOD=y

#
# General setup
#
CONFIG_NET=y
CONFIG_PCI=y
# CONFIG_PCI_GOBIOS is not set
# CONFIG_PCI_GODIRECT is not set
CONFIG_PCI_GOANY=y
CONFIG_PCI_BIOS=y
CONFIG_PCI_DIRECT=y
CONFIG_PCI_QUIRKS=y
CONFIG_PCI_OLD_PROC=y
# CONFIG_MCA is not set
# CONFIG_VISWS is not set
CONFIG_SYSVIPC=y
CONFIG_BSD_PROCESS_ACCT=y
CONFIG_SYSCTL=y
CONFIG_BINFMT_AOUT=m
CONFIG_BINFMT_ELF=y
CONFIG_BINFMT_MISC=m
CONFIG_PARPORT=y
CONFIG_PARPORT_PC=y
# CONFIG_PARPORT_OTHER is not set
CONFIG_APM=y
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
# CONFIG_APM_DO_ENABLE is not set
# CONFIG_APM_CPU_IDLE is not set
# CONFIG_APM_DISPLAY_BLANK is not set
CONFIG_APM_POWER_OFF=y
# CONFIG_APM_IGNORE_MULTIPLE_SUSPEND is not set
# CONFIG_APM_IGNORE_SUSPEND_BOUNCE is not set
CONFIG_APM_RTC_IS_GMT=y
# CONFIG_APM_ALLOW_INTS is not set

#
# Plug and Play support
#
CONFIG_PNP=y
CONFIG_PNP_PARPORT=y

#
# Block devices
#
CONFIG_BLK_DEV_FD=y
CONFIG_BLK_DEV_IDE=y

#
# Please see Documentation/ide.txt for help/info on IDE
drives
#
# CONFIG_BLK_DEV_HD_IDE is not set
CONFIG_BLK_DEV_IDEDISK=y
CONFIG_BLK_DEV_IDECD=y
CONFIG_BLK_DEV_IDETAPE=m
CONFIG_BLK_DEV_IDEFLOPPY=m
CONFIG_BLK_DEV_IDESCSI=m
CONFIG_BLK_DEV_CMD640=y
# CONFIG_BLK_DEV_CMD640_ENHANCED is not set
CONFIG_BLK_DEV_RZ1000=y
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_BLK_DEV_IDEDMA=y
# CONFIG_BLK_DEV_OFFBOARD is not set
CONFIG_IDEDMA_AUTO=y
# CONFIG_IDE_CHIPSETS is not set

#
# Additional Block Devices
#
CONFIG_BLK_DEV_LOOP=m
CONFIG_BLK_DEV_NBD=m
CONFIG_BLK_DEV_MD=y
CONFIG_AUTODETECT_RAID=y
CONFIG_MD_LINEAR=m
CONFIG_MD_STRIPED=m
CONFIG_MD_MIRRORING=m
CONFIG_MD_RAID5=m
# CONFIG_MD_TRANSLUCENT is not set
# CONFIG_MD_HSM is not set
CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_INITRD=y
# CONFIG_BLK_DEV_XD is not set
CONFIG_BLK_DEV_DAC960=m
CONFIG_PARIDE_PARPORT=y
CONFIG_PARIDE=m

#
# Parallel IDE high-level drivers
#
CONFIG_PARIDE_PD=m
CONFIG_PARIDE_PCD=m
CONFIG_PARIDE_PF=m
CONFIG_PARIDE_PT=m
CONFIG_PARIDE_PG=m

#
# Parallel IDE protocol modules
#
CONFIG_PARIDE_ATEN=m
CONFIG_PARIDE_BPCK=m
CONFIG_PARIDE_COMM=m
CONFIG_PARIDE_DSTR=m
CONFIG_PARIDE_FIT2=m
CONFIG_PARIDE_FIT3=m
CONFIG_PARIDE_EPAT=m
CONFIG_PARIDE_EPIA=m
CONFIG_PARIDE_FRIQ=m
CONFIG_PARIDE_FRPW=m
CONFIG_PARIDE_KBIC=m
CONFIG_PARIDE_KTTI=m
CONFIG_PARIDE_ON20=m
CONFIG_PARIDE_ON26=m
CONFIG_BLK_CPQ_DA=m
# CONFIG_BLK_DEV_HD is not set

#
# Networking options
#
CONFIG_PACKET=y
CONFIG_NETLINK=y
CONFIG_RTNETLINK=y
CONFIG_NETLINK_DEV=y
CONFIG_FIREWALL=y
CONFIG_FILTER=y
CONFIG_UNIX=y
CONFIG_INET=y
CONFIG_IP_MULTICAST=y
# CONFIG_IP_ADVANCED_ROUTER is not set
# CONFIG_IP_PNP is not set
CONFIG_IP_FIREWALL=y
CONFIG_IP_FIREWALL_NETLINK=y
CONFIG_NETLINK_DEV=y
CONFIG_IP_TRANSPARENT_PROXY=y
CONFIG_IP_MASQUERADE=y

#
# Protocol-specific masquerading support will be built as
modules.
#
CONFIG_IP_MASQUERADE_ICMP=y

#
# Protocol-specific masquerading support will be built as
modules.
#
# CONFIG_IP_ROUTER is not set
CONFIG_NET_IPIP=m
CONFIG_NET_IPGRE=m
CONFIG_NET_IPGRE_BROADCAST=y
# CONFIG_IP_MROUTE is not set
CONFIG_IP_ALIAS=y
CONFIG_SYN_COOKIES=y

#
# (it is safe to leave these untouched)
#
CONFIG_INET_RARP=m
CONFIG_SKB_LARGE=y

#
#
#
CONFIG_IPX=m
# CONFIG_IPX_INTERN is not set
CONFIG_ATALK=m

#
# SCSI support
#
# CONFIG_SCSI is not set
CONFIG_SCSI_G_NCR5380_PORT=y
# CONFIG_SCSI_G_NCR5380_MEM is not set

#
# Network device support
#
CONFIG_NETDEVICES=y

#
# ARCnet devices
#
# CONFIG_ARCNET is not set
CONFIG_DUMMY=m
CONFIG_EQUALIZER=m
CONFIG_NET_SB1000=m

#
# Ethernet (10 or 100Mbit)
#
# CONFIG_NET_ETHERNET is not set
CONFIG_FDDI=y
# CONFIG_DEFXX is not set

#
# Appletalk devices
#
# CONFIG_LTPC is not set
# CONFIG_COPS is not set
# CONFIG_IPDDP is not set
CONFIG_PLIP=m
CONFIG_PPP=m

#
# CCP compressors for PPP are only built as modules.
#
CONFIG_SLIP=m
CONFIG_SLIP_COMPRESSED=y
CONFIG_SLIP_SMART=y
CONFIG_SLIP_MODE_SLIP6=y
CONFIG_NET_RADIO=y
CONFIG_STRIP=m
CONFIG_WAVELAN=m
CONFIG_ARLAN=m

#
# Token ring devices
#
# CONFIG_TR is not set
CONFIG_NET_FC=y
CONFIG_IPHASE5526=m

#
# Wan interfaces
#
# CONFIG_HOSTESS_SV11 is not set
# CONFIG_COSA is not set
# CONFIG_SEALEVEL_4021 is not set
# CONFIG_DLCI is not set
# CONFIG_WAN_DRIVERS is not set
CONFIG_SBNI=m

#
# Amateur Radio support
#
# CONFIG_HAMRADIO is not set

#
# IrDA subsystem support
#
# CONFIG_IRDA is not set

#
# ISDN subsystem
#
# CONFIG_ISDN is not set

#
# Old CD-ROM drivers (not SCSI, not IDE)
#
# CONFIG_CD_NO_IDESCSI is not set

#
# Character devices
#
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
CONFIG_SERIAL=y
CONFIG_SERIAL_CONSOLE=y
# CONFIG_SERIAL_EXTENDED is not set
# CONFIG_SERIAL_NONSTANDARD is not set
CONFIG_UNIX98_PTYS=y
CONFIG_UNIX98_PTY_COUNT=256
CONFIG_PRINTER=y
CONFIG_PRINTER_READBACK=y
CONFIG_MOUSE=y

#
# Mice
#
CONFIG_ATIXL_BUSMOUSE=m
CONFIG_BUSMOUSE=m
CONFIG_MS_BUSMOUSE=m
CONFIG_PSMOUSE=y
CONFIG_82C710_MOUSE=m
CONFIG_PC110_PAD=m
# CONFIG_QIC02_TAPE is not set
# CONFIG_WATCHDOG is not set
CONFIG_NVRAM=m
CONFIG_RTC=y

#
# Video For Linux
#
# CONFIG_VIDEO_DEV is not set

#
# Joystick support
#
CONFIG_JOYSTICK=m
CONFIG_JOY_ANALOG=m
CONFIG_JOY_ASSASIN=m
CONFIG_JOY_GRAVIS=m
CONFIG_JOY_LOGITECH=m
CONFIG_JOY_SIDEWINDER=m
CONFIG_JOY_THRUSTMASTER=m
CONFIG_JOY_LIGHTNING=m
CONFIG_JOY_CONSOLE=m
CONFIG_JOY_DB9=m
CONFIG_JOY_TURBOGRAFX=m
# CONFIG_DTLK is not set

#
# Ftape, the floppy tape device driver
#
# CONFIG_FTAPE is not set
CONFIG_FT_NORMAL_DEBUG=y
# CONFIG_FT_FULL_DEBUG is not set
# CONFIG_FT_NO_TRACE is not set
# CONFIG_FT_NO_TRACE_AT_ALL is not set
CONFIG_FT_STD_FDC=y
# CONFIG_FT_MACH2 is not set
# CONFIG_FT_PROBE_FC10 is not set
# CONFIG_FT_ALT_FDC is not set

#
# Filesystems
#
CONFIG_QUOTA=y
CONFIG_AUTOFS_FS=m
# CONFIG_AFFS_FS is not set
# CONFIG_HFS_FS is not set
CONFIG_FAT_FS=m
CONFIG_MSDOS_FS=m
CONFIG_UMSDOS_FS=m
CONFIG_VFAT_FS=m
CONFIG_ISO9660_FS=y
CONFIG_JOLIET=y
CONFIG_MINIX_FS=m
# CONFIG_NTFS_FS is not set
CONFIG_HPFS_FS=m
CONFIG_PROC_FS=y
CONFIG_DEVPTS_FS=y
CONFIG_ROMFS_FS=m
CONFIG_EXT2_FS=y
CONFIG_SYSV_FS=m
CONFIG_UFS_FS=m
# CONFIG_UFS_FS_WRITE is not set

#
# Network File Systems
#
CONFIG_CODA_FS=m
# CONFIG_NFS_FS is not set
# CONFIG_SUNRPC is not set
# CONFIG_LOCKD is not set
# CONFIG_SMB_FS is not set
# CONFIG_NCP_FS is not set

#
# Partition Types
#
# CONFIG_BSD_DISKLABEL is not set
# CONFIG_MAC_PARTITION is not set
# CONFIG_SMD_DISKLABEL is not set
# CONFIG_SOLARIS_X86_PARTITION is not set
CONFIG_NLS=y

#
# Native Language Support
#
CONFIG_NLS_CODEPAGE_437=m
CONFIG_NLS_CODEPAGE_737=m
CONFIG_NLS_CODEPAGE_775=m
CONFIG_NLS_CODEPAGE_850=m
CONFIG_NLS_CODEPAGE_852=m
CONFIG_NLS_CODEPAGE_855=m
CONFIG_NLS_CODEPAGE_857=m
CONFIG_NLS_CODEPAGE_860=m
CONFIG_NLS_CODEPAGE_861=m
CONFIG_NLS_CODEPAGE_862=m
CONFIG_NLS_CODEPAGE_863=m
CONFIG_NLS_CODEPAGE_864=m
CONFIG_NLS_CODEPAGE_865=m
CONFIG_NLS_CODEPAGE_866=m
CONFIG_NLS_CODEPAGE_869=m
CONFIG_NLS_CODEPAGE_874=m
CONFIG_NLS_ISO8859_1=m
CONFIG_NLS_ISO8859_2=m
CONFIG_NLS_ISO8859_3=m
CONFIG_NLS_ISO8859_4=m
CONFIG_NLS_ISO8859_5=m
CONFIG_NLS_ISO8859_6=m
CONFIG_NLS_ISO8859_7=m
CONFIG_NLS_ISO8859_8=m
CONFIG_NLS_ISO8859_9=m
CONFIG_NLS_ISO8859_14=m
CONFIG_NLS_ISO8859_15=m
CONFIG_NLS_KOI8_R=m

#
# Console drivers
#
CONFIG_VGA_CONSOLE=y
CONFIG_VIDEO_SELECT=y

#
# Sound
#
CONFIG_SOUND=m
CONFIG_SOUND_ES1370=m
CONFIG_SOUND_ES1371=m
CONFIG_SOUND_SONICVIBES=m
CONFIG_SOUND_MSNDCLAS=m
# CONFIG_MSNDCLAS_HAVE_BOOT is not set
CONFIG_MSNDCLAS_INIT_FILE="/etc/sound/msndinit.bin"
CONFIG_MSNDCLAS_PERM_FILE="/etc/sound/msndperm.bin"
CONFIG_SOUND_MSNDPIN=m
# CONFIG_MSNDPIN_HAVE_BOOT is not set
CONFIG_MSNDPIN_INIT_FILE="/etc/sound/pndspini.bin"
CONFIG_MSNDPIN_PERM_FILE="/etc/sound/pndsperm.bin"
CONFIG_SOUND_OSS=m
CONFIG_SOUND_PAS=m
CONFIG_SOUND_SB=m
CONFIG_SOUND_ADLIB=m
CONFIG_SOUND_GUS=m
CONFIG_GUS16=y
CONFIG_GUSMAX=y
CONFIG_SOUND_MPU401=m
CONFIG_SOUND_PSS=m
# CONFIG_PSS_MIXER is not set
CONFIG_SOUND_MSS=m
CONFIG_SOUND_SSCAPE=m
CONFIG_SOUND_TRIX=m
CONFIG_SOUND_VIA82CXXX=m
CONFIG_SOUND_MAD16=m
CONFIG_MAD16_OLDCARD=y
CONFIG_SOUND_WAVEFRONT=m
CONFIG_SOUND_CS4232=m
CONFIG_SOUND_OPL3SA2=m
CONFIG_SOUND_MAUI=m
CONFIG_SOUND_SGALAXY=m
CONFIG_SOUND_OPL3SA1=m
CONFIG_SOUND_SOFTOSS=m
CONFIG_SOUND_YM3812=m
CONFIG_SOUND_VMIDI=m
CONFIG_SOUND_UART6850=m
CONFIG_SOUND_NM256=m

#
# Additional low level sound drivers
#
CONFIG_LOWLEVEL_SOUND=y
CONFIG_ACI_MIXER=m
CONFIG_AWE32_SYNTH=m
CONFIG_AEDSP16=m
CONFIG_AEDSP16_BASE=220
CONFIG_MPU_BASE=330

#
# SC-6600 Audio Cards have no jumper switches at all
#
CONFIG_SC6600=y

#
# SC-6600 specific configuration
#
CONFIG_SC6600_JOY=y
CONFIG_SC6600_CDROM=4
CONFIG_SC6600_CDROMBASE=0
CONFIG_AEDSP16_SBPRO=y

#
# Audio Excel DSP 16 [Sound Blaster Pro]
#
CONFIG_AEDSP16_BASE=220
CONFIG_AEDSP16_SB_IRQ=5
CONFIG_AEDSP16_SB_DMA=0
CONFIG_AEDSP16_MPU401=y

#
# Audio Excel DSP 16 [MPU-401]
#
CONFIG_AEDSP16_MPU_IRQ=5

#
# Kernel hacking
#
# CONFIG_MAGIC_SYSRQ is not set


#############################################


Just do a diff to see differences, but you already know
that!
Comment 6 Bill Nottingham 1999-10-18 13:41:59 EDT
*** Bug 5884 has been marked as a duplicate of this bug. ***

I have and Iomega Zip Drive (100, Parallel) connected to my
home workstation.  After upgrading from Red Hat 6.0 to 6.1,
I can no longer load the 'ppa' kernel module which is needed
to use the drive.

To test the problem, I set a new, fresh install of Red Hat
6.1 on a different PC (at work, had a different Zip drive
attached, but same model.)  I had the same results:

when I run 'dmesg' after system startup, there are no ppa,
parport or scsi messages listed.  'lsmod' initially shows:
Module                  Size  Used by
3c59x                  19112   1  (autoclean)
nls_iso8859-1           2020   1  (autoclean)
nls_cp437               3548   1  (autoclean)
vfat                    9180   1  (autoclean)
fat                    30464   1  (autoclean)[vfat]

I then run:
[root@computer /root]# modprobe ppa
/lib/modules/2.2.12-20/scsi/ppa.o: init_module: Device or
resource busy
parport: Device or resource busy
[root@computer /root]#

'dmesg' then shows:
ppa: Version 2.03 (for Linux 2.2.x)
ppa: parport reports no devices.
scsi : 0 hosts.

now 'lsmod' shows:
Module                  Size  Used by
parport_probe           2980   0  (autoclean)(unused)
parport                 7124   0  [parport_probe]
3c59x                  19112   1  (autoclean)
nls_iso8859-1           2020   1  (autoclean)
nls_cp437               3548   1  (autoclean)
vfat                    9180   1  (autoclean)
fat                    30464   1  (autoclean)[vfat]



------- Additional Comments From notting@redhat.com  10/12/99 14:31 -------
Add 'alias parport_lowlevel parport_pc' to /etc/conf.modules.
Comment 7 Bill Nottingham 1999-10-18 13:42:59 EDT
*** Bug 5773 has been marked as a duplicate of this bug. ***


Couple of problematic cases for kudzu:

1) I changed ethernet card from 3c509 to 3c59x.
   In the next boot it found out that the machine
   contained 3c59x. However, it left the old 3c509
   as eth0 and added 3c59x as eth1. It should have
   tested if 3c509 was gone (modprobe?) and removed
   it first then 3c59x would have appeared as eth0.

2) PC style parallel port (parport_pc) is not detected
   at all.



------- Additional Comments From notting@redhat.com  10/11/99 11:16 -------
1) 3c509 is an ISA card, and kudzu doesn't detect ISA stuff, so
   it doesn't know that it's gone. The current behavior is to
   assume it isn't.  We could try using modprobe as you suggested,
   but that could get ugly, as the behavior of various module probes
   is not consistent (some even load successfully even if there
   isn't a card....)
2) Add
    alias parport_lowlevel parport_pc
   to /etc/conf.modules, or update to the latest modutils
   from Raw Hide.
Comment 8 Bill Nottingham 1999-10-18 14:36:59 EDT
*** Bug 6061 has been marked as a duplicate of this bug. ***

I have two machines (one is brand new).  The old machine
was running RH 5.2.  The new one came with RH 6.0 installed
on it.

I have an HP LaserJet 4L installed on the RH5.2 box that
works, also with Samba from a 95 box.

I upgraded the older box to RH6.1.  Printing still worked.

I installed RH6.1 on the new box (fresh install).  I tried
to add the printer via Control Panel (I physically plugged
the printer into the new box).  Control Panel says that
there are no active parallel ports.  That msg also comes
out at boot time.  It says no parallel ports were found but
it will load the printer driver anyway.

I went back to the older box (now with RH6.1) and deleted
the HP laserjet driver in Control Panel | Printers.  Then I
tried to add it again.  Now the old box says that there are
no active parallel ports.

thanks

david sampson

dsampson@mindpsring.com
Comment 9 Bill Nottingham 1999-10-18 17:11:59 EDT
*** Bug 6067 has been marked as a duplicate of this bug. ***

Seems (full) fresh installs of RH61 forget to make an alias
in /etc/conf.modules aliasing parport_lowlevel to parport_pc
(or whatnot). Result: No /dev/lpx ports available for
printing. Message (see summary) in /var/log/messages
pointing to the obvious reason for this problem though.
Simply add this to /etc/conf.modules to fix the problem :
alias parport_lowlevel parport_pc

Problem verified with other RH61 user who concurs on the
phenomena.
Comment 10 Bill Nottingham 1999-10-21 13:41:59 EDT
*** Bug 6188 has been marked as a duplicate of this bug. ***

Printtool does not recognize the lp devices.  This is
because the parport_pc module is not loaded.  The fix is to
unload all modules, then modprobe parport_pc , then modprobe
lp, then run printtool and go about your life.
Comment 11 Bill Nottingham 1999-10-25 11:23:59 EDT
*** Bug 6319 has been marked as a duplicate of this bug. ***

In version 6.1, neither of my parallel port cards are
recognized, though they are recognized in 6.0
Comment 12 Bill Nottingham 1999-10-26 11:02:59 EDT
*** Bug 6364 has been marked as a duplicate of this bug. ***

After upgrading to 6.1 on two systems (one 5.2, the other
6.0,) the systems failed to detect the printer port on
following reboots.  Device files were not created in /dev
directory during upgrade.  Manually did mkdev to create
device files - but subsequent attempts to access the file
for the printer port gave 'No such device' errors.  Did not
find MAKEDEV script in /dev.
Comment 13 Bill Nottingham 1999-10-26 11:03:59 EDT
*** Bug 6362 has been marked as a duplicate of this bug. ***

I have an HP 722c and I just noticed that the new
printfilters have native support for my printer, however,
nothing seems to be working.  I open up printtool and select
add a printer, and it does not auto-detect my printer.  If I
manually select when I attempt to print any type of test
page it does not do anything, no matter what port I set the
printer to, so I do not know what is wrong with it or what I
am doing wrong.  I would appreciate any help.  Thank you
	Sean Waters
	spw5@cec.wustl.edu
Comment 14 Bill Nottingham 1999-11-01 12:01:59 EST
*** Bug 6389 has been marked as a duplicate of this bug. ***

General: RH 6.1 is an unmitigated disaster. First, upon my
attempt to upgrade from 6.0 it trashed the hard drive so
the system would no longer boot. After I reinstalled from
scratch it wouldn't recognize my Ethernet card or my
printer port (RH 6.0 had no problem with either). I
manually fixed my ethernet setup but it still refuses
torecognize my parallel port for the printer. It has also
trashed two of my user directories so that it is not
possible to log in to them.
Is there any reason why I should not revert to 6.0 and get
on with my life?


------- Additional Comments From notting@redhat.com  10/26/99 14:43 -------
To fix the printer add

alias parport_lowlevel parport_pc

to /etc/conf.modules.
Comment 15 Bill Nottingham 1999-11-01 17:33:59 EST
*** Bug 6616 has been marked as a duplicate of this bug. ***

Dear Sir:

I found a simple error in RH 6.1's kernel default for
server, custom, or workstation installs.  A local printer is
not compiled into the kernel.  I don't know if this was
intentional or not, although it a simple misconfiguration.
Take care.
Comment 16 Bill Nottingham 1999-11-02 13:24:59 EST
*** Bug 6635 has been marked as a duplicate of this bug. ***

After installing Red Hat 6.1 you cannot install the printer
using printtool.

------- Additional Comments From wcox@ruraltel.net  11/01/99 21:08 -------
Cannot install printer using printtool.
Comment 17 Bill Nottingham 1999-11-04 11:37:59 EST
*** Bug 6717 has been marked as a duplicate of this bug. ***

I've completed a full installation of RH 6.1, and found
that none of the parallel ports are recognised, and
therefore my printer is unavailable. The ports do work
under Windoze 98, and worked under a previous installation
of RH 6.0.
Comment 18 Bill Nottingham 1999-11-04 11:42:59 EST
*** Bug 6703 has been marked as a duplicate of this bug. ***

On my machine (and I tried 2) 6.0 works and the printer on
the parallel port works.  When I upgraded to 6.1 the
parallel port stopped working.  Backing the box off to 6.0
makes the parallel port work again.
What is going on.
Comment 19 Bill Nottingham 1999-11-08 10:44:59 EST
*** Bug 6780 has been marked as a duplicate of this bug. ***

Unable to install printer using CONTROL-PANEL; program fails
to find any printer port.  Linux-5.2 and Linux 6.0 did not
exhibit this problem. My printer port is an on-board port on
a SUPERMICRO P5MMS98 motherboard, configured for AUTO
address selection, BI-DIRECTION.

Was able to work around by loading LINUX 6.0 and using 6.1
to update.
Comment 20 Bill Nottingham 1999-11-19 11:30:59 EST
*** Bug 7134 has been marked as a duplicate of this bug. ***
Comment 21 Nalin Dahyabhai 2000-02-04 21:09:59 EST
*** Bug 8278 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.