Bug 577312 - install: X startup failed, falling back to text mode
install: X startup failed, falling back to text mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
: Triaged
: 582274 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-26 12:50 EDT by John Reiser
Modified: 2010-09-12 15:43 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-13.39-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 18:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/X.log (7.63 KB, text/plain)
2010-03-26 12:50 EDT, John Reiser
no flags Details
lspci; lspci -n; lspci -v (9.78 KB, text/plain)
2010-03-26 12:52 EDT, John Reiser
no flags Details
/tmp/syslog (55.23 KB, text/plain)
2010-03-26 12:58 EDT, John Reiser
no flags Details
/tmp/X.log (7.63 KB, text/plain)
2010-03-27 10:44 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2010-03-26 12:50:40 EDT
Created attachment 402889 [details]
/tmp/X.log

Description of problem: During fresh install from Fedora 13-beta-RC1 x86_64 DVD, selecting "Install with basic video driver" results in "X startup failed, falling back to text mode".  The install proceeds with only VGA character-cell "graphics" instead of X11 graphics.


Version-Release number of selected component (if applicable):
xorg-x11-server 1.7.99.902-2.20100319.fc13


How reproducible: every time


Steps to Reproduce:
1. Boot Fedora 13-beta-RC1 x86_64 DVD
2. Select Install with basic video driver
3.
  
Actual results: X startup failed, falling back to text mode


Expected results: uses X11 graphics during install


Additional info:
Comment 1 John Reiser 2010-03-26 12:52:18 EDT
Created attachment 402890 [details]
lspci; lspci -n; lspci -v

05:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE] (rev a1)
Comment 2 John Reiser 2010-03-26 12:58:01 EDT
Created attachment 402892 [details]
/tmp/syslog

16:26:58,390 INFO kernel:[drm] Initialized drm 1.1.0 20060810
16:26:58,622 INFO kernel:[drm] nouveau 0000:05:00.0: Detected an NV40 generation card (0x246300b1)
16:26:58,623 INFO kernel:[drm] Initialized nouveau 0.0.16 20090420 for 0000:05:00.0 on minor 0
16:28:31,165 ERR kernel:[drm] nouveau 0000:05:00.0: called without init
Comment 3 John Reiser 2010-03-27 10:44:19 EDT
Created attachment 403010 [details]
/tmp/X.log

Same problem on a recent card:

07:27:29,124 INFO kernel:[drm] Initialized drm 1.1.0 20060810
07:27:29,534 INFO kernel:[drm] nouveau 0000:01:00.0: Detected an NV50 generation card (0x0a5000a2)
07:27:29,535 INFO kernel:[drm] Initialized nouveau 0.0.16 20090420 for 0000:01:00.0 on minor 0
07:28:00,362 ERR kernel:[drm] nouveau 0000:01:00.0: called without init

01:00.0 VGA compatible controller: nVidia Corporation Device 0a20 (rev a2)
01:00.0 0300: 10de:0a20 (rev a2)
01:00.0 VGA compatible controller: nVidia Corporation Device 0a20 (rev a2) (prog-if 00 [VGA controller])
        Subsystem: XFX Pine Group Inc. Device 294a
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at ce000000 (64-bit, prefetchable) [size=32M]
        I/O ports at dc00 [size=128]
        Expansion ROM at fea80000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [b4] Vendor Specific Information: Len=14 <?>
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Comment 4 Matěj Cepl 2010-03-31 10:33:30 EDT
This is weird ... you ask for vesa and you get nouveau. Assigning to xserver, there is something weird there.
Comment 5 Matěj Cepl 2010-03-31 11:39:12 EDT
Seems like whoever-is-responsible for writing xorg.conf in cases user asks for xdriver=vesa didn't do its job. It could be possibly confused by /etc/xorg.conf.d which is a new thing in Fedora 13.

Reassigning to anaconda without prejudice for getting it back if it is shown to be Xorg bug after all.
Comment 6 Matěj Cepl 2010-03-31 11:41:47 EDT
Auch, sorry, taking it back.
Comment 7 Martin Sivák 2010-04-01 04:41:44 EDT
It looks like the change might have been introduced by anaconda patch e146251c0bd1b9325401eb15b9b157d886a8ff4a from Mon Dec 21 10:20:47 2009 -0500.

We used to write /etc/X11/xorg.conf during the initialization of anaconda and then another one to /mnt/sysimage/etc/X11/xorg.conf during the configuration of the installed system.

This patch changed it and the file is being written to /mnt/sysimage/etc/X11/xorg.conf on both calls.

So I think it is our fault and also F13Blocker.

What is the proper place to put Device section with driver selection now? Should we use /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/anaconda for example?
Comment 8 Martin Sivák 2010-04-01 11:14:38 EDT
Commited to anaconda as 2b9955806d2a2f735898456963676d941d07b7c9.
Comment 9 Martin Sivák 2010-04-14 11:17:26 EDT
*** Bug 582274 has been marked as a duplicate of this bug. ***
Comment 10 Joshua Kwan 2010-04-26 14:13:34 EDT
Hi, is this fix going to RHEL 6? It seems to be a problem there too when using kickstart.
Comment 11 Chris Lumens 2010-04-26 14:40:34 EDT
No, because commit e146251c0bd1b9325401eb15b9b157d886a8ff4a caused this, and that was never committed to rhel6-branch.  If you are seeing something, it's likely caused by something else.  Please file a new bug with new information.
Comment 12 Adam Williamson 2010-05-03 18:58:02 EDT
Tested TC1, this is fixed: selecting Basic Graphics mode gives you a graphical install with vesa (confirmed by checking the /etc/X11/xorg.conf file and /tmp/X.log).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Andre Robatino 2010-09-11 19:49:42 EDT
I've reported bug 632805 which looks similar to this, for 14 Beta TC1.
Comment 14 Adam Williamson 2010-09-12 15:43:11 EDT
Nope, it's not. It's just a known bug between vesa driver and qemu.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.