Bug 582274 - Install CD ignores xdriver setting
Summary: Install CD ignores xdriver setting
Keywords:
Status: CLOSED DUPLICATE of bug 577312
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Sivák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-14 14:33 UTC by kantras
Modified: 2010-04-14 15:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-14 15:17:26 UTC


Attachments (Terms of Use)

Description kantras 2010-04-14 14:33:20 UTC
Description of problem:

Install CD ignores xdriver setting, only using autodetection of graphics card. This means a graphical install can not be performed on a Dell PE850 as it has an XGI graphics card and the driver is not included.

Version-Release number of selected component (if applicable):

F13

How reproducible:

Every time

Steps to Reproduce:

1. Boot from live cd, passing xdriver=vesa as a commandline option
  
Actual results:

/tmp/X.log shows it tries to load the xgi driver, fails and exits

Expected results:

Xorg should try to use the vesa driver instead

Additional info:

I noted that it created a file under /mnt/sysimage/etc/X11/xorg.conf to specify the driver, however Xorg doesn't appear to be using it. It is using the config directory /etc/xorg.conf.d

Comment 1 Chris Lumens 2010-04-14 14:57:58 UTC
What release of anaconda is this?  This should be fixed according to bug 577312.

Comment 2 kantras 2010-04-14 15:14:35 UTC
I was using the F13 Beta Install CDs that were released yesterday.

Comment 3 Martin Sivák 2010-04-14 15:17:26 UTC
The patch is present in our f13-branch, but we haven't built any new version since it was introduced because of the upcoming beta. It should get into the distribution's f13 version soon now that beta is out.

*** This bug has been marked as a duplicate of bug 577312 ***


Note You need to log in before you can comment on or make changes to this bug.