Bug 57745 - Please improve xfs logging by indicating full /tmp
Please improve xfs logging by indicating full /tmp
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
: 64963 75442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 12:18 EST by Daniel Morris
Modified: 2007-03-26 23:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 14:21:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Morris 2001-12-20 12:18:39 EST
Description of Problem:
file system filled up just prior to a power cut, after rebuilding fs, &
tracking down why X won't start I finally determined that xfs couldn't
create /tmp/.font-unix due to no space (when fed with -droppriv -daemon as
per the start up scripts). It would have been really nice if xfs had
actually logged something sensible along the lines of mkdir failed with
ERR=28 via syslog, rather than just stopping.

Version-Release number of selected component (if applicable):


How Reproducible:
I'm not sure I want to.

Steps to Reproduce:
1. Fill up fs with /tmp on it
2. init 6
3. wait for X to stop trying to respawn.
4. login as root and 'xfs -droppriv', there's a real error message.
5. 'service xfs start' yields nothing (after deleting /var/run/xfs.pid
/var/lock/subsys/xfs)

Actual Results:
nothing logged via syslog as per the config file

Expected Results:
a little clue in the logs to track down why xfs was dying

Additional Information:
Comment 1 Kevin Range 2002-03-20 09:09:23 EST
I got burned by this also.  It took me quite a while to figure out why xfs was
dying, especially when /var/log/messages only reported the sucessful startup of
xfs and not its subsequent failure milliseconds later.
Comment 2 Mike A. Harris 2002-05-21 12:51:02 EDT
*** Bug 64963 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2002-11-03 01:19:40 EST
Ok, I'm planning on fixing this before the next release. I didn't really
consider it a big issue before, but enough people have reported the
problem to me now that I've rethought it out and now consider it to be
something that really needs to be fixed.

It should be fixed before 4.3.0 comes out.  I'll probably backport the
fix and put it into any future erratum of 4.2.0 and 4.1.0 too.
Comment 4 Mike A. Harris 2002-11-03 03:34:37 EST
*** Bug 75442 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2002-12-20 14:07:05 EST
It appears that xfs in rawhide currently solves this problem:

Dec 20 11:05:32 claw Font Server[529]: terminating
Dec 20 11:05:33 claw xfs: xfs shutdown succeeded
Dec 20 11:20:25 claw syslogd: /var/log/maillog: No space left on device
Dec 20 13:06:39 claw xfs: listening on port 7100
Dec 20 13:06:39 claw xfs: Warning: font renderer for ".pfa" registered more than
once
Dec 20 13:06:39 claw xfs: Warning: font renderer for ".pfb" registered more than
once
Dec 20 13:47:21 claw sshd(pam_unix)[15137]: session opened for user root by (uid=0)
Dec 20 13:47:21 claw sshd(pam_unix)[15137]: session closed for user root
Dec 20 13:47:39 claw sshd(pam_unix)[15146]: session opened for user root by (uid=0)
Dec 20 13:47:39 claw sshd(pam_unix)[15146]: session closed for user root
Dec 20 13:49:25 claw sshd(pam_unix)[15164]: session opened for user root by (uid=0)
Dec 20 13:49:25 claw sshd(pam_unix)[15164]: session closed for user root
Dec 20 13:50:10 claw xfs: cannot establish any listening sockets

It at least appears to either work, or to explode and log it for me anyway.
However this of course only works if /var/log has space on it too.
Comment 6 Mike A. Harris 2002-12-20 14:15:55 EST
[root@claw root]# date ; killall -9 xfs ; cat /dev/urandom > /tmp/fillme ;df ;
service xfs start ; tail /var/log/messages ; date
Fri Dec 20 14:21:36 EST 2002
cat: write error: No space left on device
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda5              8254240   8254240         0 100% /
/dev/hda2               124443     17156    100861  15% /boot
none                    256976         0    256976   0% /dev/shm
Starting xfs:                                              [  OK  ]
Dec 20 14:18:53 claw xfs: cannot establish any listening sockets
Dec 20 14:18:53 claw xfs: Warning: font renderer for ".pfa" registered more than
once
Dec 20 14:18:53 claw xfs: Warning: font renderer for ".pfb" registered more than
once
Dec 20 14:19:36 claw xfs[15316]: terminating
Dec 20 14:20:13 claw xfs: xfs startup succeeded
Dec 20 14:20:13 claw xfs: cannot establish any listening sockets
Dec 20 14:20:13 claw xfs: Warning: font renderer for ".pfa" registered more than
once
Dec 20 14:20:13 claw xfs: Warning: font renderer for ".pfb" registered more than
once
Dec 20 14:21:36 claw xfs: cannot establish any listening sockets
Dec 20 14:21:36 claw xfs: Warning: font renderer for ".pfa" registered more than
once
Fri Dec 20 14:21:36 EST 2002
Comment 7 Mike A. Harris 2002-12-20 14:21:19 EST
I think the above now shows that xfs is fixed now in current CVS.

If you experience this problem again in RHL 8.0 or higher, or using a rawhide
XFree86 in RHL 8.0, please reopen the bug report.  Also, if someone could
report to me wether or not this problem occurs in RHL 7.3 or 8.0 stock
with XFree86 4.2.0 or 4.2.1, it would be much appreciated.  I'm willing
to consider backporting whatever the fix was if someone tests it to find
if it is needed and worth the bother.  In either case please reopen if
problem occurs again in any release 7.3 or later.

Sorry for the delay digging into this one.

Closing as fixed in RAWHIDE for now

Note You need to log in before you can comment on or make changes to this bug.