Bug 578017 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: baekmuk-ttf-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
: 546490 563409 (view as bug list)
Depends On: 578015
Blocks: F13Target 586849
  Show dependency treegraph
 
Reported: 2010-03-29 23:26 EDT by Akira TAGOH
Modified: 2010-05-05 23:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: baekmuk-ttf-fonts-2.2-25.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586849 (view as bug list)
Environment:
Last Closed: 2010-04-26 22:26:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:26:25 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 65-baekmuk-ttf-batang.conf
 65-baekmuk-ttf-dotum.conf
 65-baekmuk-ttf-gulim.conf
Comment 1 Fedora Update System 2010-04-21 02:59:47 EDT
baekmuk-ttf-fonts-2.2-25.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/baekmuk-ttf-fonts-2.2-25.fc13
Comment 2 Fedora Update System 2010-04-21 17:52:49 EDT
baekmuk-ttf-fonts-2.2-25.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update baekmuk-ttf-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/baekmuk-ttf-fonts-2.2-25.fc13
Comment 3 Jens Petersen 2010-04-21 22:43:01 EDT
*** Bug 563409 has been marked as a duplicate of this bug. ***
Comment 4 Akira TAGOH 2010-04-26 01:05:58 EDT
Testing result:
# rpm -qa baekmuk-ttf-*
baekmuk-ttf-batang-fonts-2.2-25.fc13.noarch
baekmuk-ttf-gulim-fonts-2.2-25.fc13.noarch
baekmuk-ttf-fonts-ghostscript-2.2-25.fc13.noarch
baekmuk-ttf-fonts-common-2.2-25.fc13.noarch
baekmuk-ttf-hline-fonts-2.2-25.fc13.noarch
baekmuk-ttf-dotum-fonts-2.2-25.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ko
gulim.ttf: "Baekmuk Gulim" "Regular"
# fc-match monospace:lang=ko-kr
UnDotum.ttf: "UnDotum" "Regular"

  <test name="lang">
    <string>ko</string>
  </test>

  should be

  <test name="lang">
    <string>ko-kr</string>
  </test>

plus, the above reasult is from 65-nonlatin.conf since 65-baekmuk-ttf-gulim.conf is supposed to be applied for monospace and 65-baekmuk-dotum.conf is for sans-serif. to get that working, you should rename 65-baekmuk-* to 65-0-baekmuk-* or something like that.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ko
dotum.ttf: "Baekmuk Dotum" "Regular"
# fc-match sans:lang=ko-kr
wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"

Due to the same reason above, the unexpected fonts was picked up for ko-kr.

# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ko
batang.ttf: "Baekmuk Batang" "Regular"
# fc-match serif:lang=ko-kr
wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"

Due to the same reason above, the unexpected fonts was picked up for ko-kr.

# for i in $(ls /usr/share/locale|grep -v -E "^(ko)$"); do fc-match sans:lang=$i|grep -E "^(Baekmuk .*)$"; [ $? = 0 ] && echo $i; done
#
# for i in $(ls /usr/share/locale|grep -v -E "^(ko)$"); do fc-match serif:lang=$i|grep -E "^(Baekmuk .*)$"; [ $? = 0 ] && echo $i; done
#
# for i in $(ls /usr/share/locale|grep -v -E "^(ko)$"); do fc-match monospace:lang=$i|grep -E "^(Baekmuk .*)$"; [ $? = 0 ] && echo $i; done
#

That looks good.
Comment 5 Jens Petersen 2010-04-26 02:29:41 EDT
(In reply to comment #4)
> you should rename
> 65-baekmuk-* to 65-0-baekmuk-* or something like that.

Yeah - just remember that un-core-fonts is preferred, so
Baekmuk ttf should have lower priority than Un Core fonts.
Comment 6 Fedora Update System 2010-04-26 22:26:15 EDT
baekmuk-ttf-fonts-2.2-25.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Jens Petersen 2010-05-05 23:41:08 EDT
*** Bug 546490 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.