Bug 578018 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: culmus-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586834
  Show dependency treegraph
 
Reported: 2010-03-29 23:28 EDT by Akira TAGOH
Modified: 2010-04-30 19:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: culmus-fonts-0.104-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586834 (view as bug list)
Environment:
Last Closed: 2010-04-30 19:49:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:28:53 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 65-culmus-aharoni-clm.conf
 65-culmus-david-clm.conf
 65-culmus-drugulin-clm.conf
 65-culmus-ellinia-clm.conf
 65-culmus-frank-ruehl-clm.conf
 65-culmus-miriam-clm.conf
 65-culmus-miriam-mono-clm.conf
 65-culmus-nachlieli-clm.conf
Comment 1 Fedora Update System 2010-04-19 05:16:26 EDT
culmus-fonts-0.104-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/culmus-fonts-0.104-3.fc13
Comment 2 Pravin Satpute 2010-04-19 05:25:28 EDT
fixed in culmus-fonts-0.104-3.fc14
Comment 3 Fedora Update System 2010-04-20 09:16:24 EDT
culmus-fonts-0.104-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update culmus-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/culmus-fonts-0.104-3.fc13
Comment 4 Akira TAGOH 2010-04-21 03:39:32 EDT
Testing result:
# rpm -qa culmus-\*
culmus-ellinia-clm-fonts-0.104-3.fc13.noarch
culmus-david-clm-fonts-0.104-3.fc13.noarch
culmus-miriam-clm-fonts-0.104-3.fc13.noarch
culmus-nachlieli-clm-fonts-0.104-3.fc13.noarch
culmus-fonts-compat-0.104-3.fc13.noarch
culmus-fonts-common-0.104-3.fc13.noarch
culmus-drugulin-clm-fonts-0.104-3.fc13.noarch
culmus-frank-ruehl-clm-fonts-0.104-3.fc13.noarch
culmus-caladings-clm-fonts-0.104-3.fc13.noarch
culmus-miriam-mono-clm-fonts-0.104-3.fc13.noarch
culmus-aharoni-clm-fonts-0.104-3.fc13.noarch
culmus-yehuda-clm-fonts-0.104-3.fc13.noarch
# fc-match monospace:lang=he-il
DavidCLM-Medium.ttf: "David CLM" "Medium"
# fc-match monospace:lang=he
DavidCLM-Medium.ttf: "David CLM" "Medium"
# fc-match monospace:lang=en
DajaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DajaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match serif:lang=he-il
DavidCLM-Medium.ttf: "David CLM" "Medium"
# fc-match serif:lang=he
FrankRuehlCLM-Medium.pfa: "Frank Ruehl CLM" "Medium"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match sans:lang=he-il
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=he
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"


Well, basically the above result looks good. for the result of the query of sans, DejaVu Sans has the he support and it's added to the list prior to culums-fonts. it's out of interests in this bug. if you want to make culmus-fonts default for he-il, please bring it up on fonts list or talk to DejaVu fonts maintainer.

Aside from that, right now all fontconfig config files for culmus-fonts has 65- prefix. which fonts are selected by fontconfig depends on which package one installs and the alphabetical order. so please add the certain prefix if you want to.
Comment 5 Akira TAGOH 2010-04-21 03:58:37 EDT
one more interesting result:
# for i in $(ls /usr/share/locale|grep -v -E '^he');do fc-match monospace:lang=$i|grep CLM; [ $? = 0 ] && echo $i; done
DavidCLM-Medium.ttf: "David CLM" "Medium"
yi


Apparently we don't have any rules in fontconfig for Yiddish though, we may need yi.orth in fontconfig if we want to make them difference? anyway, this result looks different issue. I'll waive this so far.
Comment 6 Pravin Satpute 2010-04-21 04:07:23 EDT
i think it will be nice if we take review from some he user for making culmus default instead of Dejavu.

presently Dejavu has conf file with 57/58 prefix, so i think culmus conf file not making any problem for priority. So might be 65 is ok
Comment 7 Akira TAGOH 2010-04-21 04:22:46 EDT
Doh, nevermind. DavidCLM-Medium.ttf just has the yi support in the lang.
Comment 8 Akira TAGOH 2010-04-21 04:33:55 EDT
(In reply to comment #6)
> i think it will be nice if we take review from some he user for making culmus
> default instead of Dejavu.
> 
> presently Dejavu has conf file with 57/58 prefix, so i think culmus conf file
> not making any problem for priority. So might be 65 is ok    

Well, the problem is that. without any solutions in DejaVu, what we have options to make a priority to culmus-fonts for Hebrew users are:

1. use the strong binding
2. add higher priority to culmus-fonts than DejaVu
3. use the prepend_first

Though I'd not recommend any of them, 1 may be more realistic.
Comment 9 Fedora Update System 2010-04-30 19:49:13 EDT
culmus-fonts-0.104-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.