Bug 578020 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ipa-gothic-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586837
  Show dependency treegraph
 
Reported: 2010-03-29 23:32 EDT by Akira TAGOH
Modified: 2010-05-10 19:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-gothic-fonts-003.02-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586837 (view as bug list)
Environment:
Last Closed: 2010-05-10 19:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:32:50 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 66-ipa-gothic.conf
Comment 1 Akira TAGOH 2010-04-16 07:28:01 EDT
fixed in ipa-gothic-fonts-003.02-3.fc13.
Comment 2 Fedora Update System 2010-04-16 07:29:35 EDT
ipa-gothic-fonts-003.02-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ipa-gothic-fonts-003.02-3.fc13
Comment 3 Fedora Update System 2010-04-16 19:48:54 EDT
ipa-gothic-fonts-003.02-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ipa-gothic-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ipa-gothic-fonts-003.02-3.fc13
Comment 4 Akira TAGOH 2010-04-26 05:36:15 EDT
Testing result without vlgothic-fonts due to the priority thing:
# rpm -qa ipa-gothic-fonts
ipa-gothic-fonts-003.02-3.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ja
ipag.ttf: "IPAGothic" "Regular"
# fc-match monospace:lang=ja-jp
ipag.ttf: "IPAGothic" "Regular"

That looks good though, that may be good to not use compare="contains" since fontconfig matches other languages with it. though it's luckily not appearing due to the priority etc.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ja
ipag.ttf: "IPAGothic" "Regular"
# fc-match sans:lang=ja-jp
ipag.ttf: "IPAGothic" "Regular"

That looks good.

# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ja
ipag.ttf: "IPAGothic" "Regular"
# fc-match serif:lang=ja-jp
ipag.ttf: "IPAGothic" "Regular"

No explicit rules for serif in ipa-gothic-fonts.

# for i in $(ls /usr/share/locale|grep -v -E "^(ja)$"); do fc-match sans:lang=$i|grep -E "^(IPAGothic)$"; [ $? = 0 ] && echo $i; done

No affects to other languages.
Comment 5 Fedora Update System 2010-05-10 19:52:01 EDT
ipa-gothic-fonts-003.02-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.