Bug 578028 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lklug-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586851
  Show dependency treegraph
 
Reported: 2010-03-29 23:40 EDT by Akira TAGOH
Modified: 2010-04-28 09:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: lklug-fonts-0.6-4.20090803cvs.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586851 (view as bug list)
Environment:
Last Closed: 2010-04-25 09:47:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:40:14 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 65-lklug.conf
Comment 1 Fedora Update System 2010-04-15 05:29:11 EDT
lklug-fonts-0.6-4.20090803cvs.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lklug-fonts-0.6-4.20090803cvs.fc13
Comment 2 Pravin Satpute 2010-04-16 01:55:09 EDT
fixed in lklug-fonts-0.6-4.20090803cvs.fc14
Comment 3 Fedora Update System 2010-04-16 19:35:16 EDT
lklug-fonts-0.6-4.20090803cvs.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lklug-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/lklug-fonts-0.6-4.20090803cvs.fc13
Comment 4 Akira TAGOH 2010-04-21 08:22:01 EDT
Testing result:
# rpm -q lklug-fonts
lklug-fonts-0.6-4.20090803cvs.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=si
lklug.ttf: "LKLUG" "Regular"
# fc-match monospace:lang=si-lk
lklug.ttf: "LKLUG" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=si
lklug.ttf: "LKLUG" "Regular"
# fc-match serif:lang=si-lk
lklug.ttf: "LKLUG" "Regular"

Even though no monospaced fonts nor serif fonts in lklug-fonts (nor probably in Fedora? dunno I don't have them installed at least because it's not in comps), this would be good side-effect fontconfig tries to pick up the better font for the language. however please note that this kind of expectation isn't a good idea because it could be messed up when any existing fonts started to support Sinhala.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=si
lklug.ttf: "LKLUG" "Regular"
# fc-match sans:lang=si-lk
lklug.ttf: "LKLUG" "Regular"

That looks good.

# for i in $(ls /usr/share/locale|grep -v si); do fc-match sans:lang=$i|grep LKLUG; [ $? = 0 ] && echo $i; done
#

So the updated package works as expected.
Comment 5 Fedora Update System 2010-04-25 09:47:49 EDT
lklug-fonts-0.6-4.20090803cvs.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.