Bug 578031 - lang-specific overrides rule doesn't work as expected
Summary: lang-specific overrides rule doesn't work as expected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-gujarati-fonts
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 578015
Blocks: F13Target 586856
TreeView+ depends on / blocked
 
Reported: 2010-03-30 03:43 UTC by Akira TAGOH
Modified: 2010-04-28 22:43 UTC (History)
3 users (show)

Fixed In Version: lohit-gujarati-fonts-2.4.4-3.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 586856 (view as bug list)
Environment:
Last Closed: 2010-04-28 04:31:02 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2010-03-30 03:43:23 UTC
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 66-lohit-gujarati.conf

Comment 1 Fedora Update System 2010-04-16 05:32:49 UTC
lohit-gujarati-fonts-2.4.4-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lohit-gujarati-fonts-2.4.4-3.fc13

Comment 2 Pravin Satpute 2010-04-16 05:56:29 UTC
lohit-gujarati-fonts-2.4.4-3.fc14

Comment 3 Fedora Update System 2010-04-16 23:32:14 UTC
lohit-gujarati-fonts-2.4.4-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-gujarati-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/lohit-gujarati-fonts-2.4.4-3.fc13

Comment 4 Akira TAGOH 2010-04-22 02:09:38 UTC
Testing result:
# rpm -q lohit-gujarati-fonts
lohit-gujarati-fonts-2.4.4-3.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=gu
Lohit-Gujarati.ttf: "Lohit Gujarati" "Regular"
# fc-match monospace:lang=gu-in
Lohit-Gujarati.ttf: "Lohit Gujarati" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=gu
Lohit-Gujarati.ttf: "Lohit Gujarati" "Regular"
# fc-match serif:lang=gu-in
Lohit-Gujarati.ttf: "Lohit Gujarati" "Regular"

Since lohit-gujarati-fonts doesn't have any rules for monospace and serif (and nothing else packages available in Fedora?) this just works as the above. please note that it may be changed when any packages started to provide Gujarati fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=gu
Lohit-Gujarati.ttf: "Lohit Gujarati" "Regular"
# fc-match sans:lang=gu-in
Lohit-Gujarati.ttf: "Lohit Gujarati" "Regular"

That looks good.

# for i in $(ls /usr/share/locale|grep -v gu); do fc-match sans:lang=$i|grep "Lohit Gujarati"; [ $? = 0 ] && echo $i; done
#

So confirmed the updated package works fine.

Comment 5 Pravin Satpute 2010-04-28 04:31:02 UTC
thanks tagoh for comments

Comment 6 Fedora Update System 2010-04-28 22:43:27 UTC
lohit-gujarati-fonts-2.4.4-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.