Bug 578034 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-devanagari-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586858
  Show dependency treegraph
 
Reported: 2010-03-29 23:45 EDT by Akira TAGOH
Modified: 2010-04-28 09:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: lohit-devanagari-fonts-2.4.3-6.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586858 (view as bug list)
Environment:
Last Closed: 2010-04-26 22:17:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:45:20 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 66-lohit-devanagari.conf
Comment 1 Fedora Update System 2010-04-16 01:33:37 EDT
lohit-devanagari-fonts-2.4.3-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.4.3-6.fc13
Comment 2 Pravin Satpute 2010-04-16 01:56:47 EDT
lohit-devanagari-fonts-2.4.3-6.fc14
Comment 3 Fedora Update System 2010-04-16 19:44:56 EDT
lohit-devanagari-fonts-2.4.3-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-devanagari-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.4.3-6.fc13
Comment 4 Akira TAGOH 2010-04-22 05:11:17 EDT
Testing result:
# rpm -q lohit-devanagari-fonts
lohit-devanagari-fonts-2.4.3-6.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=hi
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=hi-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=mr
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=mr-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=kok
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=kok-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=ks
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match monospace:lang=ks-in
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match monospace:lang=ks@devanagari
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ks-in@devanagari
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match monospace:lang=sd
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match monospace:lang=sd-in
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match monospace:lang=sd@devanagari
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=sd-in@devanagari
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match monospace:lang=mai
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=mai-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=ne
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=ne-np
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=sa
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=sa-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=hi
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=hi-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=mr
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=mr-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=kok
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=kok-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=ks
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match serif:lang=ks-in
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match serif:lang=ks@devanagari
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ks-in@devanagari
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match serif:lang=sd
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match serif:lang=sd-in
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match serif:lang=sd@devanagari
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=sd-in@devanagari
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match serif:lang=mai
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=mai-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=ne
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=ne-np
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=sa
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=sa-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"

Since lohit-devanagari-fonts doesn't provide any rules for monospace and serif, this is just a kind of FYI.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=hi
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=hi-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=mr
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=mr-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=kok
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=kok-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=ks
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match sans:lang=ks-in
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match sans:lang=ks@devanagari
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ks-in@devanagari
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match sans:lang=sd
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match sans:lang=sd-in
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match sans:lang=sd@devanagari
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=sd-in@devanagari
PakType_Naqsh.ttf: "PakType Naqsh" "Regular"
# fc-match sans:lang=mai
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=mai-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=ne
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=ne-np
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=sa
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=sa-in
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"

Looking at the above result, there seems some issues here.

 * paktype-fonts appears because it doesn't have the locale-specific overrides rule.
 * fontconfig doesn't take care of the difference of ll and ll@scriptname.
 * most rules in this config file matches any of the above.
 * fontconfig says Lohit Devanagari supports Bihari and Bhojpuri though, no rules for that.

Last two are issues in lohit-devanagari-fonts. though it's separate issues with this however.

Anyway, *this* issue itself seems gone with the fix though.
Comment 5 Fedora Update System 2010-04-26 22:17:17 EDT
lohit-devanagari-fonts-2.4.3-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.