Bug 578038 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lohit-punjabi-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586866
  Show dependency treegraph
 
Reported: 2010-03-29 23:48 EDT by Akira TAGOH
Modified: 2010-04-28 09:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586866 (view as bug list)
Environment:
Last Closed: 2010-04-16 13:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:48:16 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 66-lohit-punjabi.conf
Comment 1 Pravin Satpute 2010-04-16 13:40:13 EDT
fixed in lohit-punjabi-fonts-2.4.4-1 for fc13 as well in devel
Comment 2 Akira TAGOH 2010-04-28 06:58:19 EDT
just for the note in the future, here is the testing result as I usually did for other fonts packages in this issue:
# rpm -qa lohit-punjabi-fonts
lohit-punjabi-fonts-2.4.4-1.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=pa
Lohit-Punjabi.ttf: "Lohit Punjabi" "Regular"
# fc-match monospace:lang=pa-in
Lohit-Punjabi.ttf: "Lohit Punjabi" "Regular"
# fc-match monospace:lang=pa-pk
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=pa
Lohit-Punjabi.ttf: "Lohit Punjabi" "Regular"
# fc-match serif:lang=pa-in
Lohit-Punjabi.ttf: "Lohit Punjabi" "Regular"
# fc-match serif:lang=pa-pk
DejaVuSerif.ttf: "DejaVu Serif" "Book"

No explicit rules for monospace and serif in lohit-punjabi-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=pa
Lohit-Punjabi.ttf: "Lohit Punjabi" "Regular"
# fc-match sans:lang=pa-in
Lohit-Punjabi.ttf: "Lohit Punjabi" "Regular"
# fc-match sans:lang=pa-pk
DejaVuSans.ttf: "DejaVu Sans" "Book"

That looks good. getting different result for pa-pk is expected behaviour since fontconfig has different orth file for pa-pk.

# for i in $(ls /usr/share/locale|grep -v -E "^(pa)$"); do fc-match sans:lang=$i|grep -E "^(Lohit Punjabi)$"; [ $? = 0 ] && echo $i; done

Note You need to log in before you can comment on or make changes to this bug.