Bug 578041 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: madan-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586870
  Show dependency treegraph
 
Reported: 2010-03-29 23:51 EDT by Akira TAGOH
Modified: 2010-04-28 09:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: madan-fonts-2.000-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586870 (view as bug list)
Environment:
Last Closed: 2010-04-26 22:25:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:51:19 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 65-madan.conf
Comment 1 Fedora Update System 2010-04-20 01:01:12 EDT
madan-fonts-2.000-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/madan-fonts-2.000-2.fc13
Comment 2 Fedora Update System 2010-04-20 22:20:56 EDT
madan-fonts-2.000-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update madan-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/madan-fonts-2.000-2.fc13
Comment 3 Akira TAGOH 2010-04-22 08:12:15 EDT
Testing result:
# rpm -q madan-fonts
madan-fonts-2.000-2.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ne
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match monospace:lang=ne-np
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ne
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match serif:lang=ne-np
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"

No explicit rules for monospace and serif in madan-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ne
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"
# fc-match sans:lang=ne-np
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"

For this issue, the above result isn't bad. the reasons why fontconfig didn't pick up Madan font is:

 * madan-fonts doesn't have certain glyph coverages that fontconfig is expecting in ne.orth.

   $ fc-match -v Madan | grep -E "^    ]*lang"
           lang: (s)

 * since the locale-specific overrides rule adds Madan as the weak binding now, Lohit Devanagari has a priority since it appears in 65-nonlatin.conf. 65-madan.conf should be renamed to 65-0-madan.conf or something like that.

# for i in $(ls /usr/share/locale|grep -v -E "^ne$"); do fc-match sans:lang=$i|grep "Madan"; [ $? = 0 ] && echo $i; done
#

No affects to other languages so far. but I'm not really sure when the above issues got fixed once.

Anyway, it's good enough for this issue but need further fixes to make this package useful for Nepali.
Comment 4 Fedora Update System 2010-04-26 22:25:38 EDT
madan-fonts-2.000-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.