Bug 578043 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sarai-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-03-29 23:53 EDT by Akira TAGOH
Modified: 2010-04-26 22:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: sarai-fonts-1.0-9.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 22:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:53:23 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 68-sarai.conf
Comment 1 Fedora Update System 2010-04-20 00:59:57 EDT
sarai-fonts-1.0-9.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/sarai-fonts-1.0-9.fc13
Comment 2 Fedora Update System 2010-04-20 22:23:31 EDT
sarai-fonts-1.0-9.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sarai-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/sarai-fonts-1.0-9.fc13
Comment 3 Akira TAGOH 2010-04-23 05:10:44 EDT
Testing result without lohit-devanagari-fonts, paktype-naqsh-fonts, samyak-devanagari-fonts and paktype-tehreer-fonts:
# rpm -qa sarai-fonts
sarai-fonts-1.0-9.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=brx
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=doi
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=hi
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=hi-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=kok
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=kok-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=ks
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ks@devanagari
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ks-in
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ks-in@devanagari
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=mai
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=mai-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=mr
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=mr-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=ne
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=ne-np
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=sa
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=sa-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match monospace:lang=sd
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=sd@devanagari
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=sd-in
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=sd-in@devanagari
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=brx
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=doi
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=hi
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=hi-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=kok
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=kok-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=ks
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ks@devanagari
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ks-in
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ks-in@devanagari
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=mai
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=mai-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=mr
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=mr-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=ne
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=ne-np
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=sa
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=sa-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match serif:lang=sd
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=sd@devanagari
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=sd-in
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=sd-in@devanagari
DejaVuSerif.ttf: "DejaVu Serif" "Book"

The above result is just FYI since no explicit rules for monospace and serif in sarai-fonts provided.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"

That looks good.

# fc-match sans:lang=brx
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=doi
DejaVuSans.ttf: "DejaVu Sans" "Book"

No orth files available in fontconfig for Bodo and Dogri.

# fc-match sans:lang=hi
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=hi-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=kok
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=kok-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=mai
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=mai-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=mr
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=mr-in
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=ne
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=ne-np
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=sa
Sarai_07.ttf: "Sarai" "Regular"
# fc-match sans:lang=sa-in
Sarai_07.ttf: "Sarai" "Regular"

That looks good.

# fc-match sans:lang=ks
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ks@devanagari
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ks-in
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ks-in@devanagari
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=sd
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=sd@devanagari
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=sd-in
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=sd-in@devanagari
DejaVuSans.ttf: "DejaVu Sans" "Book"

fontconfig doesn't take care of @scriptname so far.

# for i in $(ls /usr/share/locale|grep -v -E "^(brx|doi|hi|kok|ks|ks@devanagari|mai|mr|ne|sa|sd|sd@devanagari)$"); do fc-match sans:lang=$i|grep "Sarai"; [ $? = 0 ] && echo $i; done
Sarai_07.ttf: "Sarai" "Regular"
bh
Sarai_07.ttf: "Sarai" "Regular"
bho

fontconfig says that this font is capable for Bhojpuri and Bihari, but anyway.
Comment 4 Fedora Update System 2010-04-26 22:31:57 EDT
sarai-fonts-1.0-9.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.