This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 578045 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sazanami-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-03-29 23:54 EDT by Akira TAGOH
Modified: 2010-05-10 19:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: sazanami-fonts-0.20040629-11.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 19:50:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:54:30 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 66-sazanami-gothic.conf
 66-sazanami-mincho.conf
Comment 1 Akira TAGOH 2010-04-18 23:37:58 EDT
Fixed in sazanami-fonts-0.20040629-11.fc13.
Comment 2 Fedora Update System 2010-04-19 01:12:17 EDT
sazanami-fonts-0.20040629-11.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/sazanami-fonts-0.20040629-11.fc13
Comment 3 Fedora Update System 2010-04-20 09:30:14 EDT
sazanami-fonts-0.20040629-11.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sazanami-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/sazanami-fonts-0.20040629-11.fc13
Comment 4 Akira TAGOH 2010-04-26 06:54:32 EDT
Testing result without ipa-*-fonts and vlgothic-fonts to see the correct result due to the priority thing:
# rpm -qa sazanami-gothic-fonts
sazanami-gothic-fonts-0.20040629-11.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ja
sazanami-gothic.ttf: "Sazanami Gothic" "Regular"
# fc-match monospace:lang=ja-jp
sazanami-gothic.ttf: "Sazanami Gothic" "Regular"

No explicit rules for monospace in sazanami-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ja
sazanami-gothic.ttf: "Sazanami Gothic" "Regular"
# fc-match sans:lang=ja-jp
sazanami-gothic.ttf: "Sazanami Gothic" "Regular"

That looks good.

# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ja
sazanami-mincho.ttf: "Sazanami Mincho" "Regular"
# fc-match serif:lang=ja-jp
sazanami-mincho.ttf: "Sazanami Mincho" "Regular"

That looks good.

# for i in $(ls /usr/share/locale|grep -v -E "^(ja)$"); do fc-match sans:lang=$i|grep -E "^(Sazanami Gothic)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages though, that may be good to get rid of compare="contains" since it matches to other languages unexpectedly.
Comment 5 Fedora Update System 2010-05-10 19:50:15 EDT
sazanami-fonts-0.20040629-11.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.