This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 578046 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smc-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Naveen Kumar
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586847
  Show dependency treegraph
 
Reported: 2010-03-29 23:55 EDT by Akira TAGOH
Modified: 2010-04-30 19:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: smc-fonts-04.2-7.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586847 (view as bug list)
Environment:
Last Closed: 2010-04-30 19:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:55:44 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 67-smc-anjalioldlipi.conf
 67-smc-dyuthi.conf
 67-smc-kalyani.conf
 66-smc-meera.conf
 67-smc-rachana.conf
 67-smc-raghumalayalam.conf
 67-smc-suruma.conf
Comment 1 Fedora Admin XMLRPC Client 2010-04-16 05:33:47 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Update System 2010-04-16 05:52:04 EDT
smc-fonts-04.2-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/smc-fonts-04.2-7.fc13
Comment 3 Fedora Update System 2010-04-16 19:52:12 EDT
smc-fonts-04.2-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smc-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/smc-fonts-04.2-7.fc13
Comment 4 Akira TAGOH 2010-04-26 22:22:56 EDT
Testing result for smc-anjalioldlipi-fonts without other smc-(-fonts:
# rpm -qa smc-*
smc-anjalioldlipi-fonts-04.2-7.fc13.noarch
smc-fonts-common-04.2-7.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
# fc-match monospace:lang=ml-in
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
# fc-match serif:lang=ml-in
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"

No explicit rules for monospace and serif in smc-anjalioldlipi-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"
# fc-match sans:lang=ml-in
AnjaliOldLipi.ttf: "AnjaliOldLipi" "Regular"

That looks good though, that would be worth considering to rename 67-smc-anjalioldlipi.conf to 65-n- if you want to give more priority than Lohit because current config will be applied after 65-nonlatin.conf and Lohit fonts described there has more priority.

# for i in $(ls /usr/share/locale|grep -v -E "^(ml)$"); do fc-match sans:lang=$i|grep -E "^(AnjaliOldLipi)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages.
Comment 5 Akira TAGOH 2010-04-26 22:29:04 EDT
Testing result for smc-dyuthi.conf without other smc-*-fonts:
# rpm -qa smc-*
smc-fonts-common-04.2-7.fc13.noarch
smc-dyuthi-fonts-04.2-7.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml-in
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml-in
DejaVuSerif.ttf: "DejaVu Serif" "Book"

No explicit rules for monospace and serif in smc-dyuthi-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml-in
DejaVuSans.ttf: "DejaVu Sans" "Book"

This is because Dyuthi font doesn't have enough glyph coverage for Malayalam:

# fc-match -v Dyuthi|grep lang|grep ml
#

# for i in $(ls /usr/share/locale|grep -v -E "^(ml)$"); do fc-match sans:lang=$i|grep -E "^(Dyuthi)$"; [ $? = 0 ] && echo $i; done

So the above testcase isn't reliable enough. this font doesn't affects to other because of the above issue, we need to revisit this testing once it got fixed.
Comment 6 Akira TAGOH 2010-04-26 22:32:29 EDT
Testing result for smc-kalyani-fonts without other smc-*-fonts:
# rpm -qa smc-*
smc-fonts-common-04.2-7.fc13.noarch
smc-kalyani-fonts-04.2-7.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml-in
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml-in
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml-in
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# for i in $(ls /usr/share/locale|grep -v -E "^(ml)$"); do fc-match sans:lang=$i|grep -E "^(Kalyani)$"; [ $? = 0 ] && echo $i; done
#

Same to comment #5.

# fc-match -v Kalyani|grep "        lang"
        lang: (s)
Comment 7 Akira TAGOH 2010-04-26 22:51:02 EDT
Testing result for smc-meera-fonts without other smc-*-fonts:
# rpm -qa smc-*
smc-meera-fonts-04.2-7.fc13.noarch
smc-fonts-common-04.2-7.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
Meera_04.ttf: "Meera" "Regular"
# fc-match monospace:lang=ml-in
Meera_04.ttf: "Meera" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
Meera_04.ttf: "Meera" "Regular"
# fc-match serif:lang=ml-in
Meera_04.ttf: "Meera" "Regular"

No explicit rules for monospace and serif in smc-meera-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
Meera_04.ttf: "Meera" "Regular"
# fc-match sans:lang=ml-in
Meera_04.ttf: "Meera" "Regular"

That looks good though, that may be worth considering to rename 66-smc-meera.conf to 65-n- perhaps if you want to give a priority more than Lohit, because current config will be applied after 65-nonlatin.conf.


# for i in $(ls /usr/share/locale|grep -v -E "^(ml)$"); do fc-match sans:lang=$i|grep -E "^(Meera)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages.
Comment 8 Akira TAGOH 2010-04-26 22:54:11 EDT
Testing result for smc-rachana-fonts without other smc-*-fonts:
# rpm -qa smc-*
smc-fonts-common-04.2-7.fc13.noarch
smc-rachana-fonts-04.2-7.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
Rachana_04.ttf: "Rachana" "Regular"
# fc-match monospace:lang=ml-in
Rachana_04.ttf: "Rachana" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
Rachana_04.ttf: "Rachana" "Regular"
# fc-match serif:lang=ml-in
Rachana_04.ttf: "Rachana" "Regular"

No explicit rules for monospace and serif in smc-rachana-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
Rachana_04.ttf: "Rachana" "Regular"
# fc-match sans:lang=ml-in
Rachana_04.ttf: "Rachana" "Regular"

That looks good though, that may be worth considering to rename 67-smc-rachana.conf to 65-n- perhaps if you want to give a priority more than Lohit, because current config will be applied after 65-nonlatin.conf.

# for i in $(ls /usr/share/locale|grep -v -E "^(ml)$"); do fc-match sans:lang=$i|grep -E "^(Rachana)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages.
Comment 9 Akira TAGOH 2010-04-26 22:57:26 EDT
Testing result for smc-raghumalayalam-fonts without other smc-*-fonts:
# rpm -qa smc-*
smc-raghumalayalam-fonts-04.2-7.fc13.noarch
smc-fonts-common-04.2-7.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
RaghuMalayalamSans2.ttf: "RaghuMalayalam" "Sans"
# fc-match monospace:lang=ml-in
RaghuMalayalamSans2.ttf: "RaghuMalayalam" "Sans"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
RaghuMalayalamSans2.ttf: "RaghuMalayalam" "Sans"
# fc-match serif:lang=ml-in
RaghuMalayalamSans2.ttf: "RaghuMalayalam" "Sans"

No explicit rules for monospace and serif in smc-raghumalayalam-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
RaghuMalayalamSans2.ttf: "RaghuMalayalam" "Sans"
# fc-match sans:lang=ml-in
RaghuMalayalamSans2.ttf: "RaghuMalayalam" "Sans"
 That looks good though, that may be worth considering to rename 67-smc-raghumalayalam.conf to 65-n- perhaps if you want to give a priority more than Lohit, because current config will be applied after 65-nonlatin.conf.

# for i in $(ls /usr/share/locale|grep -v -E "^(ml)$"); do fc-match sans:lang=$i|grep -E "^(RaghuMalayalam)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages.
Comment 10 Akira TAGOH 2010-04-26 23:00:53 EDT
Testing result for smc-suruma-fonts without other smc-*-fonts:
# rpm -qa smc-*
smc-suruma-fonts-04.2-7.fc13.noarch
smc-fonts-common-04.2-7.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ml
suruma2.ttf: "suruma" "Medium"
# fc-match monospace:lang=ml-in
suruma2.ttf: "suruma" "Medium"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ml
suruma2.ttf: "suruma" "Medium"
# fc-match serif:lang=ml-in
suruma2.ttf: "suruma" "Medium"

No explicit rules for monospace and serif in smc-suruma-fonts.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ml
suruma2.ttf: "suruma" "Medium"
# fc-match sans:lang=ml-in
suruma2.ttf: "suruma" "Medium"

That looks good though, that may be worth considering to rename 67-smc-suruma.conf to 65-n- perhaps if you want to give a priority more than Lohit, because current config will be applied after 65-nonlatin.conf.

# for i in $(ls /usr/share/locale|grep -v -E "^(ml)$"); do fc-match sans:lang=$i|grep -E "^(suruma)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages.
Comment 11 Fedora Update System 2010-04-30 19:38:53 EDT
smc-fonts-04.2-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.