Bug 578050 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wqy-microhei-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-03-29 23:59 EDT by Akira TAGOH
Modified: 2010-05-03 22:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 22:20:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:59:44 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 65-wqy-microhei.conf
Comment 1 Fedora Admin XMLRPC Client 2010-04-15 02:00:21 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Peng Wu 2010-04-19 02:09:51 EDT
Fixed in wqy-microhei-fonts-0.2.0-0.3.beta.fc13.
Comment 3 Fedora Update System 2010-04-19 02:31:10 EDT
wqy-microhei-fonts-0.2.0-0.3.beta.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/wqy-microhei-fonts-0.2.0-0.3.beta.fc13
Comment 4 Fedora Update System 2010-04-20 09:35:45 EDT
wqy-microhei-fonts-0.2.0-0.3.beta.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wqy-microhei-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wqy-microhei-fonts-0.2.0-0.3.beta.fc13
Comment 5 Akira TAGOH 2010-04-26 04:09:25 EDT
Testing result without wqy-zenhei-fonts due to its priority thing:
# rpm -qa wqy-microhei-fonts
wqy-microhei-fonts-0.2.0-0.3.beta.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=zh
wqy-microhei.ttc: "WenQuanYi Micro Hei" "Regular"
# fc-match monospace:lang=zh-cn
wqy-microhei.ttc: "文泉驛微米黑" "Regular"
# fc-match monospace:lang=zh-hk
hanazono.ttf: "HanaMin" "Regular"
# fc-match monospace:lang=zh-sg
wqy-microhei.ttc: "文泉驛微米黑" "Regular"
# fc-match monospace:lang=zh-tw
hanazono.ttf: "HanaMin" "Regular"

That looks good though, the font for zn-cn and zh-sg was picked up by the implicit rules in fontconfig that happens when no explicit rules and fallback to the fonts. so

  <test name="lang">
    <string>zh</string>
  </test>

  should be

  <test name="lang">
    <string>zh-cn</string>
    <string>zh-sg</string>
  </test>

since most applications gives the language with ll-cc in the query from current locale.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=zh
wqy-microhei.ttc: "WenQuanYi Micro Hei" "Regular"
# fc-match sans:lang=zh-cn
wqy-microhei.ttc: "文泉驛微米黑" "Regular"
# fc-match sans:lang=zh-hk
hanazono.ttf: "HanaMin" "Regular"
# fc-match sans:lang=zh-sg
wqy-microhei.ttc: "文泉驛微米黑" "Regular"
# fc-match sans:lang=zh-tw
hanazono.ttf: "HanaMin" "Regular"

Same the above.

# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=zh
hanazono.ttf: "HanaMin" "Regular"
# fc-match serif:lang=zh-cn
wqy-microhei.ttc: "文泉驛微米黑" "Regular"
# fc-match serif:lang=zh-hk
hanazono.ttf: "HanaMin" "Regular"
# fc-match serif:lang=zh-sg
wqy-microhei.ttc: "文泉驛微米黑" "Regular"
# fc-match serif:lang=zh-tw
hanazono.ttf: "HanaMin" "Regular"

No explicit rules for serif in wqy-microhei-fonts.

# for i in $(ls /usr/share/locale|grep -v -E "^(zh)$"); do fc-match sans:lang=$i|grep -E "^(WenQuanYi Micro Hei)$"; [ $? = 0 ] && echo $i; done

No affects to other languages.

Note You need to log in before you can comment on or make changes to this bug.