Bug 578217 - kernel-2.6.32.10-90.fc12.i686 udev oops on load of ssb
Summary: kernel-2.6.32.10-90.fc12.i686 udev oops on load of ssb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 578245 578590 579118 579122 579618 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-30 15:14 UTC by Henrique Martins
Modified: 2010-04-22 07:41 UTC (History)
29 users (show)

Fixed In Version: kernel-2.6.32.11-99.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-10 10:29:22 UTC


Attachments (Terms of Use)

Description Henrique Martins 2010-03-30 15:14:18 UTC
Description of problem:
After yum update to kernel-2.6.32.10-90.fc12.i686 system oops on udev on one of my systems with an Haupagge card

Version-Release number of selected component (if applicable):
2.6.32.10-90.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1. Reboot the system
2.
3.
  
Actual results:
System gets into graphic mode but doesn't finish booting.  Escaping into the console I see:

BUG unable to handle kernel NULL pointer dereference at 00000010
IP: [<f9369937>] ssb_is_sprom_available+0x7e/0x79 [ssb]
*pde=7e78c067
oops: 0000 [#1] SMP
last sysfs file: /sys/devices/pci0000:00:0000:00:00:0d.0/video4linux/radio/dev

followed by a stack trace and a lot more ivtv0 tagged lines
and then nothing
(Forgot how to save the console dump and I do need to get to work ....)

Expected results:
system to reboot

Additional info:
works with 2.6.32.9-70.fc12.i686
my other system (a thinkpad t42 laptop) works fine with the new kernel

Comment 1 James Hogan 2010-03-31 00:08:31 UTC
I'm also hitting this same problem with my x86_64 laptop.

Comment 2 Herbert Bosshardt 2010-03-31 15:19:27 UTC
Same problem: updated this morning to kernel-PAE-2.6.32.10-90.fc12.i686 (plus additional updates). Not even boot to runlevel 1 works.

No problem with Kernel 2.6.32.9-70.fc12.i686.PAE.

Labtop: Dell Inspiron 9300 with Gnome 2.28.2

Comment 3 Rodolfo Alcazar 2010-03-31 16:07:41 UTC
The same on laptop Dell XPS M1210, no hauppage card, no tv card. Please see crash photo:

http://otbits.blogspot.com/2010/03/bug-photo-20100331.html

Comment 4 Felix Schwarz 2010-03-31 17:39:31 UTC
Same here with 2.6.32.10-90.fc12.x86_64 on two Dell machines (Dell E521, Dell Vostro 1500). Most of the times udev does not

Comment 5 Bryan Schneiders 2010-03-31 18:48:21 UTC
Same problem confirmed on 24 Dell Dimension E521 systems.

kernel-2.6.32.9-70.fc12.x86_64 works
kernel-2.6.32.10-90.fc12.x86_64 fails

Comment 6 Felix Schwarz 2010-03-31 20:08:49 UTC
I'd like to add that also 2.6.32.10-92 (currently in -testing) shows the same problems.

Comment 7 James Derrick 2010-03-31 20:19:54 UTC
Same problem found on an Acer Pundit (2.5GHz P4, 4Gb RAM, 2x cx88 DVB Freeview
TV cards).

kernel-2.6.32.9-70.fc12.x86_64 works
kernel-2.6.32.10-90.fc12.x86_64 craskes at boot.

Manually transcribed error messages:
Starting udev: BUG: unable to handle kernel NULL pointer dereference at
00000010
IP: [<f8965a47>} ssb_is_sprom_available+0xe/0x79 [ssb]
*pdpt = 0000000036b28001 *pde = 000000003b842067
Oops: 0000 [#1] SMP
last sysfs file: /sys/devices/pci......

Comment 8 Felix Schwarz 2010-03-31 20:27:11 UTC
Actually I believe this is a duplicate of bug 577463, please try koji build http://koji.fedoraproject.org/koji/buildinfo?buildID=164636 which fixes the problem for me.

Comment 9 Henrique Martins 2010-04-01 05:23:54 UTC
Build above boots fine and has been up for 10 minutes, and yes, I have a b44 based network card

Comment 10 Rodolfo Alcazar 2010-04-01 09:56:21 UTC
Ok. http://koji.fedoraproject.org/koji/buildinfo?buildID=164636 boots fine.

Comment 11 Sascha Harusta 2010-04-03 20:12:36 UTC
After installing kernel-2.6.32.10-94.fc12.x86_64 the issue is solved.

Comment 12 Lawrence Graves 2010-04-04 12:07:41 UTC
After installing kernel-2.6.32.10-94.fc12.x86_64 my laptop boots fine.  However, there is that problem with gnome-scan not working any longer.  I believe that the command to allow it to work was omitted in an effort to fix the above problem.  Because I am a novice, I have not the knowledge it takes to go in the back of my computer and turn it on.  Whoever has that knowledge thank you.

Comment 13 Micko 2010-04-04 17:50:51 UTC
I've tried kernel-2.6.32.10-94.fc12.x86_64 on Dell E521 and it boots ok with nouveau. Blacklisting nouveau also make the nvidia driver work. Thanks!

Comment 14 Felix Schwarz 2010-04-05 06:47:27 UTC
*** Bug 578245 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2010-04-05 14:25:18 UTC
kernel-2.6.32.10-94.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.32.10-94.fc12

Comment 16 John W. Linville 2010-04-05 14:33:28 UTC
*** Bug 579118 has been marked as a duplicate of this bug. ***

Comment 17 John W. Linville 2010-04-05 14:33:52 UTC
*** Bug 579122 has been marked as a duplicate of this bug. ***

Comment 18 John W. Linville 2010-04-05 14:34:40 UTC
*** Bug 578590 has been marked as a duplicate of this bug. ***

Comment 19 Juan J. Martínez 2010-04-07 18:17:27 UTC
kernel-2.6.32.11-99.fc12 is still pending in https://admin.fedoraproject.org/updates/kernel-2.6.32.11-99.fc12.

Will it be pushed into testing anytime soon?

Comment 20 Larry O'Leary 2010-04-08 04:53:49 UTC
I too have this issue on an Dell Inspirorn 5150 using 2.6.32.10-90.fc12.i686 or 2.6.32.10-92.fc12.i686 but using the Koji build seems to have resolved the Kernel Oops.

Comment 21 Fedora Update System 2010-04-09 01:37:24 UTC
kernel-2.6.32.11-99.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.32.11-99.fc12

Comment 22 Fedora Update System 2010-04-10 10:28:59 UTC
kernel-2.6.32.11-99.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Chuck Ebbert 2010-04-21 17:38:05 UTC
*** Bug 579618 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.