Bug 57838 - Installer gives message about possible bug after selecting components to install ,after creating rollback FS,before starting to copy the selected packages.
Summary: Installer gives message about possible bug after selecting components to inst...
Status: CLOSED DUPLICATE of bug 19928
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-27 08:59 UTC by Anirudh Shivaswamy
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-27 08:59:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anirudh Shivaswamy 2001-12-27 08:59:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; DigExt)

Description of problem:
I am unable to install RHL 7.0 on hda5 .After selecting components for a 
workstation setup ,and creating rollback FS ,error msg is 
given ,which suggests that I post the given anacdump.txt to bugzilla.
hda1 has win98 se
hda2 has winnt 4 ent.edition .
I do not have any other place to install .

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Create floppy image of bootimg.img and reboot with floppy and RHL 7.0 CD 
in respective drive
2.Select language ,etc. and select disk druid.
3.Select an existing FAT (extended partition-hda5) as mount point ,with no 
swap partition .
4.Select workstation setup.
5.Specify root FS and swap size.
6.Select X-Windows,EMACS,Development ,Printer and MM support in 
components .Check  `select individual components'
7.Select components and proceed .
8.anaconda will create rollback FS.
9.Setup gives error as given in logfile/
	

Actual Results:  Error message was given (refer given transcript of 
anacdump.txt)
--transcript of anacdump.txt begins--
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.GuiFstab instance at 84989a8>
mntPoint: /mnt/sysimage
selected: [ImageMagick, LPRng, MAKEDEV, Mesa, Mesa-devel, ORBit, SDL, 
SysVinit, XFree86, XFree86-75dpi-fonts, XFree86-S3, XFree86-devel, XFree86-
libs, XFree86-tools, XFree86-twm, XFree86-xdm, XFree86-xfs, Xaw3d, Xaw3d-
devel, Xconfigurator, anacron, apmd, ash, aspell, aspell-en-gb, at, 
audiofile, aumix, authconfig, autoconf, automake, awesfx, basesystem, 
bash, bc, bdflush, bind-utils, binutils, bison, byacc, bzip2, bzip2-devel, 
cdda2wav, cdecl, cdp, cdparanoia, chkconfig, chkfontpath, compat-
libstdc++, console-tools, control-panel, cpio, cpp, cproto, cracklib, 
cracklib-dicts, crontabs, ctags, cvs, cyrus-sasl, db1, db2, db3, dev, 
dev86, dhcpcd, dialog, diffstat, diffutils, dip, docbook, e2fsprogs, ed, 
eject, elm, emacs, emacs-X11, emacs-nox, esound, exmh, fetchmail, file, 
filesystem, fileutils, findutils, finger, flex, fortune-mod, freetype, 
ftp, gawk, gcc, gcc-c++, gd, gd-devel, gdb, gdbm, gdbm-devel, gettext, 
ghostscript, ghostscript-fonts, gimp, glib, glib-devel, glibc, glibc-
devel, gmp, gnome-audio, gnome-libs, gnome-linuxconf, gnupg, gphoto, gpm, 
grep, groff, groff-perl, gtk+, gv, gzip, hdparm, ical, imlib, indent,
indexhtml, inews, info, initscripts, iproute, iputils, isapnptools, 
jadetex, joystick, kbdconfig, kernel, kernel-headers, kernel-pcmcia-cs, 
kernel-utils, kernelcfg, krb5-devel, krb5-libs, kudzu, kudzu-devel, less, 
libglade, libjpeg, libjpeg-devel, libpng, libpng-devel, libstdc++, 
libstdc++-devel, libtermcap, libtermcap-devel, libtiff, libtiff-devel, 
libtool, libtool-libs, libungif, libungif-devel, libxml, lilo, links, 
linuxconf, linuxconf-devel, logrotate, losetup, lrzsz, lsof, ltrace, lynx, 
m4, mailcap, mailx, make, man, man-pages, memprof, metamail, mikmod, 
mingetty, minicom, mkbootdisk, mkinitrd, mktemp, mkxauth, modemtool, 
modutils, mount, mouseconfig, mpage, mpg123, multimedia, mutt, ncftp, 
ncompress, ncurses, ncurses-devel, net-tools, netpbm, netpbm-devel, netpbm-
progs, netscape-common, netscape-communicator, newt, nfs-utils, njamd, 
nmh, ntsysv, openjade, openldap, openssh, openssh-askpass, openssh-
clients, openssl, openssl-devel, pam, passwd, patch, pciutils, pciutils-
devel, perl, pidentd, pine, playmidi, playmidi-X11, plugger, pmake, 
pnm2ppa, popt, portmap, ppp, printtool, procmail, procps, psgml, psmisc, 
pspell, pump, pwdb, pygnome, pygtk, pygtk-libglade, python, python-devel, 
python-xmlrpc, pythonlib, qt, quota, raidtools, rcs, readline, readline-
devel, redhat-logos, redhat-release, rhn_register, rhn_register-gnome, rhs-
printfilters, rootfiles, rpm, rpm-build, rpm-devel, rpm-python, rsh, 
rsync, rxvt, sane, sash, screen, sed, sendmail, setserial, setup, 
setuptool, sgml-common, sgml-tools, sh-utils, shadow-utils, shapecfg, 
sharutils, slang, slocate, slrn, smpeg, sndconfig, sox, stat, statserial, 
strace, stunnel, stylesheets, switchdesk, sysklogd, talk, tar, tcl, tclx, 
tcsh, termcap, tetex, tetex-afm, tetex-dvilj, tetex-dvips, tetex-fonts, 
tetex-latex, tetex-xdvi, texinfo, textutils, time, timeconfig, timetool, 
tin, tix, tk, tkinter, tksysv, tmpwatch, traceroute, trn, unzip, up2date, 
up2date-gnome, urlview, urw-fonts, usermode, utempter, util-linux, vim-
common, vim-minimal, vixie-cron, which, whois, words, wvdial, xinitrc, 
xloadimage, xmailbox, xmms, xpdf, xrn, xsane, xscreensaver, xsri, xxgdb, 
yp-tools, ypbind, zip, zlib]
self: <image.CdromInstallMethod instance at 84b7758>
p: joystick
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
--transcript of anacdump.txt ends--

Expected Results:  anaconda should have begun copying the selected 
packages/

Additional info:

hda1(fat)- win 98se
hda2(fat)- winnt 4.0 ent. ed.
hda5(fat)- `/' -mountpoint.no other partitions 
each of the above drives is 2008m each .
RAM- 80m
BIOS- award 4.50

Comment 1 Jeremy Katz 2002-01-02 22:24:26 UTC

*** This bug has been marked as a duplicate of 19928 ***


Note You need to log in before you can comment on or make changes to this bug.