Bug 5789 - RedHat upgrade 6.0 -> 6.1 from hard drive: failure
RedHat upgrade 6.0 -> 6.1 from hard drive: failure
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 16:54 EDT by adavid
Modified: 2015-01-07 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-21 12:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adavid 1999-10-09 16:54:00 EDT
It would be nice to have a Component section directly
related to the boot-install images. I put this in installer
for this reason.

Priority high because if the problem is confirmed it
means that the boot image has a real problem.

My system is RH 6.0, kernel 2.2.10, upgraded from hard drive
from a previous RH 5.2.
This time I wanted to do the same to RH 6.1 but the process
stopped with errors after the second phase of the system
exploration. First it searched for redhat installation,
this went OK, but the next one seemed to work but I got this
(copied by hand):

-------------------
Traceback(innermost last):
 File "/usr/bin/anaconda.real",line 225, in ?
intf.run(todo,test=test)
 File "/tmp/lib/python1.5/site-packages/text.py", line 1000,
in run rc=apply(step[1](),step[2])
 File "/tmp/lib/python1.5/site-packages/text.py", line 251,
in __call__ todo upgradeFindPackages(root)
 File "/tmp/lib/python1.5/site-packages/todo.py", line 1155,
in upgradeFindPackages
packages=rpm.findUpgradeSet(self.hdList.hdlist,self.instPath)
rpm.error: error during upgrade check

[OK] [Debug]
----------------

My rpm version is 3.0.2 and I tried the upgrade after
rpm --rebuildb to be sure that the database was OK, and
it was.

I have copied the RedHat directory on a different partition
than my linux partition as it should be done.

/Alexandre

PS: I could not use bootnet because it simply does NOT work
with my TI1225 pcmcia controller, although it works fine
under my installed Linux
(from /proc/pci:
  Bus  0, device   3, function  0:
    CardBus bridge: Texas Instruments Unknown device (rev
1).
      Vendor id=104c. Device id=ac1c.
      Medium devsel.  Master Capable.  Latency=32.  Min
Gnt=192.Max Lat=7.
)
Comment 1 Jay Turner 1999-10-11 08:58:59 EDT
You will want to use the pcmcia.img disk when trying to use a pcmcia
device for installation.  This is why the bootnet.img file did not
work for you . . . the card manager stuff is not on that disk.  As for
the error that you are receiving, do you have any NTFS partitions on
the machine?

------- Additional Comments From   10/11/99 09:48 -------
I have noticed the change in the installation disks, that's better
now, so I tried pcmcia.img, it recognizes my hardware and goes on
but on the "finding padkages to update" message:
* if I check the customize checkbox, the machines stays silent:
  no network activity and no hardrive activity after a short time
  and during 5 minutes or so
* if I do not check the checkbox, the network seems active, but
  nothing happens even after one hour.

This may be due to a network problem, I'll try later on,
but the server responds normally, so it's strange.

My try from the hard-drive failed as well and I gave the description.
What is your diagnostic concerning these tries?


------- Additional Comments From   10/13/99 04:08 -------
I had confirmation on a network problem here,
however the local installation problem from the
hard drive still remains.

My only partitions on my disk are:
hda1: windows 98
hda5: Linux (only one mount for root)
+swap
and I had RH6.1 on hda1 to install it
on hda5.

I tried to install RH6.1 on a RH5.2 system
with this disk configuration (fstab):
/dev/hda2     /       ext2     exec,dev,suid,rw 1 1
/dev/hda1     /dosc   vfat     user,noexec,nodev,nosuid,rw 0 0
/dev/hdb3    /export ext2     exec,dev,nosuid,rw 2 2
/dev/hdb4    /home/butter    ext2     exec,dev,nosuid,rw 2 2
/dev/hda3                 none                      swap   sw
/dev/hda4                 none                      swap   sw
/dev/hdb1                 none                      swap   sw
/dev/hdb2                 none                      swap   sw

and I got the same error for a local installation.

Alexandre
Comment 2 Jay Turner 1999-10-21 12:25:59 EDT
*** This bug has been marked as a duplicate of 5768 ***

Note You need to log in before you can comment on or make changes to this bug.