Bug 57899 - Kernel panic during install: invalid operand: 0000
Kernel panic during install: invalid operand: 0000
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 58813 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-31 08:57 EST by Tethys
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2001-12-31 08:57:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Booting from a 7.2 CD (created from the downloadable ISO images),
the kernel loads, and then panics with the error message listed
below.

Points to note:
1. The CD is fine. I've installed several other machines from the
   same CD without problems
2. The machine is fine. It's currently running RH7.1, and I was
   trying to upgrade to RH7.2. The RH7.1 install still works in
   the same machine, as does the Linuxcare bootable business card.

The machine in question in an AMD K6/2 500 with 256MB RAM, a
Voodoo 3 3500 graphics card, and IDE disks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put the CD in the drive
2. Reset the machine
3. Watch it panic...
	

Actual Results:  Kernel panic

Expected Results:  Installer to load

Additional info:

Linux NET4.0 for Linux 2.4
Based on Swansea University Computer Society NET3.039
Invalid operand: 0000
CPU:    0
EIP:    0010: [<c01122d1>]
EFLAGS: 00010206
eax: c0101d08   ebx: d0800000   ecx: 91a32000   edx: c0101000
esi: c1232000   edi: 0fff0000   ebp: 00000000   esp: c1727f54
ds: 0018   es: 0018   ss: 0018
Process swapper (pid: 1, stackapge=c1727000)
Stack: 0fff1000 00001000 0fff0000 c00fa7c0 91a32000 c0101d08 00000010 d0800000
       c1232000 0fff0000 00000000 c0112523 d0800000 3f7f0000 c1232000 00000000
       d122184e c00fa7c0 00000014 d0800000 c123184d c0233a70 0fff0000 c123184d
Call Trace: [<d0800000>] [<c0112523>] [<d0800000>] [<d122184c>] [<d0800000>]
       [<c0105000>] [<c0105201>] [<c0105000>] [<c0105642>] [<c01051f8>]
Code: 0f 0b 8b 5c 24 14 85 db e9 31 01 00 00 89 f6 b8 f4 ff ff ff
 <0> Kernel Panic: Attempted to kill init

The above info was typed in by hand. While I've been careful to ensure
it's accurate, I can't rule out the possiblity of typos.
Comment 1 Need Real Name 2002-01-02 06:19:02 EST
I've the same error running on PCChips 768 (I'm not sure!) with Duron 750/128 
MB RAM (I've checked 3 pcs of absolutely new mainboards, CPUs, RAMs, HDD and 
nothing helped). On Celeron 677 and PCChips MB (I don't know which one) it runs 
OK. Strange is that I've succesfully installed RH7.2 before 1 month on the same 
HW (Duron750,PCChips...) where it NOW fails (I've tested the installer on the 
running RH7.2 system and it FAILED... strange...).
I know that it's not the point but I also tried RH7.2 install CDs patched by 
SGI XFS and the same thing happens...
Comment 2 Arjan van de Ven 2002-01-03 03:07:55 EST
Can you guys try typing

linux mem=xxxM

on the syslinux prompt (the VERY first screen) where you replace xxx with the
amount of memory you have minus 32 ?
Comment 3 Need Real Name 2002-01-03 04:03:29 EST
That helped! I've got 256 MB (or 128 MB - depend on machine) and 8 MB shared 
VGA memory (the smallest size BIOS supports). It helped even "mem=xxxM" where 
xxx is mem size-8.
Comment 4 Tethys 2002-01-03 10:51:33 EST
Yep, mem=224M works for me, too.
Comment 5 David Oestreicher 2002-01-24 19:53:57 EST
 I am having a similar problem as follows:

Hardware = AMD Athlon 1600XP
           512 MB memory
           Nvidia Geforce2-GTS video card
           Sound Blaster Live value
           D-Link 530-TX+ (Realtek chip) NIC
           CD drive and CD-RW drive (IDE both)
           Dual boot w/Windows XP.Red Hat is on a second hard drive (both IDE).

       
 I receive the following when trying to boot Red Hat 7.2

     Kernel Bug at ioremap.c:73!
     (dump info similar to above)
     <0> Kernel panic:attempted to kill init!

 I tried booting from a linux boot disk and used the mem=510M parameter.  This 
worked twice in a row and I got into Linux fine.  I rebooted again and using 
the same parameter it did not work.  I tried lowering the memory to a few 
values with no change (as low as 256).  I typed it in the exact same way when 
it worked twice and then did not.  My video card is not on board so I am not 
loosing memory that way.  

  Any help or advice is appreciated.  I am a windows wiz but a newbie to Linux.

  
Comment 6 Arjan van de Ven 2002-01-28 12:24:36 EST
*** Bug 58813 has been marked as a duplicate of this bug. ***
Comment 7 Bugzilla owner 2004-09-30 11:39:19 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.