Bug 579023 - [abrt] crash in thunderbird-3.0.4-1.fc12: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
[abrt] crash in thunderbird-3.0.4-1.fc12: Process /usr/lib64/thunderbird-3.0/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
abrt_hash:26ef9badad86ad84197408ed404...
: Triaged
: 570391 583610 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-02 03:27 EDT by kpvadm
Modified: 2010-05-19 08:28 EDT (History)
26 users (show)

See Also:
Fixed In Version: thunderbird-3.0.4-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 17:49:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (72.88 KB, text/plain)
2010-04-02 03:28 EDT, kpvadm
no flags Details

  None (edit)
Description kpvadm 2010-04-02 03:27:18 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/thunderbird-3.0/thunderbird-bin
component: thunderbird
executable: /usr/lib64/thunderbird-3.0/thunderbird-bin
kernel: 2.6.32.10-90.fc12.x86_64
package: thunderbird-3.0.4-1.fc12
rating: 4
reason: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
How to reproduce: Noteboot just woke up from "sleep" and no TB, but crush report exists
Comment 1 kpvadm 2010-04-02 03:28:59 EDT
Created attachment 404149 [details]
File: backtrace
Comment 2 steve 2010-04-02 09:07:43 EDT

How to reproduce
-----
Updated to thunderbird-3.0.4-1 but still no joy. This report has a more complete backtrace though.
Comment 3 steve 2010-04-02 09:10:19 EDT
btw, this might be the same as bug #572501

abrt probably generates a different hash for each version so I guess this issue will have bugs associated with every release until it is fixed.
Comment 4 steve 2010-04-02 09:13:05 EDT
aaarg ! I meant bug #570391 in comment #3
Comment 5 steve 2010-04-02 09:13:22 EDT
aaarg ! I meant bug #570391 in comment #3
Comment 6 Tore Anderson 2010-04-03 05:19:34 EDT

How to reproduce
-----
No idea.

Comment
-----
I woke my laptop up from suspend, Thunderbird was already running and I attempted to select an e-mail to read.  It crashed almost immediately after.
Comment 7 Tore Anderson 2010-04-05 06:53:40 EDT

How to reproduce
-----
No idea


Comment
-----
Wasn't at my computer, crash appears to be happening randomly.
Comment 8 Marek Mahut 2010-04-06 08:38:21 EDT

How to reproduce
-----
Cannot, happens when writing a mail.
Comment 9 jeder 2010-04-08 08:10:48 EDT

Comment
-----
vpn connection died while thunderbird was open, re-connected to vpn and tbird died a minute or 2 later...not sure if it's related.
Comment 10 jeder 2010-04-08 18:22:44 EDT

Comment
-----
vpn connection died while thunderbird was open, re-connected to vpn and tbird died a minute or 2 later...not sure if it's related.
Comment 11 Jeremy Fitzhardinge 2010-04-08 18:26:18 EDT

How to reproduce
-----
1.Start thunderbird
2.Log into imap server
3.Drop network connection (or connect to a different network)

Thunderbird crashes shortly after finding the network connection missing or hung.
Comment 12 johnathanhegge 2010-04-09 10:39:52 EDT

How to reproduce
-----
1.running overnight, not used
2. crashed in the morning, simliar to the 3.0.3 version
3.
Comment 13 jeder 2010-04-10 12:22:05 EDT

How to reproduce
-----
1. possibly my vpn connection dropping/being re-established ?
2.
3.
Comment 14 Chris Campbell 2010-04-10 12:53:45 EDT
#2  <signal handler called>
No symbol table info available.
#3  nsQueryInterface::operator() (this=<value optimized out>, aIID=..., 
    answer=0x7fff6964ab08) at nsCOMPtr.cpp:47
        status = <value optimized out>
#4  0x00007f68ad1667ba in nsCOMPtr_base::assign_from_qi (this=0x7fff6964ab60, 
    qi=..., iid=...) at nsCOMPtr.cpp:96
        newRawPtr = 0x7f68ad1667d4
#5  0x00007f689c753f26 in nsCOMPtr<nsIMsgFolder>::nsCOMPtr (this=
    0x7fff6964ab60, qi=<value optimized out>)
    at ../../../mozilla/dist/include/xpcom/nsCOMPtr.h:572
No locals.
#6  0x00007f689c871c89 in nsImapIncomingServer::OnStopRunningUrl (this=
    0x7f68a5bb83a0, url=<value optimized out>, exitCode=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/imap/src/nsImapIncomingServer.cpp:2353
        folderCount = 0
        msgFolder = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        imapAction = 22
        rv = <value optimized out>
        msgWindow = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        imapUrl = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f688333ce00}, <No data fields>}
#7  0x00007f689c76847a in nsMsgMailNewsUrl::SetUrlState (this=0x7f688333ce08, 
    aRunningUrl=<value optimized out>, aExitCode=2147500037)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/util/nsMsgMailNewsUrl.cpp:135
        listener = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f68a5bb8488}, <No data fields>}
        iter = 
    {<nsAutoTObserverArray<nsCOMPtr<nsIUrlListener>, 0u>::Iterator> = 
    {<nsTObserverArray_base::Iterator_base> = {mPosition = 1, mNext = 0x0}, 
            mArray = @0x7f688333cea0}, <No data fields>}
        statusFeedback = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
#8  0x00007f689c87b1b8 in nsImapMailFolder::SetUrlState (this=0x7f688b319000, 
    aProtocol=0x7f6882feb000, aUrl=0x7f688333ce08, isRunning=0, statusCode=
    2147500037)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/imap/src/nsImapMailFolder.cpp:6609
No locals.
#9  0x00007f68ad1a31d1 in NS_InvokeByIndex_P (that=0x7f688b3191f8,



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Chris Campbell 2010-04-10 12:55:58 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Chris Campbell 2010-04-10 12:59:34 EDT
*** Bug 570391 has been marked as a duplicate of this bug. ***
Comment 17 kpvadm 2010-04-11 16:24:48 EDT

How to reproduce
-----
sleep with thunderbird, wakeup with bug reporting tool.
Comment 18 jan p. springer 2010-04-11 23:31:08 EDT

How to reproduce
-----
1. run thunderbird for some time
2.
3.


Comment
-----
dunno, just run thunderbird for some time (including going to standby and back sevreal times)
Comment 19 jeder 2010-04-12 16:17:14 EDT

How to reproduce
-----
1.  possibly related to vpn connection dropping ?
2.
3.
Comment 20 Sebastian Krämer 2010-04-12 16:20:58 EDT

How to reproduce
-----
(don't know)

Comment
-----
tb crashes regularly, it is always without interaction. I start it, check mails, do some other work and at some point notice that it's gone. 3.0.4 isn't the first release that has this error, I just didn't want to go through the troube of downloading all the debuginfo stuff. Also, I had my doubts that this report can be useful because I don't know how to reproduce it. But since this error still happens and I fear it will keep happening and changed my mind about that.
I'll happily provide more information where I can.
Comment 21 Jeremy Eder 2010-04-12 16:28:54 EDT
c#11 and c#13 might indicate a trend.
Comment 22 Tore Anderson 2010-04-12 17:01:10 EDT
Jeremy, check bug #570391 - it's been identified as an upstream bug (https://bugzilla.mozilla.org/show_bug.cgi?id=550455) and there's already a fixed RPM available at http://koji.fedoraproject.org/koji/taskinfo?taskID=2092397 .

Tore
Comment 23 Jeremy Eder 2010-04-12 20:50:12 EDT
@Tore -- thanks -- couldn't find RPMs on koji, but rolled my own with upstream patch, intentionally crashed VPN connection a few times, and tbird does not crash.  Looks good!

--jer
Comment 24 salcott@redhat,com 2010-04-13 06:25:37 EDT

How to reproduce
-----
1.Start Thunderbird
2.Plugins enabled are Compact Headers and Enigmail
3.Thunderbird will crash when idle after a random period of time.
Comment 25 kenneth 2010-04-13 09:12:20 EDT

How to reproduce
-----
1. Start Thunderbird.
2. Double click on "get mail"
3. Wait for 3-4 seconds and *boom*
Comment 26 Marek Mahut 2010-04-14 08:05:33 EDT

How to reproduce
-----
Sudden crash


Comment
-----
Sudden crash
Comment 27 Jeremy Eder 2010-04-14 08:10:05 EDT
(In reply to comment #23)
> @Tore -- thanks -- couldn't find RPMs on koji, but rolled my own with upstream
> patch, intentionally crashed VPN connection a few times, and tbird does not
> crash.  Looks good!
> 
> --jer    

Network-drop crashes have seemingly subsided, however it has randomly crashed twice, each time abrt hasn't been triggered.
Comment 28 Sebastian Krämer 2010-04-14 08:12:12 EDT

Comment
-----
Idle. Eventually, like other comments mentioned, a dropped VPN connection occured and might contributed to TB's crashing.
Comment 29 Chris Campbell 2010-04-14 10:16:32 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 30 Joshua Roys 2010-04-16 08:07:14 EDT

How to reproduce
-----
1. leave thunderbird open for a few days with 4 IMAP accounts
2. when you leave for the day, set it to offline mode
3. come in in the morning and hit ctrl+T to get all new messages
crash!


Comment
-----
I pressed ctrl+T and waited for it to finish checking for new messages... but instead it crashed :(  Also, I removed all the threads but the one that raised the segv.  I couldn't tell if the other threads had any sensitive information in them or not.  if you need them, let me know.  Thanks.
Comment 31 H. Peter Anvin 2010-04-18 18:03:45 EDT

How to reproduce
-----
Happens spontaneously after running Thunderbird for some time (on the order of ~10 minutes)


Comment
-----
Note: I have very large amounts of stored email (~1.5 million emails).  I have tried removing the .msf files from the ImapMail directory; it does not affect the behavior.

This is relatively new behavior, and only affects Thunderbird on this particular system; not on any of the other systems I use.
Comment 32 kpvadm 2010-04-20 03:32:07 EDT

How to reproduce
-----
I think thunderbird crashed after see Intrnet connection online, because almost every time my notebook get back from "sleep", wifi connected and after ~10 seconds TB crash.
Comment 33 Jeff Stampes 2010-04-21 11:38:58 EDT
I can confirm just about every mode of reproduction in this thread:

- I have 3 IMAP accounts.  If I click 'Get Mail' twice, it will crash every time
- I use a VPN to telecommute that (too) frequently disconnects me.  When that happens, Thunderbird crashes
- If I go offline in an attempt to avoid the VPN-related crash, it will crash when I go back online
- Just leave it running, it's bound to crash in under 30 minutes.

I'm in the process of installing all the missing debuginfo packages, and now that I know how to cause this, I can create backtraces for any of the above conditions on request.

This is making thunderbird unusable for me, forcing me to investigate other mail solutions.
Comment 34 Jeff Stampes 2010-04-21 11:50:54 EDT

How to reproduce
-----
1.I have 3 IMAP accounts.  If I click 'Get Mail' twice, it will crash every time
2.
3.


Comment
-----
This is likely a dup of 579023, but I wanted to submit via ABRT to ensure all neeeded information was included
Comment 35 kpvadm 2010-04-22 03:28:32 EDT

How to reproduce
-----
Now I noticed strange behaviour - really, if I press "Get Mail" button twice after notebook woke up ftom suspend - TB crash.
Comment 36 Felix Schwarz 2010-04-22 14:24:18 EDT

Comment
-----
check all accounts for new mail
Comment 37 Felix Schwarz 2010-04-22 14:29:54 EDT
actually I came across this bug again (after running an unpatched version for one day) - can you please commit my adapted patch (from the koji build above) soon?
Comment 38 Mike C 2010-04-26 05:05:17 EDT
Does anyone having this problem use Thunderbird 3.1b2 nightly?  I use that version and I have no problems at all - it is stable for many days at a time until I next install a new updated version.  Is this specific to TB 3.0?
Comment 39 Fedora Update System 2010-04-30 09:19:38 EDT
thunderbird-3.0.4-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/thunderbird-3.0.4-2.fc12
Comment 40 Fedora Update System 2010-04-30 09:20:02 EDT
thunderbird-3.0.4-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/thunderbird-3.0.4-2.fc11
Comment 41 Fedora Update System 2010-04-30 09:20:23 EDT
thunderbird-3.0.4-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/thunderbird-3.0.4-3.fc13
Comment 42 Jeff Stampes 2010-04-30 15:34:55 EDT
I've tried all the actions which caused the crashes to occur, and this update appears to resolve all the issues I was seeing.
Comment 43 Fedora Update System 2010-04-30 19:41:44 EDT
thunderbird-3.0.4-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update thunderbird'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/thunderbird-3.0.4-3.fc13
Comment 44 Fedora Update System 2010-05-03 12:02:17 EDT
thunderbird-3.0.4-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update thunderbird'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/thunderbird-3.0.4-2.fc11
Comment 45 Fedora Update System 2010-05-03 12:10:32 EDT
thunderbird-3.0.4-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update thunderbird'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/thunderbird-3.0.4-2.fc12
Comment 46 Matthieu Pupat 2010-05-03 17:24:49 EDT

Comment
-----
Double-clicked on a message to open it
Comment 47 Fedora Update System 2010-05-18 17:49:01 EDT
thunderbird-3.0.4-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 48 Fedora Update System 2010-05-18 17:53:37 EDT
thunderbird-3.0.4-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 49 Fedora Update System 2010-05-18 17:59:43 EDT
thunderbird-3.0.4-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 50 Jan Horak 2010-05-19 08:28:18 EDT
*** Bug 583610 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.