Bug 579521 - [abrt] crash in pipviewer-0.3.9-6.fc12: pkg_resources.py:524:resolve:DistributionNotFound: OpenGL>=2.0
Summary: [abrt] crash in pipviewer-0.3.9-6.fc12: pkg_resources.py:524:resolve:Distribu...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pipviewer
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:be05a0c3
Keywords:
: 601351 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-05 17:56 UTC by Knut J BJuland
Modified: 2010-07-06 17:17 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-07-06 17:05:37 UTC


Attachments (Terms of Use)
File: backtrace (1.09 KB, text/plain)
2010-04-05 17:56 UTC, Knut J BJuland
no flags Details

Description Knut J BJuland 2010-04-05 17:56:45 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/pipviewer
component: pipviewer
executable: /usr/bin/pipviewer
kernel: 2.6.32.7-37.fc12.x86_64
package: pipviewer-0.3.9-6.fc12
reason: pkg_resources.py:524:resolve:DistributionNotFound: OpenGL>=2.0
release: Fedora release 12 (Constantine)

backtrace
-----
pkg_resources.py:524:resolve:DistributionNotFound: OpenGL>=2.0

Traceback (most recent call last):
  File "/usr/bin/pipviewer", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2562, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 626, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
DistributionNotFound: OpenGL>=2.0

Local variables in innermost frame:
dist: None
to_activate: [pipviewer 0.3.9 (/usr/lib/python2.6/site-packages), vhybridize 0.5.9 (/usr/lib/python2.6/site-packages)]
req: Requirement.parse('OpenGL>=2.0')
requirements: []
processed: {Requirement.parse('pipviewer==0.3.9'): True, Requirement.parse('vhybridize>=0.5.9'): True}
env: <pkg_resources.Environment object at 0x7fa54a24b250>
installer: None
self: <pkg_resources.WorkingSet object at 0x7fa54a24b050>
best: {'opengl': None}

Comment 1 Knut J BJuland 2010-04-05 17:56:47 UTC
Created attachment 404526 [details]
File: backtrace

Comment 2 Alex Lancaster 2010-06-07 18:30:47 UTC
*** Bug 601351 has been marked as a duplicate of this bug. ***

Comment 3 Alex Lancaster 2010-06-07 18:32:56 UTC
Changing version, still present in F-13

Comment 4 Alex Lancaster 2010-06-07 18:43:05 UTC
The problem appears to be that the name of package is changed in PyOpenGL 3.0.0 

/usr/lib/python2.6/site-packages/pipviewer-0.3.9-py2.6.egg-info/requires.txt

lists:

OpenGL>=2.0

but /usr/lib/python2.6/site-packages/PyOpenGL-3.0.0-py2.6.egg-info

contains:

Metadata-Version: 1.0
Name: PyOpenGL
Version: 3.0.0

If I change "OpenGL>=2.0" to "PyOpenGL>2.0" in the egg info for pipviewer it works.

Comment 5 Alex Lancaster 2010-06-07 18:43:59 UTC
...or at least doesn't crash there, I now get:

USAGE: /usr/bin/pipviewer FILE
  where FILE is a .psel file

Comment 6 Fedora Update System 2010-06-24 16:45:57 UTC
pipviewer-0.3.9-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pipviewer-0.3.9-7.fc12

Comment 7 Fedora Update System 2010-06-24 16:46:03 UTC
pipviewer-0.3.9-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pipviewer-0.3.9-7.fc13

Comment 8 Fedora Update System 2010-06-25 18:09:00 UTC
pipviewer-0.3.9-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pipviewer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pipviewer-0.3.9-7.fc12

Comment 9 Fedora Update System 2010-06-25 18:20:28 UTC
pipviewer-0.3.9-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pipviewer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pipviewer-0.3.9-7.fc13

Comment 10 Fedora Update System 2010-07-06 17:05:32 UTC
pipviewer-0.3.9-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-07-06 17:17:51 UTC
pipviewer-0.3.9-7.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.