Bug 601351 - [abrt] crash in pipviewer-0.3.9-6.fc12: pkg_resources.py:546:resolve:DistributionNotFound: OpenGL>=2.0
[abrt] crash in pipviewer-0.3.9-6.fc12: pkg_resources.py:546:resolve:Distribu...
Status: CLOSED DUPLICATE of bug 579521
Product: Fedora
Classification: Fedora
Component: pipviewer (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
abrt_hash:ff44942f
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-07 14:26 EDT by Alex Lancaster
Modified: 2010-06-07 14:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 14:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.08 KB, text/plain)
2010-06-07 14:26 EDT, Alex Lancaster
no flags Details

  None (edit)
Description Alex Lancaster 2010-06-07 14:26:55 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/pipviewer
comment: Seems that pipviewer is missing some implicit deps
component: pipviewer
executable: /usr/bin/pipviewer
kernel: 2.6.33.3-85.fc13.x86_64
package: pipviewer-0.3.9-6.fc12
reason: pkg_resources.py:546:resolve:DistributionNotFound: OpenGL>=2.0
release: Fedora release 13 (Goddard)

backtrace
-----
pkg_resources.py:546:resolve:DistributionNotFound: OpenGL>=2.0

Traceback (most recent call last):
  File "/usr/bin/pipviewer", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
DistributionNotFound: OpenGL>=2.0

Local variables in innermost frame:
dist: None
to_activate: [pipviewer 0.3.9 (/usr/lib/python2.6/site-packages), vhybridize 0.5.9 (/usr/lib/python2.6/site-packages)]
req: Requirement.parse('OpenGL>=2.0')
requirements: []
processed: {Requirement.parse('pipviewer==0.3.9'): True, Requirement.parse('vhybridize>=0.5.9'): True}
env: <pkg_resources.Environment object at 0x7f5006202d10>
installer: None
self: <pkg_resources.WorkingSet object at 0x7f5006202810>
best: {'opengl': None}
replacement: True

How to reproduce
-----
1. yum install pipviewer

Installing:
 pipviewer                                          noarch                                         0.3.9-6.fc12   fedora                                         232 k
Installing for dependencies:
 PyOpenGL                                           noarch                                         3.0.0-2.fc12  fedora                                       815 k
 PyQt                                               x86_64                                         3.18.1-6.fc13                                          fedora                                         1.5 M
 freeglut                                           x86_64                                         2.6.0-3.fc13                                           fedora                                         172 k
 qt3                                                x86_64                                         3.3.8b-29.fc13                                         fedora                                         3.5 M
 vhybridize                                         noarch                                         0.5.9-4.fc12                                           fedora                                          87 k


2. pipviewer
Comment 1 Alex Lancaster 2010-06-07 14:26:59 EDT
Created attachment 421911 [details]
File: backtrace
Comment 2 Alex Lancaster 2010-06-07 14:30:47 EDT
abrt should have detected this as a dupe of bug #579521 (backtraces are almost identical), don't know why it didn't.

*** This bug has been marked as a duplicate of bug 579521 ***

Note You need to log in before you can comment on or make changes to this bug.