This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57980 - The ethereal binary is in the wrong package
The ethereal binary is in the wrong package
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ethereal (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-04 06:33 EST by bac
Modified: 2015-03-04 20:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 08:24:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bac 2002-01-04 06:33:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011014

Description of problem:
The ethereal binary is in the ethereal-gnome package instead of the
ethereal package.  This prevents ethereal from working at all without the
ethereal-gnome package installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install ethereal without ethereal-gnome.
2. Attempt to invoke ethereal.

Actual Results:  After consolehelper asks for the root password, nothing.

Expected Results:  Ethereal should have started.

Additional info:

This was previously reported as bug 55632, which was closed without
explanation.
Comment 1 Pekka Savola 2002-01-12 13:40:20 EST
Note that one could separate tethereal and other non-X11 stuff to some "base" package.
Comment 2 Phil Knirsch 2002-01-24 06:00:07 EST
Has been fixed in version 0.9.0-2 available via rawhide real soon now.

Read ya, Phil

*** This bug has been marked as a duplicate of 55632 ***
Comment 3 Jonathan Kamens 2002-01-31 23:20:40 EST
This doesn't seem "fixed" to me.  It appears that you "fixed" it by moving *all*
of the X ethereal binaries into ethereal-gnome, so that I can't run "ethereal"
by itself with just the "ethereal" package installed.  This is not a "fix".
Ethereal isn't a gnome program; I don't use gnome, and yet I should still be
able to run "ethereal" after installing just the "ethereal" package.

Perhaps the problem is that the ethereal-gnome package should be renamed
"ethereal-X" or something like that to make it clear that it contains binaries
for running ethereal under X, whether gnome or anything else.
Comment 4 Phil Knirsch 2002-02-01 06:58:20 EST
You can use ethereal without having to install the ethereal-gnome package. Just
start tethereal, thats the text-only version and is included in the ethereal
package.

If thats not what you want please be more specific.

Read ya, Phil
Comment 5 bac 2002-02-01 08:02:44 EST
The GTK+ ethereal program does not appear to require Gnome at all, and hence 
should not be in the ethereal-gnome package (especially as that would make its 
description wrong).  Of course, separate packages for tethereal and ethereal
would still be a good idea.
Comment 6 Phil Knirsch 2002-02-01 08:11:41 EST
Well, actually, it does at least require gtk:

[root@essingen tmp]# ldd /usr/sbin/ethereal 
        libsnmp.so.0 => /usr/lib/libsnmp.so.0 (0x40036000)
        libcrypto.so.3 => /lib/libcrypto.so.3 (0x4009c000)
        libpcap.so.0.6.2 => /usr/lib/libpcap.so.0.6.2 (0x40177000)
        libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x40192000)
        libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x402ec000)
        libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x40326000)
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x40329000)
        libdl.so.2 => /lib/libdl.so.2 (0x40350000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x40355000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4035d000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4036b000)
        libm.so.6 => /lib/i686/libm.so.6 (0x40431000)
        libz.so.1 => /usr/lib/libz.so.1 (0x40453000)
        libc.so.6 => /lib/i686/libc.so.6 (0x40461000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

So renaming the ethereal-gnome to ethereal-gtk is all you are asking about??? If
thats the case, i guess this can be done easily. :-)

Read ya, Phil
Comment 7 bac 2002-02-01 08:24:08 EST
No.  The ethereal-gnome package is for something else, as its description says:

"Contains ethereal icon for Gnome 1.2 and desktop integration file"
Comment 8 Phil Knirsch 2002-03-26 08:33:21 EST
Then basically the description for the ethereal-gnome package is wrong.
Separating ethereal and ethereal-gnome is a good thing(tm) as the base package
now has no more requirements whatsoever on any X11/gtk/gnome libs.

Changing description and closing bug now.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.