Bug 58000 - error in libpcap code (RH specific)
error in libpcap code (RH specific)
Status: CLOSED DUPLICATE of bug 53692
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2002-01-04 15:11 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-04 15:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-04 15:11:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
libpcap code in RH 7.2 seems to have an error.  In tcpdump you can see the
command: ./tcpdump -n -i eth0
...some data....
-2147415483 packets received by filter
-1073744432 packets dropped by kernel

This is in libpcap, not tcpdump AFAIK because other apps, such as argus
(http://www.qosient.com) linked against libpcap have no problem.  Also, I
RH libpcap and insatlled the version (made from source) from tcpdump.org
everything worked fine on argus. 

I reproduced the problem rebuilding tpcdump.src.rpm from scratch, so it's
not just
a binary issue...it's somewhere (probably) in the RH patches.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. See above.

Actual Results:  negative byte counts in output of tcpdump. libpcap

Expected Results:  negative byte counts don't make sense. should be

Additional info:

Note this isn't just an uninit int error...other applications linked
against RH libpcap
will not work from mysterious errors.  Once libpcap was replaced with the
from tcpdump.org, those errors go away.
Comment 1 Harald Hoyer 2002-01-07 05:36:40 EST

*** This bug has been marked as a duplicate of 53692 ***

Note You need to log in before you can comment on or make changes to this bug.