Bug 53692 - tcpdump packets printed/captured numbers negative
tcpdump packets printed/captured numbers negative
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 57004 58000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-15 08:05 EDT by Pekka Savola
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-07 05:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2001-09-15 08:05:17 EDT
kernel-2.4.7-10
tcpdump-3.6.2-9

Packets printed/captured counts seem to be pretty screwed up.

]# tcpdump -n 
tcpdump: listening on eth0
15:07:51.312993 802.1d config 8000.00:00:a2:ed:60:16.8003 root
8000.00:00:a2:ec:65:df pathcost 10 age 0 max 20 hello 2 fdelay 15 
15:07:53.312805 802.1d config 8000.00:00:a2:ed:60:16.8003 root
8000.00:00:a2:ec:65:df pathcost 10 age 0 max 20 hello 2 fdelay 15 
^C
-2147349966 packets received by filter
-1073744432 packets dropped by kernel
#

Any traffic that's printed seems to trigger the problem.  Before that,
counts are 0/0.

1073744432*2 == 2147488864
-2^31 == -2147483648

looks like an arithmetic overflow.
Comment 1 Pekka Savola 2001-09-15 08:17:08 EDT
New patch51 from #52654 seems to have broken this; leaving it out
fixes this problem. :-(

The libpcap-filter patch seems huge.  Is all this really necessary?  There have
been other
changes in CVS, and if you missed some implications of the new code, the results
might not be pretty (for any app using libpcap)..


Comment 2 Harald Hoyer 2001-12-18 10:31:47 EST
*** Bug 57004 has been marked as a duplicate of this bug. ***
Comment 3 Olivier Crête 2001-12-18 15:36:41 EST
The bug is present in Rh 7.2 too, not only in rawhide as this bug seems to imply.
Comment 4 Harald Hoyer 2002-01-07 05:36:35 EST
*** Bug 58000 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2002-01-17 10:26:03 EST
should be fixed in 3.6.2-10 or newer

Note You need to log in before you can comment on or make changes to this bug.