Bug 58023 - kernel make install does not understand use of grub
kernel make install does not understand use of grub
Status: CLOSED DUPLICATE of bug 53557
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-06 04:37 EST by Landon Curt Noll
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 13:56:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 2002-01-06 04:37:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.12 i686)

Description of problem:
The make install rule will fail on a system that uses grub (instead
of lilo) because the /sbin/installkernel command only groks lilo.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install the 2.4.9-13 kernel source from RH7.2 update on a host that uses
   grub and not lilo (i.e., there is no /etc/lilo.conf file, just
   /boot/grub/grub.conf)
2.make xconfig
3.make dep
4.make all
5.make install
	

Actual Results:  The make install fails because the lilo command from
/sbin/installkernel only attempts to run lilo.

Expected Results:  The grub-install for /dev/hda (or whatever the primary
boot device) is run.

Additional info:
Comment 1 Erik Troan 2002-05-21 19:06:14 EDT

*** This bug has been marked as a duplicate of 53557 ***

Note You need to log in before you can comment on or make changes to this bug.