Bug 580370 - Request for Upgrade to Wine 1.1.42
Summary: Request for Upgrade to Wine 1.1.42
Keywords:
Status: CLOSED DUPLICATE of bug 580024
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-08 05:51 UTC by Eli Wapniarski
Modified: 2010-04-11 17:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-11 17:28:14 UTC


Attachments (Terms of Use)

Description Eli Wapniarski 2010-04-08 05:51:26 UTC
Hi

I've noticed that there has been no update of wine since version 1.1.38 in koji. I've managed to make several modifications that enabled me to rebuild the wine rpm packages on an i386 architecture with version 1.1.42 and I have included the relevant files as attachments here with a links to the SRPM. I hope that this is helpful.


Link to the SRPM that I built
*****************************

http://orbsky.homelinux.org/packages/wine-1.1.42-1.fc12.src.rpm


Details
*******
Modified wine-rpath.patch line numbers so they look like...
-----------------------------------------------------------
@@ -6741,9 +6741,9 @@ 
@@ -6757,23 +6757,23 @@ 


Modified winepulse-0.35-configure.ac.patch
------------------------------------------
I had to apply the required modifications manually and create a new patch file becuase rebuilding the rpm with the previous diff produced an error indicating that something was wrong with the patch in relationship to 1.1.42.


Substituted in winepulse-0.36.patch
-----------------------------------
I had to do that because rebuilding with 0.35 produced a missing seperator error.

Modified the spec file
----------------------
I had to modify the spec file to include the build requirement of icoutils

I had to modify the spec file to substitute in winepulse-0.36.patch

I had to modify the spec file as indicated in the post at the winehq forum

http://forum.winehq.org/viewtopic.php?p=40732&sid=22366368ce7a60e95f7edb4310506b94

I had to include the following libraries:

/usr/libwine/attrib.exe.so                                                                                                                              
/usr/lib/wine/msvcr70.dll.so                                                            
/usr/lib/wine/msvcr80.dll.so                                                                 
/usr/lib/wine/msvcr90.dll.so                                                                 
/usr/lib/wine/ping.exe.so                                                                 
/usr/lib/wine/usbd.sys.so

Comment 1 Andreas Bierfert 2010-04-11 17:28:14 UTC

*** This bug has been marked as a duplicate of bug 580024 ***


Note You need to log in before you can comment on or make changes to this bug.