Bug 580024 - wine-1.1.44 is available
Summary: wine-1.1.44 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 570720 576607 577587 580073 580370 (view as bug list)
Depends On: 583501
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-07 10:20 UTC by Upstream Release Monitoring
Modified: 2010-07-23 06:34 UTC (History)
13 users (show)

Fixed In Version: wine-1.2.0-1.fc13
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-23 02:44:41 UTC


Attachments (Terms of Use)
wine-1.1.44-4.x86_64.fc13 failure (3.61 KB, text/plain)
2010-05-16 09:45 UTC, Benedikt Morbach
no flags Details
Requested output of "rpm -qa | grep wine" (767 bytes, text/plain)
2010-05-16 17:04 UTC, Benedikt Morbach
no flags Details

Description Upstream Release Monitoring 2010-04-07 10:20:11 UTC
Latest upstream release: 1.1.42
Current version in Fedora Rawhide: 1.1.38
URL: http://sourceforge.net/projects/wine/files/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 1 Andreas Bierfert 2010-04-11 17:27:37 UTC
*** Bug 580073 has been marked as a duplicate of this bug. ***

Comment 2 Andreas Bierfert 2010-04-11 17:28:14 UTC
*** Bug 580370 has been marked as a duplicate of this bug. ***

Comment 3 Gilboa Davara 2010-04-11 17:36:47 UTC
#580073 includes patches that were used to build .42.

- Gilboa

Comment 4 Upstream Release Monitoring 2010-04-18 10:18:21 UTC
Latest upstream release: 1.1.43
Current version in Fedora Rawhide: 1.1.38
URL: http://sourceforge.net/projects/wine/files/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 5 Andreas Bierfert 2010-04-19 15:47:51 UTC
*** Bug 577587 has been marked as a duplicate of this bug. ***

Comment 6 Andreas Bierfert 2010-04-19 15:48:50 UTC
*** Bug 576607 has been marked as a duplicate of this bug. ***

Comment 7 Andreas Bierfert 2010-04-19 15:49:04 UTC
*** Bug 570720 has been marked as a duplicate of this bug. ***

Comment 8 Upstream Release Monitoring 2010-05-08 10:38:43 UTC
Latest upstream release: 1.1.44
Current version in Fedora Rawhide: 1.1.38
URL: http://sourceforge.net/projects/wine/files/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 9 Fedora Update System 2010-05-10 20:50:10 UTC
wine-1.1.44-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wine-1.1.44-1.fc12

Comment 10 Fedora Update System 2010-05-10 21:01:28 UTC
wine-1.1.44-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/wine-1.1.44-1.fc13

Comment 11 Fedora Update System 2010-05-10 21:50:37 UTC
wine-1.1.44-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.1.44-1.fc13

Comment 12 Fedora Update System 2010-05-12 12:18:14 UTC
wine-1.1.44-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.1.44-2.fc13

Comment 13 Fedora Update System 2010-05-12 17:58:30 UTC
wine-1.1.44-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.1.44-2.fc12

Comment 14 Gilboa Davara 2010-05-13 06:27:18 UTC
Something seems to be broken with this update. Trying to entry the audio tab in winecfg results in a crash.
Looks like a pulse patch issue.

Should I open a second BZ?

- Gilboa

Comment 15 Andreas Bierfert 2010-05-13 09:24:43 UTC
This is already filled as #541986 and actually a wine upstream issue. Run wine32 winecfg. It has nothing to do with the pulse-support.

Comment 16 Gilboa Davara 2010-05-13 09:46:06 UTC
I stand corrected. Thanks for the update.

Comment 17 Fedora Update System 2010-05-13 19:31:48 UTC
wine-1.1.44-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.1.44-3.fc12

Comment 18 Fedora Update System 2010-05-13 19:35:00 UTC
wine-1.1.44-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.1.44-3.fc13

Comment 19 Fedora Update System 2010-05-15 20:37:10 UTC
wine-1.1.44-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.1.44-4.fc12

Comment 20 Fedora Update System 2010-05-15 20:38:20 UTC
wine-1.1.44-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.1.44-4.fc13

Comment 21 Benedikt Morbach 2010-05-16 09:43:55 UTC
The latest update does not work for me on F13.x86_64:

yum --enablerepo='*testing' update --changelog wine
<...full output in attachment...>
--> Processing Conflict: wine-1.1.44-4.fc13.x86_64 conflicts wine-wow(x86-32) = 1.1.44-4.fc13
--> Finished Dependency Resolution
Error: wine conflicts with wine-wow
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 22 Benedikt Morbach 2010-05-16 09:45:38 UTC
Created attachment 414331 [details]
wine-1.1.44-4.x86_64.fc13 failure

Comment 23 Andreas Bierfert 2010-05-16 12:42:30 UTC
There was a bug in the 1.1.44-1 to 1.1.44-3 which depending on your installation pulled in the wrong -wow package. What you see is a result of this. Either downgrade to .38 after that upgrading should work or resolve this manually. Interestingly you seem to have both wine(x86-32) and wine(x86-64) installed. Can you do a 'rpm -qa | grep wine' and post the results here... Thanks.

Comment 24 Benedikt Morbach 2010-05-16 17:04:23 UTC
Created attachment 414382 [details]
Requested output of "rpm -qa | grep wine"

Requested output of "rpm -qa | grep wine"

Yes, it seems i have wine.i686 installed. I think that is from when wine64 wasn't working for me and I wanted to play my games :)
Should I just do "yum erase wine*.i686" ? Do 32bit Applications work with newer wine64?

Comment 25 Andreas Bierfert 2010-05-16 18:33:02 UTC
First thanks for posting your output.

With the new wine packages you cannot have both 32bit and 64bit meta packages installed because they both pull in the relevant -wow package which conflict each other (this is actually the error you are seeing when trying to upgrade). What you can do is to do a 'yum remove wine(x86-32)' and afterwards the upgrade should run fine.

As to 32bit apps on 64bit (also of interest for other people): If you install the wine(x86-64) meta package everything is pulled in to allow wine to run 64bit and 32bit apps from the same wineprefix (usually ~/.wine). Sadly wine still does not do the dispatching of 32bit apps to the 32bit wine, so if you do 'wine run_some_32bit_app.exe' it won't delegate to wine32 and instead issue an error. You explicitly need to call wine32 for these tasks.

If you don't need to run 64bit apps you should remove all wine 64bit packages (or if you have a clean system install wine(x86-32)) and afterwards running 'wine run_some_32bit_app.exe' will work.

Just be careful with the wineprefix ~/.wine ... 32bit and 64bit prefixes cannot be mixed.

Comment 26 Fedora Update System 2010-06-01 18:15:11 UTC
wine-1.2.0-0.2.rc2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.2.rc2.fc13

Comment 27 Fedora Update System 2010-06-14 17:14:02 UTC
wine-1.2.0-0.3.rc3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.3.rc3.fc13

Comment 28 Fedora Update System 2010-06-21 21:27:15 UTC
wine-1.2.0-0.4.rc4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.4.rc4.fc13

Comment 29 Fedora Update System 2010-07-06 17:14:27 UTC
wine-1.2.0-0.6.rc6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.6.rc6.fc13

Comment 30 Fedora Update System 2010-07-13 07:55:01 UTC
wine-1.2.0-0.7.rc7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wine-1.2.0-0.7.rc7.fc13

Comment 31 Fedora Update System 2010-07-23 02:44:09 UTC
wine-1.2.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 32 Fedora Update System 2010-07-23 02:49:04 UTC
wine-1.2.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Gilboa Davara 2010-07-23 06:34:22 UTC
Thanks!


Note You need to log in before you can comment on or make changes to this bug.