Bug 580378 - Crash when no bootloader detected and upgrading a system
Crash when no bootloader detected and upgrading a system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 590823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-08 02:40 EDT by Amit Shah
Modified: 2010-05-24 15:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-14.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 09:59:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda dump 1 (120.00 KB, text/plain)
2010-04-09 00:58 EDT, Amit Shah
no flags Details
Anaconda dump 2 (120.91 KB, text/plain)
2010-04-09 00:59 EDT, Amit Shah
no flags Details

  None (edit)
Description Amit Shah 2010-04-08 02:40:58 EDT
Description of problem:

I had a partially-intalled copy of F13-beta on my h/d, no bootloader was installed.

Upon restarting installation in text mode, I chose 'upgrade'. It prompted me to skip bootloader configuration or install a new one. I chose the latter.

The installer then said there was a backtrace in 'bootloader' config.

All this is from the f13-beta-netboot.iso.
Comment 1 Amit Shah 2010-04-08 03:51:44 EDT
BTW I initially tried the same thing in the graphical interface and the crash box didn't come up there -- everything had just frozen. Switching VTs I poked around in a few log files and all had old timestamps, so obviously no progress was being made.

The crash doesn't happen immediately after the bootloader screen, it proceeds to the next 'active ethernet connection' screen, then says it'll fetch the repo information and this is when the crash happens.

Anaconda version is 13.37.2.
Comment 2 Radek Vykydal 2010-04-08 04:46:25 EDT
Can you please attach the traceback you are getting? You should be able to do it using error report dialog. If there is no dialog/traceback - e.g. just freeze in graphical UI case, you can go to VT2, find command starting "kill --USR2" in bash command history (using up arrow several times), run it, and the traceback will be dropped into /tmp/anaconda-tb* file.
Comment 3 Amit Shah 2010-04-08 09:16:04 EDT
I didn't see any way of getting a useful traceback then. As I mentioned, the GUI had just frozen but the text-mode install gave me an option to get to pdb, which didn't turn up useful info AFAIR.

Anyway I don't have that state of the install right now, but it's easily reproducible in the manner I've described.

If I do get into such a situation again, I'll post the trace.
Comment 4 Radek Vykydal 2010-04-08 09:35:40 EDT
(In reply to comment #0)
> Description of problem:
> 
> I had a partially-intalled copy of F13-beta on my h/d, no bootloader was
> installed.
> 

This condition can be pretty particular and hard to reproduce as "partially-installed" is too vague description. I'd need more specific steps to reproduce the issue, and preferably the traceback to be able to consider whether this is an issue to work on in the first place.
Comment 5 Amit Shah 2010-04-08 09:53:25 EDT
I was installing via the netboot.iso cd and had a network glitch during package installs (it was openoffice.org-core that was being installed at the time). Install seemed to have stalled. After several attempts to find out if things were proceeding (by checking for logs, downloaded rpms, etc.), I gave up and hit 'reboot' on VT2. I then proceeded to do an 'upgrade' via GUI, which got stuck again, so I re-tried upgrade using the text-mode install.

After that was done, I installed the remaining packages (kernel and grub, importantly) to get to a working system to continue from there.
Comment 6 Chris Lumens 2010-04-08 09:59:55 EDT
If you can reproduce, you can jump over to tty2 and scp /tmp/anaconda-tb-* off the system to attach to this bug report.
Comment 7 Amit Shah 2010-04-09 00:58:01 EDT
Well I just cloned an F11 VM, ran

dd if=/dev/zero of=/dev/sda1 bs=512 count=1

and ran the installer in the text mode, got the traceback.

Attaching the dumps.
Comment 8 Amit Shah 2010-04-09 00:58:34 EDT
Created attachment 405460 [details]
Anaconda dump 1
Comment 9 Amit Shah 2010-04-09 00:59:04 EDT
Created attachment 405461 [details]
Anaconda dump 2
Comment 10 Amit Shah 2010-04-09 01:04:49 EDT
BTW the GUI install had frozen in the VM as well, with no idication of a crash.
Comment 11 Chris Lumens 2010-04-09 14:49:20 EDT
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/text.py", line 597, in run
    (file, classNames) = stepToClasses[step]
  File "/usr/bin/anaconda", line 1188, in <module>
    anaconda.intf.run(anaconda)
KeyError: 'bootloader'
Comment 12 Chris Lumens 2010-04-12 17:07:00 EDT
Why are you using text mode for this?  Also I'm not really sure how valid a bug report this is given that your starting situation is a "partially installed copy of F13".
Comment 13 Amit Shah 2010-04-13 00:45:53 EDT
(In reply to comment #12)
> Why are you using text mode for this?

Because the graphical mode just freezes and doesn't even tell me there was a crash. I've mentioned this above.

>  Also I'm not really sure how valid a bug
> report this is given that your starting situation is a "partially installed
> copy of F13".    

I've also mentioned that this happens when I upgrade from F11 with grub removed.
Comment 14 Chris Lumens 2010-05-10 16:00:55 EDT
*** Bug 590823 has been marked as a duplicate of this bug. ***
Comment 15 James Laska 2010-05-10 16:45:03 EDT
Tested http://clumens.fedorapeople.org/updates.img and confirm that 'New bootloader configuration' is no longer an option in text-mode upgrades
Comment 16 David Lehman 2010-05-10 16:55:28 EDT
Given that this is specific to text mode, I do not think it qualifies as a blocker -- especially at this point in the schedule. There are too many other (better) ways to get this done.

Note You need to log in before you can comment on or make changes to this bug.