Bug 590823 - Text-mode upgrade fails when installing new bootloader -- KeyError: 'bootloader'
Summary: Text-mode upgrade fails when installing new bootloader -- KeyError: 'bootloader'
Status: CLOSED DUPLICATE of bug 580378
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F13Blocker, F13FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2010-05-10 18:48 UTC by James Laska
Modified: 2013-09-02 06:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 20:00:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Laska 2010-05-10 18:48:47 UTC
Description of problem:

Doing a Fedora 13 text-mode upgrade, and selecting to create a New bootloader configuration results in ...

anaconda 13.41 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/text.py", line 597, in run
    (file, classNames) = stepToClasses[step]
  File "/usr/bin/anaconda", line 1223, in <module>
    anaconda.intf.run(anaconda)
KeyError: 'bootloader'

Version-Release number of selected component (if applicable):
 * anaconda-13.41-1

How reproducible:
 * 100%

Steps to Reproduce:
1. Install Fedora 12
2. Start a text-mode install of Fedora 13
3. Choose to upgrade existing system
4. Select to create a new bootloader configuration
  
Actual results:


anaconda 13.41 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/text.py", line 597, in run
    (file, classNames) = stepToClasses[step]
  File "/usr/bin/anaconda", line 1223, in <module>
    anaconda.intf.run(anaconda)
KeyError: 'bootloader'

Expected results:

No traceback

Additional info:

 * see full traceback as attachment#412924 [details]

Comment 1 James Laska 2010-05-10 19:03:27 UTC
== Acceptable workarounds for this bug ==

 1. Do a graphical or VNC upgrade
 2. Choose to skip or update the existing bootloader configuration (anything but create a new one).

Comment 2 Chris Lumens 2010-05-10 20:00:55 UTC

*** This bug has been marked as a duplicate of bug 580378 ***


Note You need to log in before you can comment on or make changes to this bug.