Bug 5806 - Unable to set up SB128PCI (ES1371)
Unable to set up SB128PCI (ES1371)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 8376 8394 8787 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-10 11:48 EDT by dbergst
Modified: 2014-03-16 22:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 01:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
audio test result of my fedora one box (11.30 KB, text/plain)
2004-01-13 10:24 EST, Taehwan Bae
no flags Details
audio test result of my fedora one box (11.30 KB, text/plain)
2004-01-13 10:27 EST, Taehwan Bae
no flags Details

  None (edit)
Description dbergst 1999-10-10 11:48:17 EDT
The sndconfig utility hangs when it trys to play the test
sound.
Comment 1 Bill Nottingham 1999-10-11 10:31:59 EDT
Do you get the same behavior if you do:

modprobe es1370
play /usr/share/sndconfig/sample.au

from the command line?
Comment 2 dbergst 1999-10-11 21:25:59 EDT
Prior to posting this report, I had already attempted to run the
'modprobe es1370' command and the system returned:
"/lib/modules/2.2.10/misc/es1370.o: init_module: Device or resource
busy", presumably because the system has the 1371 chip, which the BIOS
reports.  No sounds whatsoever have been playable.  In case it is
helpful, I am also posting the lspci output for this card:


00:0d.0 Multimedia audio controller: Ensoniq ES1371 (rev 07)
Comment 3 Bill Nottingham 1999-10-18 13:43:59 EDT
Does it hang if you try to play a sound from the command line
after loading the es1371 module?
Comment 4 Bill Nottingham 1999-10-18 14:35:59 EDT
Never mind that; what does
'strace play /usr/share/sndconfig/sample.au' say?



------- Additional Comments From   10/19/99 19:14 -------
Please see email attachment, From dbergst@erols.com  Tue Oct 19
07:45:57 1999.
Comment 5 Bill Nottingham 1999-10-19 22:23:59 EDT
Hm... and 'play /usr/share/sounds/shutdown1.wav (or similar)
hangs as well?  What happens if you try the 2.2.12 kernel from
Raw Hide?
Comment 6 Bill Nottingham 1999-10-19 22:24:59 EDT
Also, are there any messages in the system logs?
Comment 7 dbergst 1999-10-20 07:40:59 EDT
Yes any command to play sounds hangs the system.  In addition, klogd
seems to hog the CPU whenever the es1371.o module is loaded.  From
/var/log/messages, here is the output from this morning's test:

Oct 20 07:30:59 soundman kernel: es1371: version v0.13 time 00:00:

Oct 20 07:30:59 soundman kernel: es1371: found adapter at io 0xe80
Oct 20 07:30:59 soundman kernel: es1371: features: joystick 0x0

This was with no special options in /etc/conf.modules, just did a
'modprobe es1371'.  From /var/log/dmesg the following message appears
numerous times:

snd: es1371: codec write timeout at 0xec14 [0x40000000]

I am downloading the kernel source RPM from rawhide for 2.2.12-20 and
will report back once it is installed, compiled, and retested for this
sound chip.
Comment 8 dbergst 1999-10-21 07:54:59 EDT
Due to some problems rebuilding using SRPM for kernel 2.2.12-20, used
the RPM's for the kernel sources and headers for the same version.
However, after compiling and installing the system, the behavior after
loading the es1371 module appears to be unchanged from what was
initially reported (system does not play audio files, klogd hogs CPU
at 97% until killed and restarted).  The only additional information I
can think of at this point is that two of these cards are installed
(PS - I have tried removing one of the cards previous to this test to
no avail).

uname -a
Linux soundman.drb.net 2.2.12-20 #1 Thu Oct 21 00:09:48 EDT 1999 i686
unknown

from dmesg:

es1371: version v0.13 time 00:21:58 Oct 21 1999
es1371: found adapter at io 0xe800 irq 5
es1371: features: joystick 0x0
es1371: codec vendor  revision 0
es1371: codec features none
es1371: stereo enhancement: no 3D stereo enhancement
es1371: found adapter at io 0xec00 irq 10
es1371: features: joystick 0x0
es1371: codec vendor  revision 0
es1371: codec features none
es1371: stereo enhancement: no 3D stereo enhancement
es1371: dma timed out??
es1371: dma timed out??
Comment 9 Bill Nottingham 1999-10-21 14:48:59 EDT
What do the numbers on top of the chip say?
(I've contacted the driver maintainer; there have been other reports
of this...)
Comment 10 dbergst 1999-10-21 20:11:59 EDT
These numbers appear on the surface of the main chip near the PCI
connector (bioth cards are identical):

CT5880-D8Q
9932H J5050A

Also, if it is any additional help, the model number of the card is
CT4750.
Comment 11 redhat-bugzilla 1999-12-09 10:48:59 EST
I'm having a similar problem; perhaps it's the same.
This is the (wrapped) output of
	strace -f play foo.au


[pid 12297] write(4,
"~}}}{{|}}|{z{}~~\177\200\201\202\202\202\201\200\200\200"..., 64) = 64
[pid 12297] write(4,
"\203\202\200\177\177\200\201\202\201\201\200\200\200\200"..., 64) = 64
[pid 12297] write(4,
"\177~\177\200\201\202\202\201\200\200\200\200\177}|{{{"..., 64) = 64
[pid 12297] write(4,
"\204\203\203\203\204\206\210\211\210\207\206\204\203\201"..., 64) = 64
[pid 12297] write(4,
"}|{{{||}~\177\177\177\177\177\177\177\177\200\200\201\202"..., 64) = 64
[pid 12297] close(3)                    = 0
[pid 12297] munmap(0x40014000, 4096)    = 0
[pid 12297] write(4, "\200\200\200", 3) = 3
[pid 12297] close(4

It hangs here, of course.
Comment 12 Nick Boehling 2000-01-18 01:46:59 EST
I have the same problem with the same card.  What is the status on this fix?
Comment 13 Bill Nottingham 2000-01-18 11:31:59 EST
Fixed in 2.2.15pre1 or greater kernel.
Comment 14 Bill Nottingham 2000-01-21 01:24:59 EST
*** Bug 8394 has been marked as a duplicate of this bug. ***
Comment 15 Bill Nottingham 2000-01-24 00:16:59 EST
*** Bug 8787 has been marked as a duplicate of this bug. ***
Comment 16 Bill Nottingham 2000-01-31 14:11:59 EST
*** Bug 8376 has been marked as a duplicate of this bug. ***
Comment 17 Bill Nottingham 2000-02-05 01:06:59 EST
A 2.2.15-pre based kernel will be in the next Raw Hide release.
Comment 18 redhat-bugzilla 2000-06-22 13:49:30 EDT
I verified that this works with the drivers included with Red Hat Linux 6.2.
Comment 19 Taehwan Bae 2004-01-13 10:24:20 EST
Created attachment 96945 [details]
audio test result of my fedora one box
Comment 20 Taehwan Bae 2004-01-13 10:27:45 EST
Created attachment 96946 [details]
audio test result of my fedora one box

1. The part of dmesg on es1371 is:

es1371: version v0.32 time 20:17:31 Jan  6 2004
es1371: found chip, vendor id 0x1274 device id 0x5880 revision 0x02
es1371: found es1371 rev 2 at io 0xb800 irq 9
es1371: features: joystick 0x0
ac97_codec: AC97 Audio codec, id: 0x8384:0x7608 (SigmaTel STAC9708)
[root@localhost root]#

2. When I tried to do the below, the result is attached for your reference.

#strace play /usr/share/sndconfig/sample.au 2> test.txt

3. What is the main problem on my linux box(Fedora Core 1)? Please give me your
advice.

Note You need to log in before you can comment on or make changes to this bug.