Bug 580702 - [Patch] Fix error on git submodules
Summary: [Patch] Fix error on git submodules
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: trac-git-plugin
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 602147 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-08 19:45 UTC by Tim Niemueller
Modified: 2013-01-10 05:49 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-06-24 03:40:36 UTC


Attachments (Terms of Use)
Patch to fix Trac git plugin when using submodules (624 bytes, patch)
2010-04-08 19:47 UTC, Tim Niemueller
no flags Details | Diff

Description Tim Niemueller 2010-04-08 19:45:51 UTC
Description of problem:
Currently when accessing the source browser when using the git plugin on a repository that uses submodules this causes the error "internal error (got unexpected object kind 'commit')".
The problem is easily fixed by simply ignoring the commit objects. The attached patch trivially fixes this.

Version-Release number of selected component (if applicable):
Any currently packaged version, as the patch is not in the upstream repository. That includes all Fedora and EPEL versions.

How reproducible:
Always


Steps to Reproduce:
1. Create Trac instance for git repository with submodule
2. Got to "Browse Source"
  
Actual results:
internal error (got unexpected object kind 'commit')

Expected results:
Should simply ignore the submodule commit.

Additional info:
The problem has been reported upstream at http://trac-hacks.org/ticket/3104 but there is not much activity and hence the patch should be applied to the package until this is fixed upstream to allow git repositories with submodules to work.

Comment 1 Tim Niemueller 2010-04-08 19:47:28 UTC
Created attachment 405390 [details]
Patch to fix Trac git plugin when using submodules

Comment 2 Tim Niemueller 2010-04-08 19:50:48 UTC
Just realized that the patch is for a newer version of the plugin that I build (0.11 branch). So this should apply to the Fedora packages. For EL-5 this might need modification as the patch is ~130 lines off (http://trac-hacks.org/browser/gitplugin/0.10/gitplugin/git_fs.py#L177). Still trivial...

Comment 3 Tim Niemueller 2011-04-21 22:16:18 UTC
Jesse, are you considering to apply this patch?

Comment 4 Jesse Keating 2011-04-21 22:33:46 UTC
oh I probably should.

Comment 5 Fedora Update System 2011-06-13 22:24:01 UTC
trac-git-plugin-0.11.0.2-7.20090511svn5396.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/trac-git-plugin-0.11.0.2-7.20090511svn5396.fc14

Comment 6 Fedora Update System 2011-06-13 22:31:30 UTC
trac-git-plugin-0.0.1-6.20090628svn3369.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/trac-git-plugin-0.0.1-6.20090628svn3369.el5

Comment 7 Fedora Update System 2011-06-15 05:42:01 UTC
Package trac-git-plugin-0.11.0.2-7.20090511svn5396.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing trac-git-plugin-0.11.0.2-7.20090511svn5396.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/trac-git-plugin-0.11.0.2-7.20090511svn5396.fc14
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-06-24 03:40:31 UTC
trac-git-plugin-0.11.0.2-7.20090511svn5396.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-07-01 16:53:51 UTC
trac-git-plugin-0.0.1-6.20090628svn3369.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Ferry Huberts 2011-07-02 08:44:59 UTC
*** Bug 602147 has been marked as a duplicate of this bug. ***

Comment 11 Ferry Huberts 2011-07-02 08:46:12 UTC
Tim, can you make sure that the git trac plugin on EPEL 6 works correctly with repos with submodules (I have no RHEL6 installs)

Comment 12 Tim Niemueller 2011-07-02 13:24:21 UTC
I currently have no RHEL 6 install either. I won't be before August that I get to do this.


Note You need to log in before you can comment on or make changes to this bug.